E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > 2006 e90 - Flickering i-Drive screen, now totally inoperable



Reply
 
Thread Tools Search this Thread
      01-03-2012, 02:12 AM   #1
huskercubfan
STM TRPR
 
Drives: 2012 335i MW
Join Date: Feb 2011
Location: Omaha, NE

Posts: 358
iTrader: (0)

please delete

[deleted.]

Last edited by huskercubfan; 05-14-2012 at 07:08 PM.
huskercubfan is offline  
0
Reply With Quote
      01-08-2012, 01:18 PM   #2
huskercubfan
STM TRPR
 
Drives: 2012 335i MW
Join Date: Feb 2011
Location: Omaha, NE

Posts: 358
iTrader: (0)

Anyone??
huskercubfan is offline  
0
Reply With Quote
      05-09-2012, 03:55 PM   #3
Eric_330i
Registered
 
Drives: 2006 330I, Loaded.
Join Date: Aug 2009
Location: San Jose

Posts: 3
iTrader: (0)

I see this is bit old, but did you ever figure it out? I had the same issue on the exact same car. Bad CCC. Cost me $1200 to replace at the dealership.
Eric_330i is offline  
0
Reply With Quote
      05-14-2012, 03:38 PM   #4
truckee_calvin
Registered
 
Drives: 2007 328i wagon
Join Date: May 2012
Location: United States

Posts: 1
iTrader: (0)

$1200 to replace CCC

Where did you go to replace your CCC for $1200? I"m being quoted $1500 at Mountain View BMW. Rip off!
truckee_calvin is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:18 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST