E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > I've got a problem, and I don't know what to do !



Reply
 
Thread Tools Search this Thread
      07-29-2013, 07:47 AM   #1
Mpy18
Lieutenant
 
Mpy18's Avatar
 
Drives: '06 325 XI
Join Date: Dec 2011
Location: Staten Island, NY

Posts: 561
iTrader: (4)

I've got a problem, and I don't know what to do !

So I got in my car this morning and drove it fine for a bit. Then I put it into manual mode, downshifted and then went to upshift, and it just wouldn't go !

Tried it again, shut the car off, etc, still doesn't work. Downshifts work fine, I can be in M6 and it will go all the way back down to M1. But it won't move up. It physically moves, but has no registered action. It has never had a problem, was even working fine last night. Today? No good. WTF?
Mpy18 is offline  
0
Reply With Quote
      07-29-2013, 10:15 AM   #2
JustROLLIN
Private
 
Drives: 2007 e90 328xi
Join Date: May 2013
Location: Mpls, MN

Posts: 60
iTrader: (0)

Could be the wiring in the shifter assembly. The wires are prone to breaking and maybe you just have one wire broken? Not really sure, just guessing here as its a common issue.
JustROLLIN is offline  
0
Reply With Quote
      07-29-2013, 12:19 PM   #3
mlifxs
Diamond Geezer
 
mlifxs's Avatar
 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

Posts: 1,356
iTrader: (0)

Garage List
agree wiring is possible issue. something similar happened to me, basically lost DS mode. there is a diy on the site somewhere that can help you diagnose. if it turns out to be wires, it's an easy fix you can do yourself
__________________
AA Stage 2 - M3 control Arms - BMW PS1 - APEX EC-7 -H&R front swaybar - GC street camber plates
mlifxs is offline  
0
Reply With Quote
      07-29-2013, 08:20 PM   #4
Mpy18
Lieutenant
 
Mpy18's Avatar
 
Drives: '06 325 XI
Join Date: Dec 2011
Location: Staten Island, NY

Posts: 561
iTrader: (4)

Yep it was the wires they were frayed from the assembly going left to right from ds-d mode. Soldered them up, heat shrunk them, and got them good to go. Back to normal again
Mpy18 is offline  
0
Reply With Quote
      07-30-2013, 12:27 PM   #5
mlifxs
Diamond Geezer
 
mlifxs's Avatar
 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

Posts: 1,356
iTrader: (0)

Garage List
Excellent! Much better than transmission repair.
__________________
AA Stage 2 - M3 control Arms - BMW PS1 - APEX EC-7 -H&R front swaybar - GC street camber plates
mlifxs is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:13 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST