E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > While updating software at dealer have codes 2A5F and 2F8A that won't clear. Anyone?



Reply
 
Thread Tools Search this Thread
      02-18-2013, 05:00 PM   #1
boostd92
Captain
 
Drives: '11 E92 M-Sport
Join Date: Jun 2009
Location: Chicago, IL

Posts: 669
iTrader: (1)

Garage List
While updating software at dealer have codes 2A5F and 2F8A that won't clear. Anyone?

I had my dealer update my software regarding the cold start surging and frequently stalling at low speed turns (sib 12.09.12).

I had codes 2F8a and 2a5f stored in my DME (no SES light on). The car programmed fine (Procede in map 0 mode), and those codes could not be cleared out (currently present).

2F8A in the N55 fault codes list is described as: voltage is present at the
DME input (E_U_IGN) although the overload protection relay for ignition and injection has switched off. (suggests replacing that relay if wiring is okay)

2A5F in the N55 fault codes list is described as: The diagnostic function monitors the wire for the injector voltage supply from the overload protection
relay for ignition and injection for short circuits to positive. (suggests replacing the relay if wiring is okay)

I think they both refer to the same relay. I didn't see either of these in the "normal codes for tuned cars" list for N55's.

Any else get these codes?
boostd92 is offline  
0
Reply With Quote
      02-19-2013, 12:41 PM   #2
boostd92
Captain
 
Drives: '11 E92 M-Sport
Join Date: Jun 2009
Location: Chicago, IL

Posts: 669
iTrader: (1)

Garage List
No one, eh?

I PM'd Robert @ Vishnu for his input, but as expected, no response yet.
boostd92 is offline  
0
Reply With Quote
      02-19-2013, 12:57 PM   #3
Slops
Major General
 
Slops's Avatar
 
Drives: 2005 C55 AMG
Join Date: Jan 2011
Location: Oxford

Posts: 5,360
iTrader: (2)

I've had those codes on my DME i think a while back when i was playing around with a potential DP fix for our cars...

The exact code was this...

2F8A - Ignition, voltage supply: Short circuit to B+ (The diagnostic function monitors the power supply wire providing voltage to the individual ignition coils from the overload-protection relay for ignition and injection, checking for open wires and shorts to ground)

These codes simply came up when the second O2 sensor was unplugged. It has nothing really to do with what the code suggests...

I tried to clear it using my procede at that time, but could not. So i used my trusty BMS CAN clear tool bought a couple years go and it cleared it right away. Then used the procede to reset the ECU and all was fine.

Try that and let us know.
Slops is offline   South Africa
0
Reply With Quote
      02-19-2013, 01:06 PM   #4
boostd92
Captain
 
Drives: '11 E92 M-Sport
Join Date: Jun 2009
Location: Chicago, IL

Posts: 669
iTrader: (1)

Garage List
Huh.. I have access to the shop at my dealership and we couldn't get the code to clear with BMW's programmer (ISTA). I'll try clearing the procede a few times over the next week and maybe it will clear out.

If that's all it is, it's probably tune related and I'll ignore it. Thanks for the reply!
boostd92 is offline  
0
Reply With Quote
      02-19-2013, 01:10 PM   #5
Slops
Major General
 
Slops's Avatar
 
Drives: 2005 C55 AMG
Join Date: Jan 2011
Location: Oxford

Posts: 5,360
iTrader: (2)

I know its weird... i thought it was weird that the procede wont clear it. Try to find a bms can clear tool and try that.
Slops is offline   South Africa
0
Reply With Quote
      02-22-2013, 04:40 AM   #6
VantageV8
Enlisted Member
 
Drives: E89 35i, E92 335i
Join Date: Oct 2009
Location: Vancouver

Posts: 35
iTrader: (0)

I have those codes, and they cannot be clear easily. My mechanic has cleared them by resetting a bunch of stuff.

It basically says the relay won't open even when the ignition has been shut off, and the voltage is constantly being sent to DME when it is not suppose to. I don't know if it is doing damage to our car, but it sure is a pain in the ass to look at on diagnostic screen.

We even went the extra mile by replacing the relays(two blue one inside the ECU box). The problem persisted.
VantageV8 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST