E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > DIY: N54 Injector Coding Via INPA



Reply
 
Thread Tools Search this Thread
      02-28-2012, 06:24 PM   #177
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by cn555ic View Post
I just started this download again...

http://quick99si3.home.comcast.net/~...02_Updated.rar

When I open it up I will take a screen shot for you of what I downloaded and unzipped.
Great! I'm redownloading it again as well trying to make sure I'm not crazy.

Update: This is all I'm seeing. No "ec-apps" folder


Last edited by FirstBMWLA; 02-28-2012 at 06:34 PM.
Appreciate 0
      02-28-2012, 06:37 PM   #178
Eracer76
Second Lieutenant
Eracer76's Avatar
United_States
6
Rep
239
Posts

 
Drives: 2008 E92 335xi
Join Date: Nov 2011
Location: IL

iTrader: (5)

Thanks for trying to help guys!
I'll check the FAQ's and see if there is anything that will help me also...
I'm using a MacBook on Lion, bootcamped running Windows 7 Home Premium, if that matters...
Here are some screen shots...
[IMG][/IMG]

__________________
Gone >2008 BMW 335xi E92: 11.988 @ 114.080 MPH
BMS JB4 G5, WW meth kit, OCC ~ Stett CAI ~ Helix FMIC ~ ER Charge Pipe w/Tial BOV ~AR Catless DP~ Aero Front Lip ~ BMS LED Angel Eyes ~ Black Kidney Grills ~ Painted Lower Grills
Painted Reflectors ~ Aluminum Pedals ~ 35% window tint ~ Painted Calipers/Rotors ~ KW V1 Coilovers ~ 19" Avant Garde M310's 235/35 & 275/30 G-Max AS-03 tires
Appreciate 0
      02-28-2012, 06:38 PM   #179
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Looks to me like your missing the ";" where you appended stuff to the path environment variable

I see: v1.0\C:\EDIABAS\bin

you need v1.0\;......

I think anyway
Appreciate 0
      02-28-2012, 07:00 PM   #180
Eracer76
Second Lieutenant
Eracer76's Avatar
United_States
6
Rep
239
Posts

 
Drives: 2008 E92 335xi
Join Date: Nov 2011
Location: IL

iTrader: (5)

Quote:
Originally Posted by FirstBMWLA View Post
Looks to me like your missing the ";" where you appended stuff to the path environment variable

I see: v1.0\C:\EDIABAS\bin

you need v1.0\;......

I think anyway
Your the MAN!! That worked!
I didn't see anywhere that that I was suppose to use that little ";"
I just added what I was suppose to according to the DIY, to what was already there

Now lets see what damage I can do!

But after reading about this more... is this even going to work with my 08 E92?
__________________
Gone >2008 BMW 335xi E92: 11.988 @ 114.080 MPH
BMS JB4 G5, WW meth kit, OCC ~ Stett CAI ~ Helix FMIC ~ ER Charge Pipe w/Tial BOV ~AR Catless DP~ Aero Front Lip ~ BMS LED Angel Eyes ~ Black Kidney Grills ~ Painted Lower Grills
Painted Reflectors ~ Aluminum Pedals ~ 35% window tint ~ Painted Calipers/Rotors ~ KW V1 Coilovers ~ 19" Avant Garde M310's 235/35 & 275/30 G-Max AS-03 tires
Appreciate 0
      02-28-2012, 07:00 PM   #181
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
Great! I'm redownloading it again as well trying to make sure I'm not crazy.

Update: This is all I'm seeing. No "ec-apps" folder

Bro I am so sorry I lead you the wrong link! It was the first link! lol

Download this one and follow my instructions! lol

http://quick99si3.home.comcast.net/~...6.4.3-full.rar

I was so burnt last week trying to get this to work that I was all over the place...Worked on this for like two weeks! Had to get my laptop working with NCS and had to obtain windows XPMODE by changing bios and shit


You also need to download DTlite to get the program working
__________________
917-939-4980 CODING E and F Series New York Area


Last edited by cn555ic; 02-28-2012 at 07:10 PM.
Appreciate 0
      02-28-2012, 07:06 PM   #182
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by Eracer76 View Post
Thanks for trying to help guys!
I'll check the FAQ's and see if there is anything that will help me also...
I'm using a MacBook on Lion, bootcamped running Windows 7 Home Premium, if that matters...
Here are some screen shots...
[IMG][/IMG]

check the line that says variable_value....after the V1.0 add ; instead of \

I told you a simple mistake will make you go nuts!
__________________
917-939-4980 CODING E and F Series New York Area


Last edited by cn555ic; 02-28-2012 at 07:38 PM.
Appreciate 0
      02-28-2012, 07:06 PM   #183
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
Great! I'm redownloading it again as well trying to make sure I'm not crazy.

Update: This is all I'm seeing. No "ec-apps" folder

Bro I am so sorry I lead you the wrong link! It was the first link! lol

Download this one and follow my instructions! lol

http://quick99si3.home.comcast.net/~...6.4.3-full.rar
I have that also.
That .rar gives me an entire .nrg cd image. Once I mounted that image there is all sorts of folders.
I still don't see "ec-apps" lol
Maybe I need revised instructions.
Appreciate 0
      02-28-2012, 07:25 PM   #184
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Brain freeze! Just first run the 6.4.3 with DTlite and mount the image...Do the complete install and then use the second folder and start BMW tool step one and its pretty much straightforward!!! Use those files in the C drive that was just created! I am sorry I forgot that it makes a backup copy for you after you finish the entire process! Wow Sorry man
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
      02-28-2012, 07:27 PM   #185
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
I have that also.
That .rar gives me an entire .nrg cd image. Once I mounted that image there is all sorts of folders.
I still don't see "ec-apps" lol
Maybe I need revised instructions.
Sorry read what I wrote! You will see that folder All said and done after the install...That ec-app file will appear later at the second folder! lol WOW I am dumb!

CleaR OUT ALL the inpa related stuff from your first install and then run 6.4.3 program...Once it does a complete install then move to the second update rar file where you see steps 1-3..run that then!
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
      02-28-2012, 07:31 PM   #186
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by cn555ic View Post
Sorry read what I wrote! You will see that folder All said and done after the install...That ec-app file will appear later at the second folder! lol WOW I am dumb!

CleaR OUT ALL the inpa related stuff from your first install and then run 6.4.3 program...Once it does a complete install then move to the second update rar file where you see steps 1-3..run that then!
So did you basically follow these instructions?
http://www.bimmerforums.co.uk/forum/...64bit-t103023/
I thought I had to follow this and had issues. Giving it another shot.
Appreciate 0
      02-28-2012, 07:35 PM   #187
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
So did you basically follow these instructions?
http://www.bimmerforums.co.uk/forum/...64bit-t103023/
I thought I had to follow this and had issues. Giving it another shot.
YEah man! I am so sorry for making you go crazy!

Gives you something to do tonight!

Thats what I did exactly to the T! Just make sure you delete the old inpa stuff from C drive before you start..6.4.3
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
      02-28-2012, 09:21 PM   #188
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by cn555ic View Post
YEah man! I am so sorry for making you go crazy!

Gives you something to do tonight!

Thats what I did exactly to the T! Just make sure you delete the old inpa stuff from C drive before you start..6.4.3
Ok......... Finally INPA seems to be working pretty well with no freezing etc. I can read OBDII statuses etc no problem.

After getting that straight I tried following the ncs_diy.pdf guide to try that app out. I followed it verbatim but not getting quite the results of guide. I'm thinking it's b/c my install folders in C: or pretty whacked now lol. I'm got an NCSEXPER and an NCSEXPER.$$$ all sorts of odd stuff.
I tried running from NCSEXPER folder from Vas DIY and I got further. I can now load the CAS and see my VIN along with FA(installed options). Program freezes when i hit F6(back) as instructions say though.
So question is, after all you've done or you able to run NCSEXPER also with no problems?

Last edited by FirstBMWLA; 02-28-2012 at 10:01 PM.
Appreciate 0
      02-28-2012, 10:12 PM   #189
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
Ok......... Finally INPA seems to be working pretty well with no freezing etc. I can read OBDII statuses etc no problem.

After getting that straight I tried following the ncs_diy.pdf guide to try that app out. I followed it verbatim but not getting quite the results of guide. I'm thinking it's b/c my install folders in C: or pretty whacked now lol. I'm got an NCSEXPER and an NCSEXPER.$$$ all sorts of odd stuff.
I tried running from NCSEXPER folder from Vas DIY and I got further. I can now load the CAS and see my VIN along with FA(installed options). Program freezes when i hit F6(back) as instructions say though.
So question is, after all you've done or you able to run NCSEXPER also with no problems?
Just delete that file NCS$$$ sign...I got that too.....use the NCSexper

Did you check the folder now? Do you see EC-apps folder? IF you see the zip folder you extracted, there should be ec-apps, ediabas and NCS folder....If so now delete all the files again on the C drive of iNPA related stuff and redoe it again with these new backup files of INPA, Ediabas, NCS and NFS. Take those 4 files and drag them to C drive and start the step 1-3 again...Thats what I did and mine is working fine....Make sure you take INPA and NFS out of EC-apps and make it individual files....
__________________
917-939-4980 CODING E and F Series New York Area


Last edited by cn555ic; 02-28-2012 at 10:18 PM.
Appreciate 0
      02-28-2012, 11:20 PM   #190
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,195
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
If either of those tools are freezing, than chances are there is a communication problem between the computer and the car.

Make sure you turn off all CAN hijacking, set all piggies to full bypass. Also, check the latency timer on the advanced settings on your COM port. Check to see if any other devices might have the same COM port. This can cause collisions.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      02-29-2012, 01:08 AM   #191
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by vasillalov View Post
If either of those tools are freezing, than chances are there is a communication problem between the computer and the car.

Make sure you turn off all CAN hijacking, set all piggies to full bypass. Also, check the latency timer on the advanced settings on your COM port. Check to see if any other devices might have the same COM port. This can cause collisions.
Hmm, maybe it is working. Is it normal to take quite a while to process ECU etc when reading out a trc file? I thought it was freezing up but given enough time it does complete and I do get the readouts.
Appreciate 0
      02-29-2012, 07:45 AM   #192
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by FirstBMWLA View Post
Hmm, maybe it is working. Is it normal to take quite a while to process ECU etc when reading out a trc file? I thought it was freezing up but given enough time it does complete and I do get the readouts.
Glad u got it working!
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
      02-29-2012, 08:24 AM   #193
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,195
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
oooh, reading the TRC file takes a bit, depending on how fast is your laptop.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      02-29-2012, 08:48 AM   #194
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by vasillalov View Post
oooh, reading the TRC file takes a bit, depending on how fast is your laptop.
It's pretty new laptop but reading out the large trc file that was backup of all modules I believe took quite a bit. Maybe 30+ seconds, not sure exactly.

When reading out just the KOMBI module it seemed a bit quicker maybe.
Wasn't brave enough to try any coding last night but I did read out the KOMBI module and found the BC_Digital thingy for digital speed in cluster.
Appreciate 0
      02-29-2012, 10:14 AM   #195
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,195
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by FirstBMWLA View Post
It's pretty new laptop but reading out the large trc file that was backup of all modules I believe took quite a bit. Maybe 30+ seconds, not sure exactly.

When reading out just the KOMBI module it seemed a bit quicker maybe.
Wasn't brave enough to try any coding last night but I did read out the KOMBI module and found the BC_Digital thingy for digital speed in cluster.
I've coded it in and also the efficient dynamics shift indicator. I found both of them super annoying so I coded them back out.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      02-29-2012, 10:16 AM   #196
FirstBMWLA
Captain
FirstBMWLA's Avatar
11
Rep
777
Posts

 
Drives: 2007 335i Coupe
Join Date: Oct 2007
Location: Tucson,AZ

iTrader: (10)

Quote:
Originally Posted by vasillalov
Quote:
Originally Posted by FirstBMWLA View Post
It's pretty new laptop but reading out the large trc file that was backup of all modules I believe took quite a bit. Maybe 30+ seconds, not sure exactly.

When reading out just the KOMBI module it seemed a bit quicker maybe.
Wasn't brave enough to try any coding last night but I did read out the KOMBI module and found the BC_Digital thingy for digital speed in cluster.
I've coded it in and also the efficient dynamics shift indicator. I found both of them super annoying so I coded them back out.
Is this speed display always visible or selectable just like miles to empty etc?
Appreciate 0
      02-29-2012, 10:47 AM   #197
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,195
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Quote:
Originally Posted by FirstBMWLA View Post
Is this speed display always visible or selectable just like miles to empty etc?
It was always visible on mine. I think some options can be made to be selectable depending on the model year.
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
      02-29-2012, 10:47 AM   #198
vasillalov
Mad Linux Guru On The Loose
vasillalov's Avatar
Bulgaria
84
Rep
4,195
Posts

 
Drives: 2008 335i Sedan
Join Date: Aug 2009
Location: Chicago, IL

iTrader: (3)

Garage List
2008 335i E90  [4.00]
Guys, again, we are heavily derailing this thread. All this stuff belongs in a new thread!
__________________
Equal Opportunity Harasser!
6MT | COBB | AR | AE | Forge DV | HPF | P3 Gauge | Hybrid Intake | O.S.Giken TCD | All M3 bits | TCKLine | StopTech
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST