E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Strange fault! Any suggestions?



Reply
 
Thread Tools Search this Thread
      02-11-2012, 08:27 AM   #1
Hotcoupe
Major General
Hotcoupe's Avatar
United Kingdom
70
Rep
6,105
Posts

 
Drives: Don't know yet!
Join Date: Jul 2007
Location: UK

iTrader: (2)

Garage List
Strange fault! Any suggestions?

My car (58 - 335D, 31,600 mls) has started to display some weird problems,and I wondered if anyone has experienced similar,or could offer some advice.

The problem seems to have started after a flat battery. (since sorted,and I don't think is related to this problem)

Since the battery problem was rectified the car occasionally loses power (quite dramatically) but quickly recovers (never stops).
On two occasions the engine has completely died with no warning lights displayed even when the car has come to a standstill.On both occasions the engine restarted and then behaved as normal.

Yesterday at the start of a 60ml roundtrip the EML light briefly flashed which was quickly followed by a loss of power, but the engine continued to run and I continued on my journey.

On reaching my destination,the engine again died without any warning lights appearing,but started again without drama.
On the return trip the car displayed the EML light which once again was followed by a loss in power,but I completed the journey and the car seemed fine for the remaining 10 odd miles.

The fault seems inconsistent, and does not appear to follow any pattern,so I'm curious to know what could cause the problem.

The red boost hose was replaced last Oct,and my mileage since has been very low,however I noticed last week when charging the battery that the hose is again covered in oil and there is fresh oil on the engine shield,so it is clearly leaking somewhere,and could be a pointer to the problem.

Any suggestions Chaps?
Appreciate 0
      02-11-2012, 09:09 AM   #2
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Take it to local dealer to get the frozen frames, which may have stored the codes of problem.
Or Any member from this forum having inpa can help you to save dealers diagnostic fee.
Appreciate 0
      02-11-2012, 09:15 AM   #3
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

Did you have a new battery fitted and coded from BMW? Your loss of power will be limp mode, backed up with your eml. You deffo need a diagnostic check by the sounds of it, I'd run it into a good Indy...
Appreciate 0
      02-11-2012, 09:17 AM   #4
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Quote:
Originally Posted by Mart1000 View Post
Did you have a new battery fitted and coded from BMW? Your loss of power will be limp mode, backed up with your eml. You deffo need a diagnostic check by the sounds of it, I'd run it into a good Indy...
Sorry my ignorance, but does the new battey requires coding ?
Never heard of it before.
Appreciate 0
      02-11-2012, 09:42 AM   #5
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

I'm pretty sure I've read on here that they do, I know my Audi A8 batt needed coding, like I said I'm sure I read here that BMW ones do too. I doubt that will be the cause though at all.
Appreciate 0
      02-11-2012, 09:43 AM   #6
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

http://www.e90post.com/forums/showthread.php?t=473109
Appreciate 0
      02-11-2012, 12:14 PM   #7
Hotcoupe
Major General
Hotcoupe's Avatar
United Kingdom
70
Rep
6,105
Posts

 
Drives: Don't know yet!
Join Date: Jul 2007
Location: UK

iTrader: (2)

Garage List
Quote:
Originally Posted by makkan00 View Post
Take it to local dealer to get the frozen frames, which may have stored the codes of problem.
Or Any member from this forum having inpa can help you to save dealers diagnostic fee.
Quote:
Originally Posted by Mart1000 View Post
Did you have a new battery fitted and coded from BMW? Your loss of power will be limp mode, backed up with your eml. You deffo need a diagnostic check by the sounds of it, I'd run it into a good Indy...
Cheers Guys, the battery is the original one and had become flat owing to lack of use,it was just recharged insitu.

I don't think the loss of power is limp mode as it's very,very brief and returns to normal within seconds.

I've been out in the car again today, and the car behaved normally even when pushed.

Weird!
Appreciate 0
      02-11-2012, 01:45 PM   #8
330i07
Enlisted Member
0
Rep
35
Posts

 
Drives: 330i sport
Join Date: Jan 2012
Location: Yorkshire

iTrader: (0)

You can't recharge E90 batteries.

When you have a new battery you don't code it to the car per se. You reset the battery "brain" if you will.

Get your codes read. Or find someone with a code reader and a DCAN cable.
Appreciate 0
      02-11-2012, 01:48 PM   #9
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Quote:
Originally Posted by Mart1000 View Post

Thanks mate. Weird, that we have to program the battery.

I wonder how much stealers charge for new battery and coding?
Appreciate 0
      02-11-2012, 01:56 PM   #10
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

No probs mate. Audi wanted a friggin fortune! I can only imagine BMW being the same.
Appreciate 0
      02-11-2012, 03:39 PM   #11
330i07
Enlisted Member
0
Rep
35
Posts

 
Drives: 330i sport
Join Date: Jan 2012
Location: Yorkshire

iTrader: (0)

It not coding, its resetting the battery brain.

Any independant will do it.

It is quite literally 3 minutes work and about 15 clicks of a mouse.
Appreciate 0
      02-11-2012, 03:48 PM   #12
dxb335d
The Tarmac Terrorist
dxb335d's Avatar
England
381
Rep
29,288
Posts

 
Drives: E46 M3 CS
Join Date: Mar 2007
Location: ''Fandango Towers''

iTrader: (3)

Garage List
Quote:
Originally Posted by Mart1000 View Post
Did you have a new battery fitted and coded from BMW? Your loss of power will be limp mode, backed up with your eml. You deffo need a diagnostic check by the sounds of it, I'd run it into a good Indy...
Ive had limp mode before, the car does not ''cut out'' or ''stop'' at all mate. Just reduced engine power.
__________________
M3 gone .... But I now have a M3 CS
Appreciate 0
      02-11-2012, 03:49 PM   #13
m1bjr
LSD - No, you're not seeing things
m1bjr's Avatar
United Kingdom
37
Rep
3,313
Posts

 
Drives: RS250 CUP
Join Date: Mar 2010
Location: Somerset UK

iTrader: (4)

Send a message via MSN to m1bjr
you don't need to do it unless the battery is different in capacity etc.

It's simply telling the computer what size it is, and so by measuring a few things it can have a good stab at estimating its performance
__________________
Appreciate 0
      02-11-2012, 05:33 PM   #14
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

Ta for the explanation. Wondered why a battery needed to be 'coded' tithe car.
Appreciate 0
      02-11-2012, 05:54 PM   #15
Giff
Lieutenant
Giff's Avatar
4
Rep
490
Posts

 
Drives: E90
Join Date: Jul 2010
Location: Wirral

iTrader: (2)

Quote:
Originally Posted by 330i07 View Post
It not coding, its resetting the battery brain.
That certainly conjured up an interesting image.
Appreciate 0
      02-11-2012, 06:09 PM   #16
m1bjr
LSD - No, you're not seeing things
m1bjr's Avatar
United Kingdom
37
Rep
3,313
Posts

 
Drives: RS250 CUP
Join Date: Mar 2010
Location: Somerset UK

iTrader: (4)

Send a message via MSN to m1bjr
Quote:
Originally Posted by Giff View Post
That certainly conjured up an interesting image.
+1

It must be female...
__________________
Appreciate 0
      02-11-2012, 06:41 PM   #17
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

Lol
Appreciate 0
      02-14-2012, 01:13 AM   #18
Dr Dave
Zummerzet Zyder Drinker!
Dr Dave's Avatar
United Kingdom
63
Rep
5,541
Posts

 
Drives: '06 330D Le Mans Blue
Join Date: May 2009
Location: Somerset

iTrader: (3)

Garage List
As has been said, get the fault codes read and take it from there. I expect it will be something turbo/actuation/control related.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST