E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Jb4 535i install help



Reply
 
Thread Tools Search this Thread
      02-12-2013, 11:11 AM   #1
08E60535iLCI
Enlisted Member
 
08E60535iLCI's Avatar
 
Drives: 08 535i
Join Date: Feb 2013
Location: Seattle

Posts: 48
iTrader: (0)

Jb4 535i install help

BIMMERPOST
     Featured on BIMMERPOST.com
Hey guys I got jb4 g5 iso last night installed

Upon driving went in to limp mode


I plugged it all in. Did not do any splicing as I saw on the video.
There was a red wire that I just taped up. Did not plug it in.

I will take it apart today and try again. Can someone write up how to do this and walk me through, thanks.
08E60535iLCI is offline  
0
Reply With Quote
      02-12-2013, 11:27 AM   #2
Quebequer
Private First Class
 
Drives: BMW
Join Date: Apr 2012
Location: Quebec, Canada

Posts: 140
iTrader: (0)

There you go : http://burgertuning.com/instructions/JB4PnP.pdf
__________________
2008 BMW 335xi MT e90
JB4 G5, WW meth kit, turbonetics intercooler, DCI, UR catted dp's, UR catback, koni yellow + H&R springs, Rieger front bumper, Avant Garde 19" wheels
Quebequer is offline   Canada
0
Reply With Quote
      02-13-2013, 01:36 PM   #3
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,320
iTrader: (86)

Quote:
Originally Posted by 08E60535iLCI View Post
Hey guys I got jb4 g5 iso last night installed

Upon driving went in to limp mode


I plugged it all in. Did not do any splicing as I saw on the video.
There was a red wire that I just taped up. Did not plug it in.

I will take it apart today and try again. Can someone write up how to do this and walk me through, thanks.
Was it the power wire that you did not install and just taped up?

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      02-13-2013, 04:12 PM   #4
Lankster
Sigma Alpha Epsilon
 
Drives: 2007 335xi
Join Date: Apr 2012
Location: Encinitas

Posts: 425
iTrader: (1)

I dont think the car actually starts without the power wire, i forgot to plug mine in once on an install and the car just kept tying to turn over... then again I'm a 335 n54
__________________
Forum Bible http://www.albinoblacksheep.com/flash/posting
JB4, BMS DCI, Dimisa 4" tips, VMR 710 Matt Black, Plasti-Dip Mod
Lankster is offline   United_States
0
Reply With Quote
      02-14-2013, 01:31 PM   #5
08E60535iLCI
Enlisted Member
 
08E60535iLCI's Avatar
 
Drives: 08 535i
Join Date: Feb 2013
Location: Seattle

Posts: 48
iTrader: (0)

Mike it was the power wire I taped up, the car did start without the power wire.

I somehow being excited at 10pm at night thought that was a step I dont do watching the video of the install on my iphone.

So the next day I took the car apart and hooked up the power wire to the green connector, closed it all back up.

Closed the hood and put it on map 5, went out for a drive and was like whoaaaa
then I got a warning fuel pump something something, it said you can drive the car but call the dealership.

I turned the car off, turned it back on, and it went away. Since then I have been driving like a mad man, and I was getting about 15 to 16lbs of boost.

Very easy install of the jb4 g5 and bms dci. Highly recommended.

Last night I had my brother with me in the 535 and ran my cousin in his stock 335. I was shocked how embarassingly the 535 pulled on him, from 40 to about 110 I had at least 6 or more cars on him.
08E60535iLCI is offline  
0
Reply With Quote
      02-14-2013, 01:42 PM   #6
PR3CI5N
need4speed
 
PR3CI5N's Avatar
 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

Posts: 1,155
iTrader: (15)

That red wire you speak of is very important. It goes into slot #2 on the green connector near the front of the DME box. Connect the female end you took out of slot #2 to the male end of the jb4 wiring harness.
__________________
N54
PR3CI5N is offline   United_States
0
Reply With Quote
      02-14-2013, 01:45 PM   #7
08E60535iLCI
Enlisted Member
 
08E60535iLCI's Avatar
 
Drives: 08 535i
Join Date: Feb 2013
Location: Seattle

Posts: 48
iTrader: (0)

Quote:
Originally Posted by PR3CI5N View Post
That red wire you speak of is very important. It goes into slot #2 on the green connector near the front of the DME box. Connect the female end you took out of slot #2 to the male end of the jb4 wiring harness.


Already done man, the car did start with the wire not connected, I was able to go through the maps with the steering wheel controls. I did get a CEL light though and engine malfunction, went in to limp mode.

The next morning I took it all apart again and connected the red wire, stupid of me trying to be in a hurry and get it all installed quick.

So far happy with the results, havent tried E85 yet. Might do 30% e85 and see how it feels.
08E60535iLCI is offline  
0
Reply With Quote
      02-14-2013, 02:01 PM   #8
PR3CI5N
need4speed
 
PR3CI5N's Avatar
 
Drives: 2010 E90 M 335i
Join Date: Jun 2010
Location: West Coast

Posts: 1,155
iTrader: (15)

Glad to hear it. Definitely add about 4-5 gallons of E-85 to a full tank. I personally don't like adding too much more because the car starts running too lean. Enjoy
__________________
N54
PR3CI5N is offline   United_States
0
Reply With Quote
      02-14-2013, 02:25 PM   #9
08E60535iLCI
Enlisted Member
 
08E60535iLCI's Avatar
 
Drives: 08 535i
Join Date: Feb 2013
Location: Seattle

Posts: 48
iTrader: (0)

Quote:
Originally Posted by PR3CI5N View Post
Glad to hear it. Definitely add about 4-5 gallons of E-85 to a full tank. I personally don't like adding too much more because the car starts running too lean. Enjoy
Thanks man, I dont want to stress the car too much now hehe.

She is my baby after all and I do drive my kids around in it sometimes, so gotta keep her in tip top shape. I think a few gallons of E85 to just experiment with it should be good enough for now.

I need to find a good deal on a charge pipe now.
08E60535iLCI is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:22 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST