E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Random stalling



Reply
 
Thread Tools Search this Thread
      03-02-2012, 01:42 PM   #1
GTOtoBMW
Private First Class
 
Drives: 2011 BMW 335i
Join Date: Sep 2011
Location: Bossier

Posts: 121
iTrader: (1)

Random stalling

2011 335i M6 PPK, just over 4000 miles

Ive noticed the car will randomly stall out on me when coming to a stop. Yes, my foot is on the clutch and (the times was paying attention to the car stalling) the brake too. The car does not stutter or buckle, it just shuts off as if I pressed the start/stop button. Ive filled up at different stations and always run 93 octane.


Ive also noticed some extended cranks, normally after driving the car and then restarting it 15-20 min later. This sounds like the HPFP but other than that I have no other issues that would point to the HPFP.


I do have an appointment with my local dealership for next friday but I wanted to see if anyone else had the same issue. I'm thinking they may not do anything if they cannot duplicate the problem.
GTOtoBMW is offline   Ireland
0
Reply With Quote
      03-02-2012, 04:37 PM   #2
Bavarian Tech
Captain
 
Drives: 335i
Join Date: Jan 2007
Location: Pittsburgh/Harrisburg

Posts: 630
iTrader: (8)

Garage List
2006 330i  [5.00]
Use your cell phone and record a video so you have proof when u go to the dealer.
__________________
335i Sport Sedan: 6Speed: Sport :Prem : CIC Swap : M3 Cluster
Bavarian Tech is offline  
0
Reply With Quote
      03-02-2012, 04:46 PM   #3
GTOtoBMW
Private First Class
 
Drives: 2011 BMW 335i
Join Date: Sep 2011
Location: Bossier

Posts: 121
iTrader: (1)

Quote:
Originally Posted by msbc721 View Post
Use your cell phone and record a video so you have proof when u go to the dealer.
Thing is I dont know when it is going to happen until right after it dies. Of all the driving I did today it only happened once, and yesterday was the same. The day before it happened 3 times in a row, and 3 more times throughout the day.
GTOtoBMW is offline   Ireland
0
Reply With Quote
      03-02-2012, 04:48 PM   #4
cable96
Private First Class
 
Drives: threethreefive
Join Date: Oct 2009
Location: USA

Posts: 187
iTrader: (5)

just keep on recording until you get it, id be pretty annoyed and sorta embarrassed if that happened on the street. RECORDDD
cable96 is offline  
0
Reply With Quote
      03-16-2012, 07:10 PM   #5
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

same here it happend to me too today. Stopped at the stop light and boom almost stalled. Got home waited in the garage for like 5 min and almost stalled again. e92 6 speed manual transmission and yes I was on brake in neutral. Thinking the fuel pump might be going but not sure. Could be many things I had my fuel pump replaced like 3 times already. Any one having this problem?

Just thought to go to the garage again and recorded it (AT IDLE STANDING STILL) ....got lucky to capture the car almost stalling while the engine is still warm

__________________

.../// TURBO! Why in the world would you choose anything else?... ///

Last edited by labedra; 03-16-2012 at 08:10 PM. Reason: Adding video
labedra is offline   United_States
0
Reply With Quote
      03-16-2012, 07:56 PM   #6
Nr!qUe
Captain
 
Nr!qUe's Avatar
 
Drives: 2009 E90 LCI 328i 6MT
Join Date: Nov 2008
Location: Miami, FL

Posts: 974
iTrader: (3)

Send a message via MSN to Nr!qUe Send a message via Skype™ to Nr!qUe
Ive had it happen to me too. Ive said it before. And this brings up the whole debate about whether or not coasting on a gear cuts off the fuel supply to the engine (which it totally does)

This is the situation that ive had it happen to me in.
Im coming to a stoplight and im coasting on third gear. Im like 7/8th of the way to a full stop and right before i come to a stop and i push the clutch in, baM, stall.. It didnt even sound like stall. Its more like the engine died quietly... This is becuase as you coast, since there is no fuel being supplied to the engine to this point pushing the clutch in is like making the car gasp for gas, the rpms drop too low before the fuel supply is able to start burning again...

Edit: this hasnt happened to me in a long time though, ive had this happen to me like 3 or 4 times in the lifetime of my car
__________________
2009 BMW E90 328i | Xenons | MT | Space Gray | Beige-ette | CF Fabric Trim | iPod/USB | 20% Tints | Euro-Plate | Rear Fog Switch Lego Mod | Painted Reflectors | Performance Short-shift Kit | Style 197 Wheels | OEM Sport Suspension | OEM Trunk Spoiler | Pioneer AVH4400BH -DVD
Nr!qUe is offline   United_States
0
Reply With Quote
      03-16-2012, 08:28 PM   #7
mashimarho
BMW Genius
 
mashimarho's Avatar
 
Drives: e92 LCI 335i xDrive™
Join Date: Mar 2010
Location: Grand Rapids, michigan

Posts: 8,843
iTrader: (33)

Garage List
Mine Just Did This Today Too!!!!

Not to mention that I sat in the garage and my car almost stalls while idling.
down n up down n up
__________________

Volk///ER///BMS///KW///VRSF///ARKYM///DD///CYBA///STOPTECH///BMW Performance ///
My Progress: http://www.e90post.com/forums/showthread.php?t=770326
mashimarho is offline   United_States
0
Reply With Quote
      03-16-2012, 10:46 PM   #8
str8clownr
Enlisted Member
 
Drives: 335coupe
Join Date: Feb 2012
Location: mia

Posts: 32
iTrader: (1)

manual 2011 e92 here too, same problem... what gives??? i am holding off on my downpipes install because of it, should i take it in?
str8clownr is offline  
0
Reply With Quote
      03-17-2012, 08:03 AM   #9
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,409
iTrader: (0)

This is still happening? I thought it was a done deal. I can tell you that with my car, starting in 10/09, it began stalling. It was impossible to duplicate until 4/10, so I put up with it over a 6 mo. period. It is not something the owner is imagining, nor will it go away on its own. It would be curious to see if it's only N54s i.e. 335is, or N55s as well. Someone on this thread has a 328, so that doesn't make a lot of sense either.
John 070 is offline  
0
Reply With Quote
      03-17-2012, 01:12 PM   #10
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

My car is 2008 335i E92, 6 speed manual transmission, only 22 K miles, ya I baby it,

My mods are:

* Burger Motor Sports single cone filter.
* Clutch Delay Valve delete
* VMR 701 19" GUNMETAL rims /w Hanhook tires

Not tunned.

So far the dealer replaced 1 fuel injector, 3 fuel pumps, wheel bearing and ABS sensor, and reprogrammed the ECU to latest codes. I was good for about 2K miles. The last repair was a fuel injector but I got codes that time when the injector was mis functioning. This time however no codes just started to almost stall yesterday.

Here is exactly what I'm noticing, When florred not noticable difference, car drives normal at normal driving, when I stop at a red light in neutral with foot off the clutch and brake pressed, the car randomly tries to stall. It doesn't happen all the time, but it happened 2 times while stopped at one red light.

In my opinion it could be the following:

1. Fuel pump about to go again (but no codes)
2. Some Fuel injector is at fault again (but no codes)
3. Fuel rail
4. ECU acting up
5. Bad gas with water in it

Could this be turbo related?
Don't know.

Also my warranty is about to expire in August........:/

Anyhow if anyone had this problem and successfully diagnoesd it please chime in.

Thanks!
__________________

.../// TURBO! Why in the world would you choose anything else?... ///

Last edited by labedra; 03-17-2012 at 01:23 PM.
labedra is offline   United_States
0
Reply With Quote
      03-17-2012, 01:53 PM   #11
cookiesowns
;)
 
cookiesowns's Avatar
 
Drives: 2010 E60 535i M-Sport
Join Date: Jan 2011
Location: Irvine, CA

Posts: 94
iTrader: (0)

Send a message via AIM to cookiesowns
For those with newer vehicles, it's called the BMW Auto Start stop feature. when you are coasting to a redlight, it will automatically shut down the engine to save fuel, there's also a button to disable it..

http://www.bmw.com/com/en/insights/t...tart_stop.html
cookiesowns is offline   Taiwan
0
Reply With Quote
      03-18-2012, 07:30 AM   #12
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,409
iTrader: (0)

Quote:
Originally Posted by cookiesowns View Post
For those with newer vehicles, it's called the BMW Auto Start stop feature. when you are coasting to a redlight, it will automatically shut down the engine to save fuel, there's also a button to disable it..

http://www.bmw.com/com/en/insights/t...tart_stop.html
That's on new 4 cyl. cars only. I don't think it applies to anyone on this thread. I'm just curious if this problem is still occuring.
John 070 is offline  
0
Reply With Quote
      03-18-2012, 10:57 AM   #13
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

Quote:
Originally Posted by cookiesowns View Post
For those with newer vehicles, it's called the BMW Auto Start stop feature. when you are coasting to a redlight, it will automatically shut down the engine to save fuel, there's also a button to disable it..

http://www.bmw.com/com/en/insights/t...tart_stop.html
Aaaaaaaaa NO. This is NOT a NEW feature as it has never been on my 2008 335i.....
__________________

.../// TURBO! Why in the world would you choose anything else?... ///
labedra is offline   United_States
0
Reply With Quote
      03-18-2012, 11:01 AM   #14
grandmoff
Private First Class
 
Drives: 2011 e92 335i M-Sport 6MT
Join Date: Jan 2011
Location: Atlanta

Posts: 144
iTrader: (1)

Happens to me all the time on my 2011 w/ 6MT especially in bad traffic. Pisses me off.
grandmoff is offline   United_States
0
Reply With Quote
      03-18-2012, 05:46 PM   #15
GTOtoBMW
Private First Class
 
Drives: 2011 BMW 335i
Join Date: Sep 2011
Location: Bossier

Posts: 121
iTrader: (1)

Well, I'm glad to know I'm not the only one having this problem. It has only happened once in a few hundred miles after I posted this. I removed my tune and it still happened, so threw it back on.

What I did notice was that it happened more often right after a few bursts of the throttle.
GTOtoBMW is offline   Ireland
0
Reply With Quote
      03-18-2012, 05:55 PM   #16
DriM3
Private
 
DriM3's Avatar
 
Drives: 2008 335i
Join Date: May 2011
Location: CT

Posts: 69
iTrader: (0)

mine hasnt stalled yet, but been damn near close to it. Its an automatic so theres no way its my fault. it happened twice today, once right after i turned it on this morning. it just wants to shut off but catches itself. Theres no way this is normal...
DriM3 is offline  
0
Reply With Quote
      03-19-2012, 09:29 PM   #17
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

Quote:
Originally Posted by GTOtoBMW View Post
Well, I'm glad to know I'm not the only one having this problem. It has only happened once in a few hundred miles after I posted this. I removed my tune and it still happened, so threw it back on.

What I did notice was that it happened more often right after a few bursts of the throttle.
Yep after a few burst of throttle or sprint driving on streets. So I drove today quite fast and had to come to like 4 complete stops in the middle and it happened again. I think it might actually be some sensor but I'll go to the dealer and check it out. Very weird....... Only happens at idle after sprint driving. When I had the HPFP go it happened right away never seen this before and I had the HPFP fail 3 times.
__________________

.../// TURBO! Why in the world would you choose anything else?... ///
labedra is offline   United_States
0
Reply With Quote
      03-19-2012, 09:33 PM   #18
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

Quote:
Originally Posted by DriM3 View Post
mine hasnt stalled yet, but been damn near close to it. Its an automatic so theres no way its my fault. it happened twice today, once right after i turned it on this morning. it just wants to shut off but catches itself. Theres no way this is normal...

Mine doesn't stall all the way as you see in my video, it just goes to like 400 RPM and then revs up to ~700 RPM but almost a stall.
__________________

.../// TURBO! Why in the world would you choose anything else?... ///
labedra is offline   United_States
0
Reply With Quote
      03-19-2012, 09:35 PM   #19
labedra
First Lieutenant
 
labedra's Avatar
 
Drives: 2008 BMW 335i E92 6 MT
Join Date: Jun 2009
Location: Somewhere on Planet Earth for now.

Posts: 303
iTrader: (2)

################################################## ##
All I Have To Say To Bmw Is That .....THIS IS BULL SHIT! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
################################################## ##

I had lots of shitty cars in my young years that I paid $200 for (NOT +50K) and didn't have so many problems as this POS!

Ya the ultimate driving machine.............when it runs! MALAKAS!
__________________

.../// TURBO! Why in the world would you choose anything else?... ///
labedra is offline   United_States
0
Reply With Quote
      03-20-2012, 12:05 AM   #20
hsleiman
First Lieutenant
 
hsleiman's Avatar
 
Drives: 11 e90 335xi PPK 6MT
Join Date: Apr 2009
Location: Morgantown, WV

Posts: 303
iTrader: (1)

Happened to me the other day too. 800 miles on a 2011 6MT with PPK1.
hsleiman is offline   Lebanon
0
Reply With Quote
      03-20-2012, 12:14 AM   #21
Speed6
Private First Class
 
Drives: 2012 E92
Join Date: Sep 2011
Location: Plano, TX

Posts: 106
iTrader: (1)

Sadly another victim here...

Just put on my JB4 too and it still happens. Definitely matches what some of you guys are describing, decelerating to a stop, the revs just drop too low. I happen to be stuck in traffic a lot so I can't pin point if having the clutch in or not makes a difference. Will try to test it out tomorrow during my commute though.

Seems like a pretty dumb problem to have...
__________________
1993 NSX
2013 Civic Si
Speed6 is offline   United_States
0
Reply With Quote
      03-20-2012, 09:04 AM   #22
GTOtoBMW
Private First Class
 
Drives: 2011 BMW 335i
Join Date: Sep 2011
Location: Bossier

Posts: 121
iTrader: (1)

Quote:
Originally Posted by Speed6 View Post
Sadly another victim here...

Just put on my JB4 too and it still happens. Definitely matches what some of you guys are describing, decelerating to a stop, the revs just drop too low. I happen to be stuck in traffic a lot so I can't pin point if having the clutch in or not makes a difference. Will try to test it out tomorrow during my commute though.

Seems like a pretty dumb problem to have...
I originally thought the opposite, as my tune was installed when the stalling was happening. Once I removed the tune it still stalled.
GTOtoBMW is offline   Ireland
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:19 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST