E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > N52 325i issue



Reply
 
Thread Tools Search this Thread
      07-16-2012, 12:50 PM   #1
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

N52 325i issue

Hey there

Sorry about the tittle but i have no ideea what to call it.
I have a 2006 325i vith services and everything done at time (not sure about the transmission fluid though). I noticed a thing that i don't know if it's normal or not, i never driven a e90 325 before this. Sometimes if i start from a traffic light for example and i push the trottle down it shoots like a bullet, sometimes it pickes up speed very slow imo. (i don't do drag or something but i like the feeling to be put in backrest, even if i go up to like 50kph). It happen also at bigger speeds and so on. Doesn't depend if engine is hot or cold, sometimes goes as it should even with cold engine sometimes it goes slower if i am in sport, so it's kinda random.

I checked my air filter today, looks spotless.
I hooked it up to autodata, no error codes at all.
Should i try to clean my MAF?
So anyone may have a sugestion or should i only live with the ideea.
Thanks in advance.
mAdTYzz is offline  
0
Reply With Quote
      07-16-2012, 01:57 PM   #2
Patmos330
Private
 
Patmos330's Avatar
 
Drives: 06 330I
Join Date: Jun 2012
Location: WA

Posts: 70
iTrader: (0)

Sounds like your traction nanny kicking in.
Patmos330 is offline  
0
Reply With Quote
      07-16-2012, 03:57 PM   #3
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

Ok, first i was thinking of it too, to be honest i didn't try with it off, but if it is so wouldn't it have to show something that it is kicking in? Just asking cause i am kinda newbie. I dunno it feels like i loose the power, not only at a "fresh start" sometimes also when i'm overtakeing. It really doesn't feel like it has "200"hp, even kicking it down.
But please don't take it like i say that your post is wrong, thank you.
mAdTYzz is offline  
0
Reply With Quote
      07-16-2012, 08:58 PM   #4
andrey_gta
Colonel
 
andrey_gta's Avatar
 
Drives: 130i coupé ;)
Join Date: Nov 2011
Location: Bimmerpost

Posts: 2,911
iTrader: (1)

Garage List
2008 BMW 128i  [0.00]
Is it a manual car?
I feel little sluggish at times, but think its related to the dual mass flywheel
__________________
128i Sport 6MT converted to Euro 130i spec, tuned by evolve ~220 whp 207 wtq(ft-lb) SAE
In-progress: e46 m3 trans mnt, e36M lip Wishlist: m3 susp, n55 eng mnt, headers, LSD, finn dif e60


"The 1-series is the last car that BMW engineered before the Germans, as a car-making culture, fell out of love with driving." - R&T 2013 135is
andrey_gta is offline   Canada
0
Reply With Quote
      07-16-2012, 11:14 PM   #5
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

No, it's automatic
mAdTYzz is offline  
0
Reply With Quote
      07-16-2012, 11:36 PM   #6
Patmos330
Private
 
Patmos330's Avatar
 
Drives: 06 330I
Join Date: Jun 2012
Location: WA

Posts: 70
iTrader: (0)

To be fair its less than 200 to the wheels afaik.
Patmos330 is offline  
0
Reply With Quote
      07-17-2012, 01:14 AM   #7
Malbolge
Major General
 
Malbolge's Avatar
 
Drives: TiAg Z4 Coupe 3.0Si
Join Date: Sep 2007
Location: EE

Posts: 5,226
iTrader: (1)

Garage List
isn't this first kick from Vanos? And if you feather throttle it won't be so pronounced? Unless I'm talking complete rubbish, someone correct me if I'm wrong. Op, I have 325i and it would definately shove you into the seat if you smash the pedal but it's not violent or anything. You can also have very smooth getaway if you drive it differently.

If you drive always the same then may be your gearbox needs software reset or oil change?
__________________
'07 TiAg BMW Z4 Coupe 3.0si / Everything
Malbolge is offline   Estonia
0
Reply With Quote
      07-17-2012, 02:38 AM   #8
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

Quote:
Originally Posted by Patmos330 View Post
To be fair its less than 200 to the wheels afaik.
I know it's less thats why
"200"
mAdTYzz is offline  
0
Reply With Quote
      07-17-2012, 02:46 AM   #9
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

Quote:
Originally Posted by research View Post
isn't this first kick from Vanos? And if you feather throttle it won't be so pronounced? Unless I'm talking complete rubbish, someone correct me if I'm wrong. Op, I have 325i and it would definately shove you into the seat if you smash the pedal but it's not violent or anything. You can also have very smooth getaway if you drive it differently.

If you drive always the same then may be your gearbox needs software reset or oil change?
Would't the vanos trow some error codes? later in the summer i plan to change the transmission oil. does the filter is with the oil pan? how do you reset the gearbox?
mAdTYzz is offline  
0
Reply With Quote
      07-17-2012, 02:57 AM   #10
Malbolge
Major General
 
Malbolge's Avatar
 
Drives: TiAg Z4 Coupe 3.0Si
Join Date: Sep 2007
Location: EE

Posts: 5,226
iTrader: (1)

Garage List
Quote:
Originally Posted by mAdTYzz View Post
Would't the vanos trow some error codes? later in the summer i plan to change the transmission oil. does the filter is with the oil pan? how do you reset the gearbox?
I think the kick from vanos is normal. it doesnt mean its broken. it should give this kick on start up. afaik.
__________________
'07 TiAg BMW Z4 Coupe 3.0si / Everything
Malbolge is offline   Estonia
0
Reply With Quote
      07-17-2012, 04:22 AM   #11
mAdTYzz
Private
 
Drives: 2006 E90 325i
Join Date: Jun 2012
Location: Sweden

Posts: 51
iTrader: (0)

Sorry to bother you but what do you mean by kick from vanos. and yeah sometimes at startup engine has to spin up a while before it starts, totally random.
mAdTYzz is offline  
0
Reply With Quote
      07-17-2012, 08:44 AM   #12
mikenazz
Enlisted Member
 
Drives: 325i e93
Join Date: Apr 2011
Location: Forestville Sydney

Posts: 43
iTrader: (0)

Try this out.
http://www.e90post.com/forums/showth...=gearbox+reset

might work
mikenazz is offline   Australia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:56 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST