E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > USA - NY / NJ / CT / PA > limp mode?



Reply
 
Thread Tools Search this Thread
      03-13-2012, 08:41 PM   #1
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
limp mode?

I lost engine power the other day. I get the check engine light in yellow. It does go away after i turn off the car and turn it back on. This wasn't the first time it happened. It happen once last month and once maybe a year ago. I was wondering if it is getting serious and if this is the "limp mode" i keep hearing you guys talk about. The thing is i drive a 328i and i thought this was because of the turbos on the 335. Any suggestions? I am just out of warranty btw.
Appreciate 0
      03-14-2012, 07:16 AM   #2
chiaobaby
First Lieutenant
chiaobaby's Avatar
United_States
3
Rep
317
Posts

 
Drives: 335i
Join Date: Jul 2009
Location: NYC

iTrader: (7)

had this when my low pressure fuel sensor was going bad.
Appreciate 0
      03-14-2012, 07:35 AM   #3
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by nelnelxd View Post
I lost engine power the other day. I get the check engine light in yellow. It does go away after i turn off the car and turn it back on. This wasn't the first time it happened. It happen once last month and once maybe a year ago. I was wondering if it is getting serious and if this is the "limp mode" i keep hearing you guys talk about. The thing is i drive a 328i and i thought this was because of the turbos on the 335. Any suggestions? I am just out of warranty btw.
find a shop/friend/forum member that can pull the codes from your car.
Limp modes can happen to all cars for several reasons.
Appreciate 0
      03-14-2012, 08:05 AM   #4
Alpine Whiteboy
Jerry's Fault...
Alpine Whiteboy's Avatar
117
Rep
9,259
Posts

 
Drives: 2013 535xi M-Sport SGM
Join Date: Sep 2009
Location: Queens, N.Y.

iTrader: (1)

Because racecar...
__________________
Boopie*Motorwerks

Martino*Auto*Concepts
Appreciate 0
      03-14-2012, 09:07 AM   #5
Genek335
Captain
Genek335's Avatar
United_States
15
Rep
929
Posts

 
Drives: 335
Join Date: Oct 2009
Location: East Coast

iTrader: (28)

yea, it can really be from anything. HPFP, Vanos, etc. I found that when my limp mode was intermittent; i would just come on during hard acceleration and go away after restart, it turned out to be my Vanos.
Appreciate 0
      03-15-2012, 04:48 PM   #6
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
Quote:
Originally Posted by Genek335 View Post
yea, it can really be from anything. HPFP, Vanos, etc. I found that when my limp mode was intermittent; i would just come on during hard acceleration and go away after restart, it turned out to be my Vanos.
Yeah this may be what happened here. I live right off a highway and to merge I do some hard acceleration. Its probably doesn't help that the car isn't really warmed up all that much either.
Appreciate 0
      03-15-2012, 05:01 PM   #7
TommyG@ColemanAutobody
First Lieutenant
TommyG@ColemanAutobody's Avatar
7
Rep
350
Posts

 
Drives: 2011 335i sedan 6MT
Join Date: Apr 2010
Location: Coleman Autobody

iTrader: (0)

I was out with my friend (S/A @ Open Road) this weekend and it went limp...my 335, that is! He took her in Monday and found it was the VANOS

535 loaner isn't bad but my car is missed dearly
Appreciate 0
      03-18-2012, 11:26 PM   #8
Genek335
Captain
Genek335's Avatar
United_States
15
Rep
929
Posts

 
Drives: 335
Join Date: Oct 2009
Location: East Coast

iTrader: (28)

Quote:
Originally Posted by nelnelxd View Post
Yeah this may be what happened here. I live right off a highway and to merge I do some hard acceleration. Its probably doesn't help that the car isn't really warmed up all that much either.
yea, BMW ,in the manual, has said it is better to drive the car without conventionally warming it up, but staying at a low rpm for a while until it heats up.
Appreciate 0
      03-19-2012, 12:39 PM   #9
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
so i went to auto zone for code reading and was told it was my spark plug in cylinder 4. does this mean it needs,to be replaced i mean the check engine isnt even on anymore.
Appreciate 0
      03-19-2012, 12:45 PM   #10
sA x sKy
Sameet
sA x sKy's Avatar
Bangladesh
36
Rep
1,752
Posts

 
Drives: 335xi '11 -> M4 '15
Join Date: Apr 2010
Location: Long Island, New York

iTrader: (2)

Quote:
Originally Posted by nelnelxd View Post
so i went to auto zone for code reading and was told it was my spark plug in cylinder 4. does this mean it needs,to be replaced i mean the check engine isnt even on anymore.
Depending on mileage, I would just replace all of them. They aren't that much anyway.
Appreciate 0
      03-19-2012, 12:48 PM   #11
hemi to e90
dat boost doe
hemi to e90's Avatar
Poland
17
Rep
1,552
Posts

 
Drives: 10 335i, 12 a8, 14 899, 10 zr1
Join Date: Aug 2005
Location: staten island

iTrader: (1)

Quote:
Originally Posted by Tommy g View Post
I was out with my friend (S/A @ Open Road) this weekend and it went limp...my 335, that is! He took her in Monday and found it was the VANOS

535 loaner isn't bad but my car is missed dearly
u got a 535i loaner? wtf? i always get 328xi's. all i want out of a loaner is navi......
__________________
Appreciate 0
      03-19-2012, 03:03 PM   #12
TommyG@ColemanAutobody
First Lieutenant
TommyG@ColemanAutobody's Avatar
7
Rep
350
Posts

 
Drives: 2011 335i sedan 6MT
Join Date: Apr 2010
Location: Coleman Autobody

iTrader: (0)

Quote:
Originally Posted by hemi to e90 View Post
u got a 535i loaner? wtf? i always get 328xi's. all i want out of a loaner is navi......
I have connections
Appreciate 0
      03-22-2012, 12:21 PM   #13
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
Quote:
Originally Posted by PeterM1 View Post
find a shop/friend/forum member that can pull the codes from your car.
Limp modes can happen to all cars for several reasons.
scans at auto zone said it was a misfire in cylinder 4. The check engine only appeared after i felt engine cut power. I turned it it off/ back on and its gone. Since it shows in my scans does this mean I am still misfiring right now or is it just when it cut power to my engine? If I change the spark plug and that was the problem will it no longer appear in the scans?
Appreciate 0
      03-22-2012, 01:30 PM   #14
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

it will indefinitely stay there until it's cleared via a BT/GT1 or other tool. Wherever you go to have your plugs replaced, ask them to clear your codes too.
Appreciate 0
      03-22-2012, 05:09 PM   #15
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
Quote:
Originally Posted by PeterM1 View Post
it will indefinitely stay there until it's cleared via a BT/GT1 or other tool. Wherever you go to have your plugs replaced, ask them to clear your codes too.
Well I was planning to do it myself. DIY didn't seem to bad. If autozone used a BT/GT1 or other tool to read the codes they can also clear is as well right? Or is it only specific ones that can do so? Also if my car is still misfiring would my check engine light remain on because its not even on anymore.
Appreciate 0
      03-22-2012, 05:34 PM   #16
AddictedToBavarian
My other ride is a Bianchi Infinito
AddictedToBavarian's Avatar
Portugal
38
Rep
2,762
Posts

 
Drives: Miss my E92 but love my E46 M3
Join Date: Apr 2011
Location: North Jersey

iTrader: (2)

Mine went limp once.... but that's because I drank way too much that night.
Appreciate 0
      03-23-2012, 10:30 AM   #17
mid-corner fun
Major
United_States
15
Rep
1,418
Posts

 
Drives: e92
Join Date: Jun 2005
Location: NE

iTrader: (4)

Quote:
Originally Posted by nelnelxd View Post
Well I was planning to do it myself. DIY didn't seem to bad. If autozone used a BT/GT1 or other tool to read the codes they can also clear is as well right? Or is it only specific ones that can do so? Also if my car is still misfiring would my check engine light remain on because its not even on anymore.
Not sure if autozone's policy is to read only or read and clear, ask them. If that doesn't work offer someone with a BT cable a beer and they'll do it on the spot :-)
Appreciate 0
      03-23-2012, 12:20 PM   #18
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
thanks i just ordered a cheap,code reader on amazon just in case and for future use. gonna try the diy when i get it.
Appreciate 0
      03-23-2012, 11:57 PM   #19
BoogeyMan'sBMW
Major
BoogeyMan'sBMW's Avatar
Bangladesh
18
Rep
1,380
Posts

 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

iTrader: (3)

i had a similar problem with my 330i right before a misfire how many miles on the odo?

i had my spark plugs changed and its been fine since *knock on wood*
Appreciate 0
      03-26-2012, 12:31 PM   #20
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
54000 on mine
Appreciate 0
      04-07-2012, 02:50 PM   #21
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
I just changed my spark plus with ngk but now the car has some random shaking when I am at a standstill. Anyone know what I did wrong?
Appreciate 0
      04-07-2012, 02:58 PM   #22
nelnelxd
Second Lieutenant
United_States
6
Rep
210
Posts

 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

iTrader: (0)

Send a message via AIM to nelnelxd
I used ngk LRF6AIX-11 plugs and torqued to 17 lbs
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST