E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Waterpump? - Help with a few codes P2e81, H2a16, H2e97 & P2DED



Reply
 
Thread Tools Search this Thread
      05-23-2012, 05:36 PM   #1
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Waterpump? - Help with a few codes P2e81, H2a16, H2e97 & P2DED

Hey guys.. I researched each code separately but now i'm thinking it may not be the water pump.


This is for my 2007 328xi

Its been raining the past 2 days but the car was driving fine.
Today, I drive my 2 kids to the medicenter and as i'm turning right the gas pedal doesnt do anything. I let off.. and press.. it revs up a bit but doesnt move.
I wait a second or 2 and try again. It rev'd up but there wasn't much power and I then get a Yellow coolant light followed quickly by a red coolant light and it goes in limp mode. I pull over and get the car towed back home. I take the Cobb from my 335 and check the codes on the 328. I get the following codes:

2e81 - waterpump malfunction
2a16
2e97
2DED


At first I thought it was my water pump.. but before I order one.. Does anyone have any suggestions? its an 07 328xi with 180,000 km (110ish miles)
__________________

Last edited by Dr. Anthony; 05-23-2012 at 07:38 PM.
Dr. Anthony is offline   Canada
0
Reply With Quote
      05-23-2012, 09:29 PM   #2
sisspc
New Member
 
Drives: 2006 330i
Join Date: Jan 2012
Location: Between Jack Daniels and Bonnaroo

Posts: 22
iTrader: (0)

Hate to tell you but that's definitely your water pump.
sisspc is offline  
0
Reply With Quote
      05-23-2012, 09:59 PM   #3
E90cruisin
First Lieutenant
 
Drives: 330i
Join Date: Jan 2011
Location: Florida

Posts: 313
iTrader: (8)

How many miles do you have?
E90cruisin is offline  
0
Reply With Quote
      05-24-2012, 11:46 AM   #4
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

Hmm.. The other codes are interesting. You have a small evap leak and 2 electrical system faults. One with the battery the other with the alternator. Your water pump code is specifically a speed deviation which might be caused by your electrical system issues. It might not be your water pump as you said. Find out what caused those last 2 error codes and see if that might have caused the pump to slow. Not sure about the evap system though.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      05-24-2012, 03:15 PM   #5
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Quote:
Originally Posted by sisspc View Post
Hate to tell you but that's definitely your water pump.
Thats what I was thinking too at first but then the other 3 codes came up. At first only the 1st 3 codes came up, and then later on in the day when I checked it for codes the 4th (2DED) came up. I just don't want to replace the pump if its a different issue.

Quote:
Originally Posted by E90cruisin View Post
How many miles do you have?
around 110,000k miles. (180,000 km)

Quote:
Originally Posted by e90pilot View Post
Hmm.. The other codes are interesting. You have a small evap leak and 2 electrical system faults. One with the battery the other with the alternator. Your water pump code is specifically a speed deviation which might be caused by your electrical system issues. It might not be your water pump as you said. Find out what caused those last 2 error codes and see if that might have caused the pump to slow. Not sure about the evap system though.

Thats what I'd like to know too. I just don't know where to start. If I take it to the dealer they'll replace my water pump, alternator and battery and say "it could be other things but we won't know until we replace these"
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
      05-24-2012, 04:17 PM   #6
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

You need to find out what causes each of the codes. The pump speed deviation is easy. Whenever the actual speed doesn't match the commanded speed you get the error. The last 2 I'm not sure. It just says "alternator" or "battery" in the description. The dealer should be able to tell you or an indy shop.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      05-24-2012, 05:32 PM   #7
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,095
iTrader: (3)

Did some digging for you:
2e97 - From what I gather, this means your alternator is not charging your battery. It could be a faulty alternator or faulty battery.
2ded - This error occurs when the battery is draining more that it should at a given moment (e.g. when the car is off). Aftermarket radios or other components that tap into the car's electrical supply will cause this if they are not hooked up to a switched power source.
2e81 - We talked about this one but the car will store freeze frame information about this fault. One of them is water pump voltage. It should be ~14V.

A dealer or indy shop can run an electrical diagnostic for you to see where the problem is occurring. I'm almost certain this is causing your water pump issue. Then again I'm not a mechanic/tech so I could very well be wrong.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      05-24-2012, 05:47 PM   #8
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Quote:
Originally Posted by e90pilot View Post
Did some digging for you:
2e97 - From what I gather, this means your alternator is not charging your battery. It could be a faulty alternator or faulty battery.
2ded - This error occurs when the battery is draining more that it should at a given moment (e.g. when the car is off). Aftermarket radios or other components that tap into the car's electrical supply will cause this if they are not hooked up to a switched power source.
2e81 - We talked about this one but the car will store freeze frame information about this fault. One of them is water pump voltage. It should be ~14V.

A dealer or indy shop can run an electrical diagnostic for you to see where the problem is occurring. I'm almost certain this is causing your water pump issue. Then again I'm not a mechanic/tech so I could very well be wrong.
You're awesome! Thanks!

I called up a service adviser I know at the dealer here. I gave him the codes to see if he can check with a tech on what he thought it could be.

I ended up ordering a water pump but I'm hoping I don't have to replace it.
Now that I think of it, my alternator does whine a bit. I suppose I could always remove it and bring it into a shop to have them test it. Or, at the end of the day, just tow the car to the dealer and have them diagnose the elec. issue.

I really do appreciate your help in looking into it for me. I've been searching allover and can't really find the correlation between all the codes. The only thing I could think of was bad alternator or some other electrical issue.
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
      05-25-2012, 10:51 AM   #9
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

I ordered a new water pump. I'm going to give that a try and see.
I'm fairly sure that the previous owner didn't replace the pump. I'm thinking the other codes may have come as a result of a short in the water pump.

I'll reply on this thread so anyone else searching can find the answer.
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
      06-07-2012, 09:10 PM   #10
omerfar23
First Lieutenant
 
Drives: 2008 E92 335i, 2014 Corolla LE
Join Date: May 2007
Location: Baltimore, MD

Posts: 355
iTrader: (0)

Quote:
Originally Posted by Dr. Anthony View Post
I ordered a new water pump. I'm going to give that a try and see.
I'm fairly sure that the previous owner didn't replace the pump. I'm thinking the other codes may have come as a result of a short in the water pump.

I'll reply on this thread so anyone else searching can find the answer.
So did a water pump fix your issues? btw which code reader do you have?
__________________
********** 2008 BMW 335i TT******
omerfar23 is offline   United_States
0
Reply With Quote
      06-07-2012, 11:36 PM   #11
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Quote:
Originally Posted by omerfar23 View Post
So did a water pump fix your issues? btw which code reader do you have?
Yup, waterpump fixed it. I figured the pump's electronics were being shorted by the coolant.

as far as a scanner goes, I used my COBB accessport from my 335
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
      06-08-2012, 08:51 AM   #12
sisspc
New Member
 
Drives: 2006 330i
Join Date: Jan 2012
Location: Between Jack Daniels and Bonnaroo

Posts: 22
iTrader: (0)

Quote:
Originally Posted by Dr. Anthony View Post
Yup, waterpump fixed it. I figured the pump's electronics were being shorted by the coolant.

as far as a scanner goes, I used my COBB accessport from my 335
Glad that fixed it. For the sake of clarity, did you also replace the thermostat?
sisspc is offline  
0
Reply With Quote
      06-08-2012, 01:46 PM   #13
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Quote:
Originally Posted by sisspc View Post
Glad that fixed it. For the sake of clarity, did you also replace the thermostat?
I did. you don't *have* to, but you're doing all that work twice if you dont.

Also, you don't *need* to buy new bolts. The old bolts have blue dots on it indicating they cant be reused, but the new bolts are identical but without the blue dot.
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
      06-08-2012, 05:18 PM   #14
just4kickz
boku no namae ha...
 
Drives: 2006 BS 330i
Join Date: Feb 2006
Location: S. Bay Area, CA + Newark, NJ + ChiCity + True Blue

Posts: 11,038
iTrader: (11)

Garage List
2006 E90 330i  [0.00]
OP, what's your mileage? this waterpump thing kinda blows. i wish there was a warning so you could do it before you're stranded.
__________________
looking for a PreLCI Black Sapphire e90 front bumper without license plate holes

"Akimbo shotguns. Broken wrists anyone? And don't give me that 'it's just a game' bull****. Where the **** are my akimbo interventions then?! One scope on each eye mother****er!!"
just4kickz is offline   United_States
0
Reply With Quote
      06-09-2012, 12:16 AM   #15
Dr. Anthony
First Lieutenant
 
Dr. Anthony's Avatar
 
Drives: 2009 E90 M3, 2008 535xi Msport
Join Date: Aug 2009
Location: Edmonton

Posts: 369
iTrader: (6)

Quote:
Originally Posted by just4kickz View Post
OP, what's your mileage? this waterpump thing kinda blows. i wish there was a warning so you could do it before you're stranded.
182,000 km (113,000 miles)
__________________
Dr. Anthony is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:51 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST