E90Post
 


ProTUNING Freaks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > 11 335xi jerky auto shifts...? Help....



Reply
 
Thread Tools Search this Thread
      03-13-2012, 11:25 PM   #1
antrot
Private First Class
Canada
3
Rep
182
Posts

Drives: 11 335i sedan
Join Date: Mar 2009
Location: Toronto/Vaughan

iTrader: (0)

Question 11 335xi jerky auto shifts...? Help....

So I have an 11 335 xi with 2000kms
Sparks were replaced at 200 kms because they were faulty
When the car shifts automatically from 1st to 2nd and so on the shifts aren't smooth. Kind of jerky. No codes tho. Car feels boring to drive....
Brought to dealer and they ran some computer tests n said its all fine
Could they have messed up the sparks install
Also how do I reset the throttle on this car
Any help.........
Appreciate 0
      03-14-2012, 08:57 AM   #2
PowerLex
Private First Class
2
Rep
186
Posts

Drives: Lexus IS-F
Join Date: Jul 2008
Location: Windy City

iTrader: (2)

I also have a 2011 335i with xdrive and I've noticed the downshifts more than anything are very jerky. While braking to a stop, the car rocks as the engine/tranny downshift accordingly. Going from 2nd to first gear around the time you are fully stopped there is a very noticeable "jump", for lack of a better word, that can be felt. Not sure if I should talk to the dealer or not.
Appreciate 0
      03-14-2012, 10:28 AM   #3
Babydragon
Captain
Babydragon's Avatar
United_States
19
Rep
783
Posts

Drives: 2007 328xi
Join Date: Nov 2010
Location: Chic/ago

iTrader: (0)

May be a solenoid or torque converter.
Appreciate 0
      03-14-2012, 01:40 PM   #4
Babydragon
Captain
Babydragon's Avatar
United_States
19
Rep
783
Posts

Drives: 2007 328xi
Join Date: Nov 2010
Location: Chic/ago

iTrader: (0)

Check motor mounts too
Appreciate 0
      03-14-2012, 10:59 PM   #5
Omar335
Registered
United_States
0
Rep
1
Posts

Drives: 2010 335i X Drive
Join Date: Mar 2012
Location: Chicago

iTrader: (0)

Having the same issue with my 2010 after a firmware update and fuel injectors replaced. Taking it back to the Dealer tomorrow.
Appreciate 0
      03-14-2012, 11:37 PM   #6
antrot
Private First Class
Canada
3
Rep
182
Posts

Drives: 11 335i sedan
Join Date: Mar 2009
Location: Toronto/Vaughan

iTrader: (0)

Quote:
Originally Posted by Omar335 View Post
Having the same issue with my 2010 after a firmware update and fuel injectors replaced. Taking it back to the Dealer tomorrow.
K so I know a bit about cars but where can I find the solenoid or torque converter and engine mounts on this car. Anyone have a pic of this.
Also how can I go to the dealer and tell them to check these. They are going to think I'm on crack because the car has such low kms and it's practically brand new
I'm sure they'll give the line ..... The cars new it can't have those problems
Will these ever throw a code??.?.
Appreciate 0
      03-14-2012, 11:41 PM   #7
antrot
Private First Class
Canada
3
Rep
182
Posts

Drives: 11 335i sedan
Join Date: Mar 2009
Location: Toronto/Vaughan

iTrader: (0)

Quote:
Originally Posted by hajduk View Post
May be a solenoid or torque converter.

K so I know a bit about cars but where can I find the solenoid or torque converter and engine mounts on this car. Anyone have a pic of this.
Also how can I go to the dealer and tell them to check these. They are going to think I'm on crack because the car has such low kms and it's practically brand new
I'm sure they'll give the line ..... The cars new it can't have those problems
Will these ever throw a code??.?.
Appreciate 0
      03-15-2012, 09:42 AM   #8
Babydragon
Captain
Babydragon's Avatar
United_States
19
Rep
783
Posts

Drives: 2007 328xi
Join Date: Nov 2010
Location: Chic/ago

iTrader: (0)

Solenoid or torque convertor will throw a code. Motor mounts don't.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:35 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST