E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N55 Turbo Engine Tuning and Exhaust Modifications - 335i Tuning > 2nd to 3rd Gear Jerk..not a tuning problem



Reply
 
Thread Tools Search this Thread
      03-22-2012, 08:43 AM   #1
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

2nd to 3rd Gear Jerk..not a tuning problem

Copying and pasting email I sent to Terry:

Ok this has been driving me crazy still. Was in rush hour today and in regular D, the car still would jerk from 2nd to 3rd only when im at constant speed or about to slow down. Not when speeding up.

I had to keep it in DS mode in 2nd gear to keep calm. I noticed if i shift myself to 3rd, the jerk would only happen at 1.5K rpm. At 1.5K rpm is when it would shift in regular D.

All other gears feel fine so it doesnt look like my transmission is slipping. Im thinking the ecu picked up on my driving habits when i got the car back, i was driving very hard when it was stock to see any problems.

My friend suggested resetting the adaptation. Is it worth the try?

I know its not the JB4 cos i put it in map 0 and it still happens."

I have lagfix set 0 and it's still not helping. I was getting so frustrated during my commute to school today that I was about to wrap myself around a pole. Any input would be appreciated my N55 bros.
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-22-2012, 09:02 AM   #2
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

I also think reset AT adaptation should be the first step to try. I don't know how you cab do this with the JB4. On the Procede there is an option for that. If you have a BT tool maybe you can try with it, but the n55 is not officially supported so maybe it won't work.

Thats the best I can say personally, I have a 6MT...

If you still don't find a solution, you might want to try at a dealership for a quick drive in ask for them to reset AT adaptation for a first test.

You can also reset adaptations with INPA (but its a fairly too large subject to explain here, there is a coding section on the forum). I can guide you a bit eventually if you try that route.

Hope this helps, at least a bit...
Kalud is offline  
0
Reply With Quote
      03-22-2012, 09:05 AM   #3
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

Quote:
Originally Posted by Kalud View Post
I also think reset AT adaptation should be the first step to try. I don't know how you cab do this with the JB4. On the Procede there is an option for that. If you have a BT tool maybe you can try with it, but the n55 is not officially supported so maybe it won't work.

Thats the best I can say personally, I have a 6MT...

If you still don't find a solution, you might want to try at a dealership for a quick drive in ask for them to reset AT adaptation for a first test.

You can also reset adaptations with INPA (but its a fairly too large subject to explain here, there is a coding section on the forum). I can guide you a bit eventually if you try that route.

Hope this helps, at least a bit...
The JB4 has an option to reset adaptations. Is it better to go through the JB4 or do the "hold pedal down in ignition for 30 seconds" thing?

Thankfully I have a friend who has INPA hooked up on his laptop so if I have to go through that route, I can go to him.

This did help a bit Kalud. Thanks man.

Question..if a transmission is slipping, the car would jerk in ALL gears right? I'm going to wait for Terrys response before going the JB4 reset route but yea, I really hope this is a simple fix.
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-22-2012, 09:12 AM   #4
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

Quote:
Originally Posted by sA x sKy View Post
Question..if a transmission is slipping, the car would jerk in ALL gears right?
I think that if it was slipping you would feel it at WOT just after the shifts, at peak torque probably. And its not the case here, you mentioned light throttle. Well... my 2c, I have a very limited AT experience...
Kalud is offline  
0
Reply With Quote
      03-22-2012, 02:26 PM   #5
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

Reset adaptation using the pedal technique..was surprised to find out that the JB4 cannot reset transmission adaptation but whatever. SEEMS better, but for all I know its placebo. Nah scratch that, it definitely feels better..I just hope it doesn't come back.
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-22-2012, 02:58 PM   #6
papiti
Private First Class
 
papiti's Avatar
 
Drives: 2011 E92 335i Coupe M-Tech
Join Date: Sep 2010
Location: San Juan, Puerto Rico

Posts: 147
iTrader: (1)

How do you do that reset adaptation through pedal technique? Please explain!!
__________________
Alpine White 2011 335i M-Tech Coupe, AR Downpipe, N55 JB4 Stage 2, ER Charge Pipe, BMS Intake, Front 10mm Spacers, Rear 12mm Spacers, Red Air-Scoops, Tee Mod, All Windows Tinted.
papiti is offline   Puerto Rico
0
Reply With Quote
      03-22-2012, 03:02 PM   #7
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

Quote:
Originally Posted by papiti View Post
How do you do that reset adaptation through pedal technique? Please explain!!
1) Put key into key slot

2) Press start button

3) Hold down pedal for 30 seconds all the way

4) Without letting go of pedal, press start button again

4) Take foot off pedal

5) Wait 2 min

6) Start the car
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-22-2012, 03:04 PM   #8
papiti
Private First Class
 
papiti's Avatar
 
Drives: 2011 E92 335i Coupe M-Tech
Join Date: Sep 2010
Location: San Juan, Puerto Rico

Posts: 147
iTrader: (1)

Wahat pedal?, Gas pedal, right??
__________________
Alpine White 2011 335i M-Tech Coupe, AR Downpipe, N55 JB4 Stage 2, ER Charge Pipe, BMS Intake, Front 10mm Spacers, Rear 12mm Spacers, Red Air-Scoops, Tee Mod, All Windows Tinted.
papiti is offline   Puerto Rico
0
Reply With Quote
      03-22-2012, 03:06 PM   #9
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

Quote:
Originally Posted by papiti View Post
Wahat pedal?, Gas pedal, right??
Yes. Never touch the brakes.
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-22-2012, 03:06 PM   #10
papiti
Private First Class
 
papiti's Avatar
 
Drives: 2011 E92 335i Coupe M-Tech
Join Date: Sep 2010
Location: San Juan, Puerto Rico

Posts: 147
iTrader: (1)

__________________
Alpine White 2011 335i M-Tech Coupe, AR Downpipe, N55 JB4 Stage 2, ER Charge Pipe, BMS Intake, Front 10mm Spacers, Rear 12mm Spacers, Red Air-Scoops, Tee Mod, All Windows Tinted.
papiti is offline   Puerto Rico
0
Reply With Quote
      03-22-2012, 04:34 PM   #11
Sam335ix
Major
 
Sam335ix's Avatar
 
Drives: 335 ix performance edition
Join Date: Sep 2011
Location: Redskin Country

Posts: 1,276
iTrader: (0)

Quote:
Originally Posted by sA x sKy View Post
Copying and pasting email I sent to Terry:

Ok this has been driving me crazy still. Was in rush hour today and in regular D, the car still would jerk from 2nd to 3rd only when im at constant speed or about to slow down. Not when speeding up.

I had to keep it in DS mode in 2nd gear to keep calm. I noticed if i shift myself to 3rd, the jerk would only happen at 1.5K rpm. At 1.5K rpm is when it would shift in regular D.

All other gears feel fine so it doesnt look like my transmission is slipping. Im thinking the ecu picked up on my driving habits when i got the car back, i was driving very hard when it was stock to see any problems.

My friend suggested resetting the adaptation. Is it worth the try?

I know its not the JB4 cos i put it in map 0 and it still happens."

I have lagfix set 0 and it's still not helping. I was getting so frustrated during my commute to school today that I was about to wrap myself around a pole. Any input would be appreciated my N55 bros.
This is the same issue I had with Procede but at higher RPM's and it jerked really bad as if something was pulling my car back from going forward... like I hit a wall... I heard that the system was adapting to the tune but forget that... It was scary a @#$#@ an no way it was good for the car. I cleared adaptations and it still did it and now I had check engine light on. I truly feel like the piggy backs ECU is not fast enough for the car's ECU.
Sam335ix is offline  
0
Reply With Quote
      03-22-2012, 10:17 PM   #12
sA x sKy
Sameet
 
sA x sKy's Avatar
 
Drives: One Slow Matte Black N55
Join Date: Apr 2010
Location: Long Island, New York

Posts: 1,739
iTrader: (2)

Quote:
Originally Posted by Sam335ix View Post
This is the same issue I had with Procede but at higher RPM's and it jerked really bad as if something was pulling my car back from going forward... like I hit a wall... I heard that the system was adapting to the tune but forget that... It was scary a @#$#@ an no way it was good for the car. I cleared adaptations and it still did it and now I had check engine light on. I truly feel like the piggy backs ECU is not fast enough for the car's ECU.
Honestly, I think it was a faulty PROcede box.

Anyways, drove a little bit more tonight, out of 15 or so tries to replicate the problem, the car did it again twice. Better than the 100% like it was doing this morning. I emailed my SA about it..hopefully theres some transmission software update that is available without me taking all my mods off..again.

Is anyone else experiencing this? It's kinda like someone is shoving the back of the car and it ONLY occurs 2nd to 3rd at 5-10 mph in regular D. I've been searching around, and apparently its common in the N54's too. Sometimes in my other gears it might hold the gear for a half a second longer than it should, but that doesn't worry me.

It sucks cos I'm constantly bracing myself for the jerk but then it doesn't happen and then I relax, and boom. The car has a personality of its own lol
__________________
| KW V3 | Vanguard V2 Exhaust | JB4 | AR DP | Custom Stainless Steel DO Meth Setup | BMS CP | BMS Intake | M-Sport | ZCP M3 Spoiler | Gunsmoke Euro LCI Tails |


PLASTIDIPPPED Matte Black E92 Photoshoot
sA x sKy is offline   Bangladesh
0
Reply With Quote
      03-23-2012, 09:45 PM   #13
Jalndrs
Private First Class
 
Drives: 2013 328i Sport Line
Join Date: Aug 2010
Location: Boston

Posts: 144
iTrader: (0)

Quote:
Originally Posted by sA x sKy View Post
Honestly, I think it was a faulty PROcede box.

Anyways, drove a little bit more tonight, out of 15 or so tries to replicate the problem, the car did it again twice. Better than the 100% like it was doing this morning. I emailed my SA about it..hopefully theres some transmission software update that is available without me taking all my mods off..again.

Is anyone else experiencing this? It's kinda like someone is shoving the back of the car and it ONLY occurs 2nd to 3rd at 5-10 mph in regular D. I've been searching around, and apparently its common in the N54's too. Sometimes in my other gears it might hold the gear for a half a second longer than it should, but that doesn't worry me.

It sucks cos I'm constantly bracing myself for the jerk but then it doesn't happen and then I relax, and boom. The car has a personality of its own lol
This exact same thing was happening to me and thought it was tune related as well. I took my procede and downpipe off and brought it to the dealer. I was still running the original DME software from when I bought the car in july 2010. They updated the software and I upgraded my procede to Rev 2.5. Now the car is running like a champ with no issues whatsoever with the shifting. My problem was when pulling away from a stop sign slowing the shift from two to three was terrible and would slam into gear.
Jalndrs is offline   United_States
0
Reply With Quote
      03-24-2012, 09:33 AM   #14
Slops
Major General
 
Slops's Avatar
 
Drives: 2005 C55 AMG
Join Date: Jan 2011
Location: Oxford

Posts: 5,333
iTrader: (2)

Mine only happened when I was on any map. Switching to map 0 on my procede helped but seems like the tune has adjusted as I'm not getting it as I use to
Slops is offline   South Africa
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST