E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Black screen iDrive. radio still works.



Reply
 
Thread Tools Search this Thread
      03-08-2015, 08:44 PM   #1
tjobeid
Banned
tjobeid's Avatar
11
Rep
560
Posts

Drives: 2007 335i coupe
Join Date: May 2013
Location: houston,tx

iTrader: (1)

Black screen iDrive. radio still works.

Got a 2007 335i with ccc idrive. Everything was working fine. Just went down to get gas when i got back in the car the idrive screen was black. I can still use the volume button to turn up and down the radio station it was on. i can hit "mode" to change source to AUX and listen to music from my phone. But the Idrive screen is black don't see anything.

1) Tried to press the volume with 2 eject buttons for 30 seconds( someone said that resets it) but that didn't work.
Anything else i can try?
Anyone have any suggestions that they HAVE tried and worked?
Appreciate 0
      03-18-2015, 05:14 PM   #2
Zernaff
Private First Class
United_States
3
Rep
189
Posts

Drives: 2006 325i
Join Date: Jan 2014
Location: Charlotte, NC

iTrader: (3)

I've got mine set to turn off if I hit one of the two steering wheel buttons, not sure if yours is set that way but worth a shot.
Appreciate 0
      03-20-2015, 10:31 AM   #3
glachhman2
Private First Class
6
Rep
156
Posts

Drives: 2007 335i
Join Date: Mar 2015
Location: Queens, NY

iTrader: (0)

Needs cic
__________________
Formerly GLachhman
2007 e90 335i SGM
Appreciate 0
      03-22-2015, 09:14 PM   #4
Bavarian Tech
Captain
Bavarian Tech's Avatar
16
Rep
778
Posts

Drives: 335i
Join Date: Jan 2007
Location: Pittsburgh/Harrisburg

iTrader: (11)

Garage List
2006 330i  [5.00]
Check the fuse for the CID
__________________
335i Sport Sedan: 6Speed: Sport : Prem : Cold Weather : CIC Swap/Combox : M3 Cluster
Appreciate 0
      04-08-2015, 07:32 PM   #5
A_Lightyear
Space Ranger
A_Lightyear's Avatar
2
Rep
105
Posts

Drives: e92 N54 FBO
Join Date: Sep 2012
Location: Houston,TX

iTrader: (1)

Maybe borrow a CCC head unit from someone local to see if thats the culprit?

Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:09 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST