E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > CIC Retrofit - USB Not working



Reply
 
Thread Tools Search this Thread
      11-16-2014, 02:20 PM   #1
gf3106
New Member
gf3106's Avatar
United Kingdom
0
Rep
14
Posts

 
Drives: E92 335i N54 Coupe
Join Date: Jul 2014
Location: London, UK

iTrader: (0)

CIC Retrofit - USB Not working

Hi,

I have a problem with my new CIC retrofit. I had old CCC unit that has now been removed.

Fitted the CIC & CAN emulator harness yesterday, everything is working apart from Bluetooth and front PDC. I can fix this with coding to car, I just need to get my laptop in order for coding again.

Also with the unit, I had the OEM USB cable and connector sent, when I installed the unit I wired this into the glove box. Unfortunately the CIC USB is not reading any files (MP3 Import or Map update) I have tried multiple USB sticks, 16GB, 32GB, 64GB with USB 2.0 and 3.0 FAT32 as primary partition, the light flashes for half a second on the drive and then nothing. I have also tried rebooting the unit, and waiting for the CIC to detect the drive 5mins+

The map updates should be working as the unit is mid 2010 and has the tick in the bottom right of the navigation, you can also make the info bar disappear when pressing the idrive button.

I don't understand why the USB is not working, it clearly has some power, I have also tested the connector with multi-meter and it appears to have no bad pins. When I connect my OBD USB cable to test the red light is ON, so it must have power!! Maybe it is possible the USB cable became loose at the back of the nav, but it was connected properly when it went in, although it was a tight fit at the back due to extra emulator cabling.

Does anyone have any idea why the USB is not working? I can't imagine that coding the unit to the car will have any bearing on the USB functionality?

Thanks
Alex
Appreciate 0
      11-17-2014, 11:47 PM   #2
PichaDis11
Major
PichaDis11's Avatar
United_States
9
Rep
1,004
Posts

 
Drives: 08 328i
Join Date: Mar 2013
Location: NY

iTrader: (3)

I say get the unit coded first then try again. Even thought you say the unit is from a 2010 it may still need coding.. If so check the cable connections as you said.
__________________
fitted: $609, $620, $6VA, $6VC, $6NR, $6FL, $614, $615 Auto-Dimming Interior Mirror, LCI Halogen Head Lights, Wheels, ECS Geomet Slotted Rotors, Akebono Pads.
Appreciate 0
      11-18-2014, 02:56 AM   #3
ptpending
Second Lieutenant
2
Rep
230
Posts

 
Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

may be you messed with oem cable because USB port pinout on CIC different than USB port in armrest and combpx and you orderded cable for combox and armrest
__________________
E91 2006. Retrofits:High beam assistant,Individual Audio,Autodim mirrors,CIC,Combox(USB and Bluetooth),Electric Sport Seats,Light package,Front PDC, Heated Steering Wheel,Happy Robot.
Appreciate 0
      11-18-2014, 07:26 AM   #4
gf3106
New Member
gf3106's Avatar
United Kingdom
0
Rep
14
Posts

 
Drives: E92 335i N54 Coupe
Join Date: Jul 2014
Location: London, UK

iTrader: (0)

I will try the coding and see if that helps. I have attached an image of the exact cable that I have, connected in the same way as the photo. Hopefully it is the correct one for the CIC. I thought combox USB also had aux connector built in?



Thanks
Appreciate 0
      11-25-2014, 01:36 PM   #5
climax_e92
Private First Class
1
Rep
152
Posts

 
Drives: E92
Join Date: Mar 2014
Location: Los Angeles

iTrader: (1)

Code it first.. I just did the cic retro last week. Front USB you can only use for importing music and stuff. You will have to click import music. Mine also showed power but wasn't working until it was coded
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:44 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST