E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > LCI taillight error free coding success! details inside----



Reply
 
Thread Tools Search this Thread
      04-06-2012, 11:43 PM   #1
e90sexion
E 9 0 S E X I O N
e90sexion's Avatar
Canada
81
Rep
6,365
Posts

 
Drives: M3, Z4MC
Join Date: Sep 2006
Location: Vancouver/WA

iTrader: (16)

LCI taillight error free coding success! details inside----

This is reference for anyone had struggle with coding.

I ordered the cable from most of here members gotten from, I had to reinstall windows XP on my macbook since it's the only computer i got and old paralles had few problems. After new xp Pro had been installed, then I found out there is no com port feature in XP I installed, so I had to search and search and found out there is VCP drivers and I somehow got to install com port and made sure all the setting is correct according to the information here.

I read pdf instruction over and over to make sure I know what I am doing.
http://www.e90post.com/forums/showthread.php?t=451145
(Huge kudos to xxxjecxxx !!! thank you)

Finally today, (after long long research) I connected the cable to the car, and started.
Went to INPA first, I see 2 black dots good. After choosing e90, then tried to exit but a error box came up, but I just ignored it. I just thought 2 black dots is good enough.

Went with NCS, and followed the pdf instructions, setting up profile, go to CAS always first like instruction says, and go to NFRM (I have 08 e92) and change few 2 lines
to nicht. (I could be little wrong on the spelling tho)

WARMUEBERWACHUNG_BLK_H
nicht_aktiv
KALTUEBERWACHUNG_BLK_H
nicht_aktiv

This 2 lines were only used for error free LCI taillight retrofit coding.
(Big thanks to charles.soori for telling me those 2 lines)
coding ended. I did not bother with any other coding, because I could always make changes later in the future.

Anyways, I started the car, and no more fast blinking signal, but there were still error left (Rear left/right lamp malfunctioning) but it went away after 10sec. After that no more error came on.

The pdf instruction is very very straight forward as it was my first time trying coding. I would like to thank everyone whom I sent pm's for help and answering my questions.

Happy coding guys!

Last edited by e90sexion; 04-06-2012 at 11:48 PM.
Appreciate 0
      04-07-2012, 12:43 AM   #2
NiVeDh
Major General
NiVeDh's Avatar
United_States
158
Rep
8,014
Posts

 
Drives: '08 E90 335i, '99 E36 M3
Join Date: Apr 2009
Location: Houston, TX & Atlanta, GA

iTrader: (132)

Garage List
You should also code out bulb checks for brake lamps (and BFD) to prevent flickering and errors.
Appreciate 0
      04-07-2012, 12:58 AM   #3
e90sexion
E 9 0 S E X I O N
e90sexion's Avatar
Canada
81
Rep
6,365
Posts

 
Drives: M3, Z4MC
Join Date: Sep 2006
Location: Vancouver/WA

iTrader: (16)

Quote:
Originally Posted by NiVeDh View Post
You should also code out bulb checks for brake lamps (and BFD) to prevent flickering and errors.
You are absolutely right, I see right side brake lamps malfunctioning,
strange, I did not see this error before.
edit: Ok, I coded brake lamps, brake force display (BFD) , and 100% error free. thanks!

Last edited by e90sexion; 04-07-2012 at 02:27 PM.
Appreciate 0
      04-29-2012, 12:16 AM   #4
robbie211
Captain
United_States
10
Rep
811
Posts

 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]
I'm in the process of doing a LCI tail light conversion and have NOT coded my car for the LCI tail lights yet.

I plugged in the the tail lights to my 2007 E90 and when parking/headlights are off they illuminate properly when the brake is pressed. However, when the parking/headlights are on the LCI bars light up as well as the outer brake light (as if i had the brake pressed). Is this common until I have properly coded my car?
Appreciate 0
      04-29-2012, 02:55 PM   #5
ROBNYC
Lieutenant
ROBNYC's Avatar
Dominican Republic
8
Rep
444
Posts

 
Drives: 14' X3 28i M-Sport AW
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by robbie211 View Post
I'm in the process of doing a LCI tail light conversion and have NOT coded my car for the LCI tail lights yet.

I plugged in the the tail lights to my 2007 E90 and when parking/headlights are off they illuminate properly when the brake is pressed. However, when the parking/headlights are on the LCI bars light up as well as the outer brake light (as if i had the brake pressed). Is this common until I have properly coded my car?
I also want to know this
__________________
Current: 2014 X3 28i ///M-Sport/Alpine White/Dynamic Handling pkg/Oyster Nevada/Premium/Cold Weather/Driver Assist/Tech/Xenons/Prem Hi-fi/Continental DWS/Escort RedLine XR/FormulaOne Llumar 20%/RaceChip Ultimate
Past: 11' M.Benz c300 | 07' bmw 328xi | 06' Cadillac STS RWD v6
Appreciate 0
      04-30-2012, 01:18 AM   #6
1QuikWS6
No 55mph
1QuikWS6's Avatar
United_States
67
Rep
4,808
Posts

 
Drives: 09 E92 328iX N51 3-Stage ->M6
Join Date: Jul 2009
Location: Blitzburgh, PA

iTrader: (83)

Garage List
And if you want to get rid of that pesky error that pops up, but goes away - code out the Error Reporting for all the lights you coded out the Cold/Warm checks. It's a seperate line of code.
__________________
2009 328ix E92//SGM//ACS Roof Spoiler//MTech Aero Lip+Trunk Spoiler//M3 Side Skirts//CF Roundels+Grilles//M3 Novillo Interior//Perf Shift Lever+Boot//MPerf DCT Wheel//M3 GT3 eBrake Handle+Boot//ACS Pedals//M3 Mirrors//LCI Tails w/LUX Rev//DTEC V7 AE+MTec 6000K D1S+HPB HID 6000K Fogs//HPB LED Interior//RPI Scoops//CF Euro Airbox+Underhood Hsgs//K&N//BMW PE//MTech Rear Bumper-iS Sport Diffuser//CF Strut Brace//Vishnu OFT//BMW 193M's+Kumho 4X
Appreciate 0
      05-01-2012, 10:13 AM   #7
NiVeDh
Major General
NiVeDh's Avatar
United_States
158
Rep
8,014
Posts

 
Drives: '08 E90 335i, '99 E36 M3
Join Date: Apr 2009
Location: Houston, TX & Atlanta, GA

iTrader: (132)

Garage List
Quote:
Originally Posted by robbie211 View Post
I'm in the process of doing a LCI tail light conversion and have NOT coded my car for the LCI tail lights yet.

I plugged in the the tail lights to my 2007 E90 and when parking/headlights are off they illuminate properly when the brake is pressed. However, when the parking/headlights are on the LCI bars light up as well as the outer brake light (as if i had the brake pressed). Is this common until I have properly coded my car?
Quote:
Originally Posted by ROBNYC View Post
I also want to know this
For E90 LCI tail light retrofit, you need to "re-order" the wiring harness so that it looks like this:

Appreciate 0
      05-01-2012, 12:34 PM   #8
robbie211
Captain
United_States
10
Rep
811
Posts

 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]
Quote:
Originally Posted by NiVeDh View Post
For E90 LCI tail light retrofit, you need to "re-order" the wiring harness so that it looks like this:

I understand about re-ordering the wiring harness for Pre-LCI to LCI to get the correct output for the trunk lid lights and I have done this. My experience is described below.

Headlights off
brake not pressed all lights off
brake pressed lights up normally, outside tail lamps illuminate

Headlights on
brake not pressed rear light bars are on and outside brake tail lamps illuminate
brake pressed rear light bars are on and outside and inside brake tail lamps illuminate

I do NOT have coding yet and was just wondering if its normal to have these issues before coding is done.
Appreciate 0
      05-02-2012, 10:39 AM   #9
NiVeDh
Major General
NiVeDh's Avatar
United_States
158
Rep
8,014
Posts

 
Drives: '08 E90 335i, '99 E36 M3
Join Date: Apr 2009
Location: Houston, TX & Atlanta, GA

iTrader: (132)

Garage List
Quote:
Originally Posted by robbie211 View Post
I understand about re-ordering the wiring harness for Pre-LCI to LCI to get the correct output for the trunk lid lights and I have done this. My experience is described below.

Headlights off
brake not pressed all lights off
brake pressed lights up normally, outside tail lamps illuminate

Headlights on
brake not pressed rear light bars are on and outside brake tail lamps illuminate
brake pressed rear light bars are on and outside and inside brake tail lamps illuminate

I do NOT have coding yet and was just wondering if its normal to have these issues before coding is done.
That doesn't seem normal but try the coding and see if it helps.
Appreciate 0
      05-02-2012, 01:14 PM   #10
Elliott@DetailAddict
Brigadier General
United_States
81
Rep
4,448
Posts

 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

iTrader: (0)

Post a video if you can.
Appreciate 0
      05-04-2012, 01:35 AM   #11
robbie211
Captain
United_States
10
Rep
811
Posts

 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]


notice the brake lights light up when headlights are on and brake is not pressed. is this normal when doing the LCI conversion without coding being done yet?
Appreciate 0
      05-06-2012, 09:35 PM   #12
ROBNYC
Lieutenant
ROBNYC's Avatar
Dominican Republic
8
Rep
444
Posts

 
Drives: 14' X3 28i M-Sport AW
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
any updates on your progress?
__________________
Current: 2014 X3 28i ///M-Sport/Alpine White/Dynamic Handling pkg/Oyster Nevada/Premium/Cold Weather/Driver Assist/Tech/Xenons/Prem Hi-fi/Continental DWS/Escort RedLine XR/FormulaOne Llumar 20%/RaceChip Ultimate
Past: 11' M.Benz c300 | 07' bmw 328xi | 06' Cadillac STS RWD v6
Appreciate 0
      05-07-2012, 06:33 PM   #13
robbie211
Captain
United_States
10
Rep
811
Posts

 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]
Quote:
Originally Posted by ROBNYC View Post
any updates on your progress?
not yet. I'm going to get my car coded within the next 2 weeks and hopefully everything will be working as it should.

do you have the same problem?
Appreciate 0
      05-07-2012, 07:34 PM   #14
ROBNYC
Lieutenant
ROBNYC's Avatar
Dominican Republic
8
Rep
444
Posts

 
Drives: 14' X3 28i M-Sport AW
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by robbie211 View Post
not yet. I'm going to get my car coded within the next 2 weeks and hopefully everything will be working as it should.

do you have the same problem?
Not yet I will in 2 weeks, did you have to re-wire the inner or outer lights?
__________________
Current: 2014 X3 28i ///M-Sport/Alpine White/Dynamic Handling pkg/Oyster Nevada/Premium/Cold Weather/Driver Assist/Tech/Xenons/Prem Hi-fi/Continental DWS/Escort RedLine XR/FormulaOne Llumar 20%/RaceChip Ultimate
Past: 11' M.Benz c300 | 07' bmw 328xi | 06' Cadillac STS RWD v6
Appreciate 0
      05-08-2012, 10:52 AM   #15
robbie211
Captain
United_States
10
Rep
811
Posts

 
Drives: E90 335i, E36 M3
Join Date: Mar 2006
Location: OC

iTrader: (16)

Garage List
2007 335i  [3.38]
re-wired the inner (trunk) wiring harness to get the correct lighting configuration.
Appreciate 0
      05-14-2012, 04:15 PM   #16
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

I have done front and rear LCI conversion.
Everything worked fined including the coding.
Initially I had some problems with the lights in bootlid as with normal lights on, rear fog lights were turning one and on reversing, lights were getting grounded. I have sorted the wiring issues, and all lights are fine and functional now.

However I am having rear right brake errors:
Following are error codes which I get OBC:
CC-ID 87
CC-ID 118
CC-ID 123
CC-ID 133
On googling all of these point toward Right side rear brake lights.

All the lights work fine and no problems.
I have check all the bulbs and they seems fine. I have also change the bulbs of rear Right side light (not the one on bootlid) but errors are still there.

Can anybody suggest what could have gone wrong? I can live with it, but it is annoying that I get errors whereas all lights work fine.
__________________

Last edited by makkan00; 05-14-2012 at 05:06 PM.
Appreciate 0
      05-14-2012, 04:37 PM   #17
Dziqsek_
Banned
Poland
4
Rep
413
Posts

 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

iTrader: (0)

There is actually retrofit cable for e90 pre-lci to LCI tailights , and it doesn cost much
Appreciate 0
      05-14-2012, 04:59 PM   #18
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Quote:
Originally Posted by *******_ View Post
There is actually retrofit cable for e90 pre-lci to LCI tailights , and it doesn cost much
Thanks, I know about it.
I believe I do not need it, reason being, I have sorted all the wiring and all rear lights are on.

But error for Right side rear light is still there.
It does not show up on inpa, however it does show OBC.
Very strange and never heard of it. Googled and could not find any suggestions.
__________________
Appreciate 0
      05-14-2012, 10:40 PM   #19
ROBNYC
Lieutenant
ROBNYC's Avatar
Dominican Republic
8
Rep
444
Posts

 
Drives: 14' X3 28i M-Sport AW
Join Date: Apr 2012
Location: NYC/NJ

iTrader: (3)

Garage List
Send a message via AIM to ROBNYC
Quote:
Originally Posted by *******_ View Post
There is actually retrofit cable for e90 pre-lci to LCI tailights , and it doesn cost much
what cable is that?

Quote:
Originally Posted by makkan00 View Post
Thanks, I know about it.
I believe I do not need it, reason being, I have sorted all the wiring and all rear lights are on.

But error for Right side rear light is still there.
It does not show up on inpa, however it does show OBC.
Very strange and never heard of it. Googled and could not find any suggestions.
sorry to hear that man, did you ask the other folks who started the LCI conversion on here?
__________________
Current: 2014 X3 28i ///M-Sport/Alpine White/Dynamic Handling pkg/Oyster Nevada/Premium/Cold Weather/Driver Assist/Tech/Xenons/Prem Hi-fi/Continental DWS/Escort RedLine XR/FormulaOne Llumar 20%/RaceChip Ultimate
Past: 11' M.Benz c300 | 07' bmw 328xi | 06' Cadillac STS RWD v6
Appreciate 0
      05-15-2012, 01:57 AM   #20
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

I have taken photos of correct wiring for both sides.
Let me know if somebody is interested and I will post those here.
__________________
Appreciate 0
      05-15-2012, 05:47 AM   #21
DimitrisM3
e90 my big fat lady!
DimitrisM3's Avatar
Greece
8
Rep
234
Posts

 
Drives: e90
Join Date: Oct 2011
Location: Greece Naoussa

iTrader: (0)

Any Update?
I buy lci trunk and lights and I see that the problems will be a lot

I must change the light modul NFRM2 to NFRM3 ???
__________________

Last edited by DimitrisM3; 05-15-2012 at 07:50 AM.
Appreciate 0
      05-15-2012, 12:15 PM   #22
makkan00
Major General
makkan00's Avatar
United Kingdom
122
Rep
7,555
Posts

 
Drives: F10
Join Date: Dec 2011
Location: Essex

iTrader: (48)

Quote:
Originally Posted by DimitrisM3 View Post
Any Update?
I buy lci trunk and lights and I see that the problems will be a lot

I must change the light modul NFRM2 to NFRM3 ???
What update are you asking mate?

No problems, if you go right way.

First you do not need to go for NFRM3. All FRM / NFRM works with it.

First thing is changing the cables for inner parts (in trunk lid) and then fitting these.
Once you fitted these, you only need coding.
Hope that helps.
__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST