E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > RPM needle flicker at cold start.



Reply
 
Thread Tools Search this Thread
      04-07-2012, 09:42 AM   #1
AddictedToBavarian
My other ride is a Bianchi Infinito
 
AddictedToBavarian's Avatar
 
Drives: E92 328xi
Join Date: Apr 2011
Location: North Jersey

Posts: 2,730
iTrader: (0)

RPM needle flicker at cold start.

Hey guys, so for a few months now (maybe the entire year I've owned my car) when I do a cold start my RPM needle flickers between 800-1200 for about 5 seconds. It's a slight flicker up and down and the car vibrates a bit. Again only on cold starts. Car runs smooth and never had a mechanical issue. Is this normal or should I be looking into something specific?
AddictedToBavarian is offline   Portugal
0
Reply With Quote
      04-08-2012, 12:51 AM   #2
kkttsang
Enlisted Member
 
Drives: 2008 328i
Join Date: Feb 2012
Location: vancouver

Posts: 45
iTrader: (0)

I have the same problem. But not all the time and when its at idle it doesn't flicker just on start up.
I was told its normal.
kkttsang is offline  
0
Reply With Quote
      04-08-2012, 08:52 AM   #3
AddictedToBavarian
My other ride is a Bianchi Infinito
 
AddictedToBavarian's Avatar
 
Drives: E92 328xi
Join Date: Apr 2011
Location: North Jersey

Posts: 2,730
iTrader: (0)

Quote:
Originally Posted by kkttsang View Post
I have the same problem. But not all the time and when its at idle it doesn't flicker just on start up.
I was told its normal.
Yea, mine doesn't flicker at idle either only those 5 seconds or so at start up. The part that worries me is that while it's flickering my car vibrates a bit. Does yours?
AddictedToBavarian is offline   Portugal
0
Reply With Quote
      04-08-2012, 11:26 AM   #4
kkttsang
Enlisted Member
 
Drives: 2008 328i
Join Date: Feb 2012
Location: vancouver

Posts: 45
iTrader: (0)

yup it does, but like i said it doesnt happen all the time and its not only at cold start either, So im not too worry, some members have told me thats normal. i dont know.
kkttsang is offline  
0
Reply With Quote
      04-08-2012, 11:27 AM   #5
kkttsang
Enlisted Member
 
Drives: 2008 328i
Join Date: Feb 2012
Location: vancouver

Posts: 45
iTrader: (0)

how old is yours? mine only has 30000 kms so i dont know if thats related.
kkttsang is offline  
0
Reply With Quote
      04-08-2012, 12:13 PM   #6
AddictedToBavarian
My other ride is a Bianchi Infinito
 
AddictedToBavarian's Avatar
 
Drives: E92 328xi
Join Date: Apr 2011
Location: North Jersey

Posts: 2,730
iTrader: (0)

Quote:
Originally Posted by kkttsang View Post
how old is yours? mine only has 30000 kms so i dont know if thats related.
Mine has 37,000 miles and it's an 08.
AddictedToBavarian is offline   Portugal
0
Reply With Quote
      04-08-2012, 07:12 PM   #7
DDS2015
Major
 
Drives: 2011 E90 LCI 328i xdrive
Join Date: Mar 2011
Location: Winnipeg/Minneapolis

Posts: 1,032
iTrader: (0)

Garage List
I noticed this from new, currently have 17500 kms on it (2011).
DDS2015 is offline   Canada
0
Reply With Quote
      04-09-2012, 01:33 AM   #8
Simon.bmw
Second Lieutenant
 
Simon.bmw's Avatar
 
Drives: E90 323I.
Join Date: Nov 2011
Location: Halifax.NS.CA

Posts: 287
iTrader: (0)

well, i have the same problem now.. that is what i have been told... try get a bottle of engine throttle cleaner and take off the air intake assembly and spray it into the throttle plate, and use towel wipe the cleaner off , and make sure is nice and clean before u put all stuff back on.


have not try it yet. .. lol
hope that works...
Simon.bmw is offline  
0
Reply With Quote
      04-09-2012, 11:22 AM   #9
ska///235i
***** noob
 
ska///235i's Avatar
 
Drives: M235i
Join Date: Sep 2005
Location: Boston

Posts: 8,765
iTrader: (31)

Garage List
2006 325xi  [0.00]
use fuel cleaners/injector cleaners, then do oil change 2weeks later + clean vanos solenoids

since you're at it, change cabin air filter and intake air filter (not that its related to your idle)
__________________
" Hey, your m235i is not a true M car"..."No shit, its a M Performance doe"
ska///235i is offline   United_States
0
Reply With Quote
      04-09-2012, 12:01 PM   #10
Johnny D
Major
 
Johnny D's Avatar
 
Drives: 2006 BMW 325i
Join Date: Apr 2011
Location: Hot Springs, AR

Posts: 1,124
iTrader: (4)

Garage List
2006 BMW 325i  [4.58]
It is a common occurring thing. Nothing that I would consider a problem. Let it warm up and drive as usual.
__________________
Johnny D is offline  
0
Reply With Quote
      04-09-2012, 04:38 PM   #11
AddictedToBavarian
My other ride is a Bianchi Infinito
 
AddictedToBavarian's Avatar
 
Drives: E92 328xi
Join Date: Apr 2011
Location: North Jersey

Posts: 2,730
iTrader: (0)

Quote:
Originally Posted by ska325xi View Post
use fuel cleaners/injector cleaners, then do oil change 2weeks later + clean vanos solenoids

since you're at it, change cabin air filter and intake air filter (not that its related to your idle)
I've never ran a fuel injector and I'm not due for an oil change for a very long time as I just did one and will not reach 15,000 miles even 2 years. Lol. If it starts driving me crazy maybe I'll give it a shot though, thanks for the suggestion.
AddictedToBavarian is offline   Portugal
0
Reply With Quote
      04-09-2012, 04:39 PM   #12
AddictedToBavarian
My other ride is a Bianchi Infinito
 
AddictedToBavarian's Avatar
 
Drives: E92 328xi
Join Date: Apr 2011
Location: North Jersey

Posts: 2,730
iTrader: (0)

Quote:
Originally Posted by jntar View Post
It is a common occurring thing. Nothing that I would consider a problem. Let it warm up and drive as usual.
AddictedToBavarian is offline   Portugal
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST