E90Post
 


Scorpp Design
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Car lost power



Reply
 
Thread Tools Search this Thread
      04-18-2012, 11:48 PM   #1
Honda954
New Member
 
Drives: Bmw 335i
Join Date: Apr 2012
Location: Yonkers

Posts: 10
iTrader: (0)

Car lost power

My car made a big bang and then the engine light came on indicates that the engine lost full power I either blew a Turbo or an intercoller hose which I checked and count find any louse. This this happen to anybody before
Honda954 is offline  
0
Reply With Quote
      04-18-2012, 11:50 PM   #2
Simple3
Lieutenant
 
Drives: e90
Join Date: Jul 2011
Location: USA

Posts: 493
iTrader: (7)

charge pipe? checked both sides of the intercooler?
Simple3 is offline  
0
Reply With Quote
      04-18-2012, 11:50 PM   #3
rader1
Banned
 
Drives: Cobb Stage 2+ 135i
Join Date: Apr 2011
Location: Roanoke, VA

Posts: 2,197
iTrader: (0)

what codes did you get? mods? Be sure to check the diverter valves and other intercooler piping.
rader1 is offline  
0
Reply With Quote
      04-18-2012, 11:53 PM   #4
Honda954
New Member
 
Drives: Bmw 335i
Join Date: Apr 2012
Location: Yonkers

Posts: 10
iTrader: (0)

I only have jb4
Honda954 is offline  
0
Reply With Quote
      04-18-2012, 11:55 PM   #5
Honda954
New Member
 
Drives: Bmw 335i
Join Date: Apr 2012
Location: Yonkers

Posts: 10
iTrader: (0)

The engine block in yellow when I looked in the owners Manuel it said engine lost full power I have a cover under the car that I have to take off to check the piping but they seen to be intact from the top
Honda954 is offline  
0
Reply With Quote
      04-18-2012, 11:57 PM   #6
Simple3
Lieutenant
 
Drives: e90
Join Date: Jul 2011
Location: USA

Posts: 493
iTrader: (7)

sounds like the intercooler piping. Happened to me too it may look intact but its not.
Simple3 is offline  
0
Reply With Quote
      04-19-2012, 12:10 AM   #7
Honda954
New Member
 
Drives: Bmw 335i
Join Date: Apr 2012
Location: Yonkers

Posts: 10
iTrader: (0)

Ill have to check it out in the morning thanks
Honda954 is offline  
0
Reply With Quote
      04-19-2012, 05:09 AM   #8
zanelefko
Lieutenant
 
zanelefko's Avatar
 
Drives: E92 335i
Join Date: Jan 2012
Location: So Fla

Posts: 404
iTrader: (0)

check charge pipe to throttle body as well. I blew mine there, somehow the MAP sensor also came unplugged and put my car in limp mode so dont forget to check that!
__________________
VRSF DP / DCI / JB4 / ETS FMIC / ETS Charge pipe / Tial BOV /
zanelefko is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST