E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Can anyone read my log? Missing on top of 3rd gear.



Reply
 
Thread Tools Search this Thread
      04-09-2012, 11:39 PM   #1
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Can anyone read my log? Missing on top of 3rd gear.

Car has:

Procede v5
Procede PWM methanol injection with charge pipe (20/80-ish mix)
RB turbos
HPF FMIC
Forge diverter valves
aFE dual-cone intake

But I'm a noob when it comes to tuning Can someone tell me what's happening here? The car feels like missing towards redline in 3rd, then SES light comes on (not half engine) and it sounds like I'm running on 5 cylinders. This goes on until I restart the engine.

Plugs are relatively new (15k or so miles), injectors are properly coded.
Also after restart SES light started blinking once every 10 seconds or so. Car sounded like it was in map1 or 0, and boost was only around 9psi with no meth. Limp mode from Procede?
Attached Files
File Type: zip data_file1.zip (49.9 KB, 35 views)
Appreciate 0
      04-09-2012, 11:50 PM   #2
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

If I'm looking at it right my fuel trims are at 0?
Appreciate 0
      04-10-2012, 12:20 AM   #3
jdbretz
Captain
jdbretz's Avatar
10
Rep
813
Posts

Drives: '12 M3, '07 E70 X5 4.8i
Join Date: Dec 2010
Location: NC

iTrader: (10)

You are maxing out your fuel trims. Trim changing OL Fuel setting to 100. Aside from that everything looks pretty good. All the timing pulls seem correspond to the throttle closing slightly, so maybe you had DTC intervene during the log. The OL Fuel setting should help a little with the AFR's too. They don't seem to be hitting their target on boost onset, but quickly reach it after.
Attached Images
 
Appreciate 0
      04-10-2012, 12:25 AM   #4
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Traction was completely off. I had this happen with only DTC off so I figured it might be that. But this time everything was off.
So change OL fueling to 100?

Forgot to mention 2-3 was NLS shift.
Appreciate 0
      04-10-2012, 12:40 AM   #5
jdbretz
Captain
jdbretz's Avatar
10
Rep
813
Posts

Drives: '12 M3, '07 E70 X5 4.8i
Join Date: Dec 2010
Location: NC

iTrader: (10)

Here is the close up of the throttle. You definitely had some closures so if DTC was completely off (held down for 5 seconds), then either your foot was lifting off the throttle or something else is going on. The OL Fueling of 100 will definitely help with your fuel trims though. I haven't logged running the NLS yet so I don't know what its supposed to look like, but I doubt the throttle is supposed to close during the shift like it did on your log.
Attached Images
 
Appreciate 0
      04-10-2012, 12:48 AM   #6
jdbretz
Captain
jdbretz's Avatar
10
Rep
813
Posts

Drives: '12 M3, '07 E70 X5 4.8i
Join Date: Dec 2010
Location: NC

iTrader: (10)

It looks like you went really lean with that misfire occurred. The throttle was still open and boost and ignition were up, but fuel was cut. I don't know exactly how the DME reacts to a misfire, but it seems like it pulls fuel.
Appreciate 0
      04-10-2012, 12:54 AM   #7
The Ghost
Reborn
The Ghost's Avatar
United_States
24
Rep
1,152
Posts

Drives: 335i
Join Date: Jun 2011
Location: USA

iTrader: (1)

Also, if it continues after the OL fuel change, change your plugs. That worked for me.
Appreciate 0
      04-10-2012, 01:12 AM   #8
themyst
Major General
themyst's Avatar
South Korea
91
Rep
6,608
Posts

Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
yes sir you're tapped out on fuel. Don't think it's meth related since IATs are dropping and there is nothing in the timing that's evident. You're going to need to raise OL fueling to 100%, run 100% meth and hope you're not tapped. Otherwise, it's time to drop the boost and see if trims drop to within a manageable range.

Re: misfires, can you do a hard 3-4 shift with NLS disabled? I'd want to ensure that the NLS isn't causing it. I'd check injector coding first to ensure that it's fine, and even though 15k miles of regular daily driving should not cause your plugs to go bad so quickly, that would be the second place I'd look. If misfires are isolated to one cylinder, swap the coil pack from that cylinder to another and check if the misfire follows.

The key variable is the RB turbos. They require a lot of fuel to keep trims and AFR in check at the power level you desire. Hunting for car/tune issues is never fun as I've been there, done that.

Just to give you an idea as to what AFRs look like on a tailpipe sniffer with fuel pressure (open loop fueling) tapped out, here's a dyno chart of an RB turbo car with JB4. If I'm not mistaken, this car had an LPFP modification as well.



PS - your boost looks pretty good. Honestly wouldn't want to go much higher than 17-18 psi up top as the RB turbos are tapped around 19 psi at redline.

PPS - you don't have downpipes???
__________________
E90 LCI N54 6AT

Last edited by themyst; 04-10-2012 at 01:21 AM.
Appreciate 0
      04-10-2012, 01:33 AM   #9
jippii ensio
Major
28
Rep
1,382
Posts

Drives: 335i
Join Date: Feb 2009
Location: On the road

iTrader: (0)

When the fueling is fixed, 20+ psi is possible with upgraded MAP sensor and respectove firmware.
Appreciate 0
      04-10-2012, 02:08 AM   #10
themyst
Major General
themyst's Avatar
South Korea
91
Rep
6,608
Posts

Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
Quote:
Originally Posted by jippii ensio View Post
When the fueling is fixed, 20+ psi is possible with upgraded MAP sensor and respectove firmware.
In the mid range definitely. The rb turbos are close to tapped at 18 psi at redline however.
__________________
E90 LCI N54 6AT
Appreciate 0
      04-11-2012, 01:37 PM   #11
jippii ensio
Major
28
Rep
1,382
Posts

Drives: 335i
Join Date: Feb 2009
Location: On the road

iTrader: (0)

OP, did you get your fueling fixed?
Appreciate 0
      04-11-2012, 03:11 PM   #12
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

I've been so busy with work that I didn't had a chance to do another run. I changed to 100% last night but only went around the block so no conclusive results.
I did pull up all the errors from DME. It's straight from INPA so it's all in german, so I used google translate.
Every single 1 through 6 cylinder has this error

$ FehlerOrtNr: 10705
$ FehlerOrtText: 0x29D1 misfiring cylinder 5
570D29D181000305012838ECBFECCAAB000000000000000000 000000
Error: 11 (11) No: 10705 0x29D1 misfiring cylinder 5 Frequency: 1
Error Code: 1 (5514) injection is switched off
Readiness Flag: (16) Test conditions are met
Error status: available (32) error is not currently, no OBD-debounced
MIL - status: (49) error would the lighting of the warning lamp (MIL) cause
P-code: P0305 Engine misfire detected - cylinder 5 F_LZ: 40
Environment text / Sign In 116576 km (1)
Engine temperature 95.25 C.
Load value for misfire detection 92.19%
Engine speed 6464.00 rpm
Lambda integrator Group 2 33.59%
Appreciate 0
      04-11-2012, 03:14 PM   #13
shiv@vishnu
Tuner
United_States
758
Rep
17,616
Posts

Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

iTrader: (0)

Quote:
Originally Posted by onebadmofo View Post
I've been so busy with work that I didn't had a chance to do another run. I changed to 100% last night but only went around the block so no conclusive results.
You shouldn't need to run 100% open loop fuel in addition to meth. Even with your RB turbos. So something else is going on. First thing I reccomend is dropping boost a bit and then inching up from there. I'd start off with a map2 boost value of 25%.
Appreciate 0
      04-12-2012, 10:18 PM   #14
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

New logs. They look perfect right up to ~6500 where car starts misfiring no matter what. Bad procede box? I'm also getting long cranks sometimes which are non-existant without procede connected. Both fuel pumps were changed recently.

Pictures are too big to post inline

http://i.imgur.com/uuzyN.png
http://i.imgur.com/hSAB8.png

Logs themselves are attached.
Attached Files
File Type: zip data.zip (9.3 KB, 21 views)
Appreciate 0
      04-13-2012, 12:10 AM   #15
themyst
Major General
themyst's Avatar
South Korea
91
Rep
6,608
Posts

Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
Quote:
Originally Posted by onebadmofo View Post
New logs. They look perfect right up to ~6500 where car starts misfiring no matter what. Bad procede box? I'm also getting long cranks sometimes which are non-existant without procede connected. Both fuel pumps were changed recently.

Pictures are too big to post inline

http://i.imgur.com/uuzyN.png
http://i.imgur.com/hSAB8.png

Logs themselves are attached.
I actually have a novel idea that might determine if it's tune or hardware. We'll get it done next week as time allows.
__________________
E90 LCI N54 6AT
Appreciate 0
      04-14-2012, 04:53 PM   #16
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Bump
Appreciate 0
      04-14-2012, 07:15 PM   #17
enrita
Major General
enrita's Avatar
Sweden
99
Rep
7,382
Posts

Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

Quote:
Originally Posted by onebadmofo View Post
New logs. They look perfect right up to ~6500 where car starts misfiring no matter what. Bad procede box? I'm also getting long cranks sometimes which are non-existant without procede connected. Both fuel pumps were changed recently.

Pictures are too big to post inline

http://i.imgur.com/uuzyN.png
http://i.imgur.com/hSAB8.png

Logs themselves are attached.
i had exact same missfire issue at 6400-6500 rpm but only when running meth.
__________________
07 335i AT - MOTIV 750 - MHD E85 BMS flash - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Snow Stg. 3 - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
Appreciate 0
      04-14-2012, 09:57 PM   #18
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Quote:
Originally Posted by enrita View Post
i had exact same missfire issue at 6400-6500 rpm but only when running meth.
And what happened? You don't use meth anymore?
Appreciate 0
      04-15-2012, 01:14 AM   #19
jippii ensio
Major
28
Rep
1,382
Posts

Drives: 335i
Join Date: Feb 2009
Location: On the road

iTrader: (0)

Quote:
Originally Posted by enrita View Post
i had exact same missfire issue at 6400-6500 rpm but only when running meth.
What caused the missfire?
Appreciate 0
      04-15-2012, 07:48 AM   #20
jippii ensio
Major
28
Rep
1,382
Posts

Drives: 335i
Join Date: Feb 2009
Location: On the road

iTrader: (0)

OP, do you have the 2nd design of the AFE dual cone intake?
Appreciate 0
      04-15-2012, 10:08 AM   #21
onebadmofo
Banned
Russian Federation
65
Rep
2,394
Posts

Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Quote:
Originally Posted by jippii ensio View Post
OP, do you have the 2nd design of the AFE dual cone intake?
Not sure, I have this
Appreciate 0
      04-15-2012, 11:10 AM   #22
enrita
Major General
enrita's Avatar
Sweden
99
Rep
7,382
Posts

Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

Quote:
Originally Posted by onebadmofo View Post
And what happened? You don't use meth anymore?
i changed tune.
__________________
07 335i AT - MOTIV 750 - MHD E85 BMS flash - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Snow Stg. 3 - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:43 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST