E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Factory Xenon electrical problem.....



Reply
 
Thread Tools Search this Thread
      04-10-2012, 09:26 AM   #1
cfoster
Private
0
Rep
91
Posts

 
Drives: E93 335i Vert
Join Date: Apr 2012
Location: Essex, UK

iTrader: (0)

Factory Xenon electrical problem.....

Hi all, first post here, stumbled across this forum whilst searching for a fix for my electrical problem!

I've got a 2007 plate BMW 325i m sport coupe and got an annoying electrical issue with one of the headlights. Basically when I turn the headlights on the passenger side xenon flickers on and off a few times (about 2 second gap in between flickers), then comes on and is fine but I get an error come up on the iDrive screen thing saying 'left dipped beam failure'. Any ideas?!

So far the long power wire from the battery at the back to the fuse box has been replaced along with the fuse box itself (under warranty - fixed for something else (common non starting issue)), the ballasts have been swapped and the bulbs themselves have been swapped but made no difference!! Anything else to try?! Could it be an earthing problem maybe? I've checked all fuses etc but all are ok!

Anything else to check?!

Thanks!
Appreciate 0
      04-10-2012, 11:02 AM   #2
Mart1000
Capt Slow
Mart1000's Avatar
14
Rep
1,076
Posts

 
Drives: Leon FR Supercopa
Join Date: Jan 2012
Location: Suffolk

iTrader: (1)

I had this on my old Vectra. Everytime it rained the near side light (hid) would flicker and annoy me. I just coated everything electrical in that area in WD40. Never did it again after that.
Appreciate 0
      04-10-2012, 01:11 PM   #3
cfoster
Private
0
Rep
91
Posts

 
Drives: E93 335i Vert
Join Date: Apr 2012
Location: Essex, UK

iTrader: (0)

I was thinking of spraying everything with wd40 and see what happens! Does anyone know where the earth point for the headlights are? I can see a small cigarette sized box in the inner wing near the headlight with loads of earth point so could it be in there?!
Appreciate 0
      04-12-2012, 02:35 AM   #4
cfoster
Private
0
Rep
91
Posts

 
Drives: E93 335i Vert
Join Date: Apr 2012
Location: Essex, UK

iTrader: (0)

Bit of an update, having looked through other forums and searched on here I decided to swap the headlights last night over (left to right) and see if it still flickered (hoping it did on the same side so its not a new headlight needed!). Anyway managed to get the bumper off and lights out (bugger to do!) and the passenger side still flickered (with the drivers light connected to it). Thinking now its either the Earth connector or maybe the Footwell Control Module?! Any thoughts?
Appreciate 0
      07-02-2012, 04:42 PM   #5
Pagewear.net
New Member
0
Rep
6
Posts

 
Drives: 2007 E92 Coupe Msport
Join Date: Oct 2010
Location: Yorkshire England

iTrader: (0)

Hi, I have had this issue on my E92 MSport 325i for the last two years I too swapped the headlamps but it solved nothing, recently I doused everything in WD40 and it did stop but only for a short period and once it came back I never managed to stop it again?

Please let me know if you have any luck, for reference the dealer looked at it for three hours labour and found nothing
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:46 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST