E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Code P2C2D



Reply
 
Thread Tools Search this Thread
      04-17-2012, 05:49 PM   #1
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

Code P2C2D

Hello everyone, my car is throwing a code "lambda probe before catalyst, shear test." Does anyone know what this is about? Thank you!
onlycyb is offline  
0
Reply With Quote
      04-17-2012, 05:59 PM   #2
Elliott@DetailAddict
Brigadier General
 
Drives: E90
Join Date: May 2011
Location: Santa Clara, CA

Posts: 4,448
iTrader: (0)

Sounds like a bad O2 Sensor (Lambda Probe).
Clear and see if it comes back. May be a fluke.
Elliott@DetailAddict is offline   United_States
0
Reply With Quote
      04-17-2012, 06:33 PM   #3
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

Thanks for the response! Yeah, I tried clearing it already but it came back. Im a little confused cuz I thought it would specify either bank1 or bank2. Btw, it didnt trigger SES or CEL. Hmmm, I wonder if its something I should be worried about.
onlycyb is offline  
0
Reply With Quote
      04-17-2012, 10:19 PM   #4
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

Anyone else running cobb have or had this code come up?
onlycyb is offline  
0
Reply With Quote
      04-18-2012, 07:48 AM   #5
MilehighM3
Colonel
 
MilehighM3's Avatar
 
Drives: E90 M3
Join Date: May 2011
Location: Colorado Springs

Posts: 2,007
iTrader: (9)

These cars call bank 1 O2 sensor/lambda probe. It will state bank 2 when necessary.
MilehighM3 is offline  
0
Reply With Quote
      04-18-2012, 08:10 AM   #6
ianthegreat
Colonel
 
ianthegreat's Avatar
 
Drives: n54
Join Date: Apr 2008
Location: Pittsburgh/Houston

Posts: 2,314
iTrader: (1)

Quote:
Originally Posted by onlycyb View Post
Hello everyone, my car is throwing a code "lambda probe before catalyst, shear test." Does anyone know what this is about? Thank you!
Do you have catless DP's installed?
ianthegreat is offline  
0
Reply With Quote
      04-18-2012, 09:54 AM   #7
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

Quote:
Originally Posted by Bmw135er View Post
These cars call bank 1 O2 sensor/lambda probe. It will state bank 2 when necessary.
oh ok, thanks.
onlycyb is offline  
0
Reply With Quote
      04-18-2012, 09:54 AM   #8
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

Quote:
Originally Posted by ianthegreat View Post
Do you have catless DP's installed?
yes
onlycyb is offline  
0
Reply With Quote
      06-18-2013, 07:57 AM   #9
sickem
Freude am fahren
 
sickem's Avatar
 
Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

Posts: 1,940
iTrader: (4)

Garage List
Any resolution on this? Got this code this am
sickem is offline  
0
Reply With Quote
      06-23-2013, 08:54 AM   #10
onlycyb
New Member
 
Drives: e90lci
Join Date: Mar 2012
Location: NJ

Posts: 15
iTrader: (0)

After clearing the code a few times, it went a way. I'm assuming it had to do with the DME adjusting to new tune. Good luck!
onlycyb is offline  
0
Reply With Quote
      06-23-2013, 09:41 AM   #11
sickem
Freude am fahren
 
sickem's Avatar
 
Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

Posts: 1,940
iTrader: (4)

Garage List
Quote:
Originally Posted by onlycyb
After clearing the code a few times, it went a way. I'm assuming it had to do with the DME adjusting to new tune. Good luck!
Thanks. I cleared it as well and it hasn't come back. I appreciate the follow up!
__________________
Cobb E40 PROtune by Jake@PTF/RR catless DPs/aFe DCI/ETS 5" FMIC/ER CP/Forge DVs/Alpina B3 TCU flash/BMW Perf. Exhaust./BMW Performance Style 313s/M-Tech Rear
sickem is offline  
0
Reply With Quote
      06-23-2013, 02:42 PM   #12
Robbie200
Private
 
Drives: E92 335i
Join Date: Dec 2012
Location: UK

Posts: 54
iTrader: (0)

I was getting the same code once every few days on my standard car. Changed bank 1 (cylinders 1,2,3) pre cat lambda sensor and the code hasn't returned.
Robbie200 is offline   United Kingdom
0
Reply With Quote
      06-24-2013, 10:23 AM   #13
sickem
Freude am fahren
 
sickem's Avatar
 
Drives: in the fast lane
Join Date: Mar 2010
Location: People's Republic of New Jersey

Posts: 1,940
iTrader: (4)

Garage List
Quote:
Originally Posted by Robbie200 View Post
I was getting the same code once every few days on my standard car. Changed bank 1 (cylinders 1,2,3) pre cat lambda sensor and the code hasn't returned.
thanks. when my o2 sensors were crapping out I got different codes...but in any case I've cleared the code, it hasn't come back, and the car seems to be running fine otherwise. My mechanic needs to adjust my DPs slightly next week so I'll have him ensure that the wiring is fully intact and that nothing else is amiss. I'll report back any findings.
__________________
Cobb E40 PROtune by Jake@PTF/RR catless DPs/aFe DCI/ETS 5" FMIC/ER CP/Forge DVs/Alpina B3 TCU flash/BMW Perf. Exhaust./BMW Performance Style 313s/M-Tech Rear
sickem is offline  
0
Reply With Quote
      08-03-2013, 10:30 AM   #14
335bmwjohn
Private First Class
 
335bmwjohn's Avatar
 
Drives: 2007 BMW E90 335i
Join Date: Sep 2012
Location: Fort Worth, Texas

Posts: 102
iTrader: (2)

Garage List
2007 BMW 335i  [5.00]
I have a simliar problem and have installed 2 sets of o2 precat sensors but the code still come up everytime I start the car. I can clear it and it will not return till I shut the car off and restart. I have replaced coils, plugs, injectors, 02 Sensors, wallnut blast, vaccum lines etc... Im stuck lol
335bmwjohn is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:55 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST