E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Water Pump failure. Any experience? Cost?



Reply
 
Thread Tools Search this Thread
      06-03-2012, 12:11 AM   #45
RazRokz.!
Lieutenant
RazRokz.!'s Avatar
8
Rep
581
Posts

 
Drives: 07 JET BLACK BMW 328i
Join Date: Aug 2011
Location: BELGIUM

iTrader: (0)

http://www.rockauto.com/catalog/raframecatalog.php

^If you check this website out they have water pumps by ac delco for our cars for 42ish dollars. I wonder if it will work?
__________________
l-2007 Jet Black E90-l-Heated Seats-l-Injen Short Ram Intake-l-Kicker Audio-l-Tablet Pc Integration-l-19" Avant Garde M310-l-Falken 452-l-Depo Projectors-l-Depo Blacklines-l-M3 Replica Front Bumper-l-Canbus HID Headlights & Foglights-l-20% Tint All Around-l
Appreciate 0
      06-03-2012, 02:48 AM   #46
monaco330
Private
monaco330's Avatar
0
Rep
75
Posts

 
Drives: Moanco 330i
Join Date: Feb 2012
Location: broward Fl

iTrader: (0)

Quote:
Originally Posted by sisspc
Quote:
what were the symptoms that led you to believe it was the water pump?
While driving on the freeway the yellow temp light and chime came on followed quickly by the red light and chime. Also the fan had been louder than usual for a couple days but I hadn't had time to investigate. When i pulled over and opened the hood coolant had sprayed everywhere. The car would start and run but I only drove from the driveway (where the tow truck driver set it down) into the garage, 30-40 feet max.

Btw, my car is an '06 330i with 130,000 miles.
This is exactly what happened to me 2 exits away from my job today. I plan on ordering a water pump & thermostat when I get home in the morning. Should I maybe have a shop look at it before I just assume its the water pump?

I have a 2006 330I with about 83,000 miles btw.
Appreciate 0
      06-03-2012, 08:28 AM   #47
Efthreeoh
Brigadier General
United_States
48
Rep
3,693
Posts

 
Drives: E90
Join Date: May 2012
Location: MARLAND

iTrader: (0)

Quote:
Originally Posted by RazRokz.! View Post
http://www.rockauto.com/catalog/raframecatalog.php

^If you check this website out they have water pumps by ac delco for our cars for 42ish dollars. I wonder if it will work?
Rock auto is not showing the correct part. The part they show is a belt-driven water pump for the E46 series. The part they quote will not work on the N52.
Appreciate 0
      06-04-2012, 01:15 AM   #48
RazRokz.!
Lieutenant
RazRokz.!'s Avatar
8
Rep
581
Posts

 
Drives: 07 JET BLACK BMW 328i
Join Date: Aug 2011
Location: BELGIUM

iTrader: (0)

Quote:
Originally Posted by Efthreeoh View Post
Rock auto is not showing the correct part. The part they show is a belt-driven water pump for the E46 series. The part they quote will not work on the N52.
thanks for the info, i almost bought it. I wonder if theres a diy for waterpump change anywhere?
__________________
l-2007 Jet Black E90-l-Heated Seats-l-Injen Short Ram Intake-l-Kicker Audio-l-Tablet Pc Integration-l-19" Avant Garde M310-l-Falken 452-l-Depo Projectors-l-Depo Blacklines-l-M3 Replica Front Bumper-l-Canbus HID Headlights & Foglights-l-20% Tint All Around-l
Appreciate 0
      06-05-2012, 05:28 AM   #49
Efthreeoh
Brigadier General
United_States
48
Rep
3,693
Posts

 
Drives: E90
Join Date: May 2012
Location: MARLAND

iTrader: (0)

There is in the DIY section. You can search for it.
Appreciate 0
      06-05-2012, 01:24 PM   #50
sisspc
New Member
0
Rep
22
Posts

 
Drives: 2006 330i
Join Date: Jan 2012
Location: Between Jack Daniels and Bonnaroo

iTrader: (0)

Quote:
Originally Posted by monaco330 View Post
Should I maybe have a shop look at it before I just assume its the water pump?
Obviously that's your call. I considered it a waste of money having a shop look at it based on the symptoms. I was correct.
Appreciate 0
      06-05-2012, 03:29 PM   #51
Trooper9009
Second Lieutenant
Trooper9009's Avatar
5
Rep
248
Posts

 
Drives: 2011 335 XI coupe M sport
Join Date: Dec 2009
Location: CT

iTrader: (2)

I was in the same situation few months ago and ended up spending $1300...I beleive someone local here in Atlanta got it done for less than 800 ..check regional section and u might find it
Appreciate 0
      06-06-2012, 02:29 AM   #52
monaco330
Private
monaco330's Avatar
0
Rep
75
Posts

 
Drives: Moanco 330i
Join Date: Feb 2012
Location: broward Fl

iTrader: (0)

Quote:
Originally Posted by sisspc
Quote:
Originally Posted by monaco330 View Post
Should I maybe have a shop look at it before I just assume its the water pump?
Obviously that's your call. I considered it a waste of money having a shop look at it based on the symptoms. I was correct.
I felt 95% sure it was so I ordered
The parts same day. Hope I'm right lol
Appreciate 0
      06-06-2012, 09:06 AM   #53
sisspc
New Member
0
Rep
22
Posts

 
Drives: 2006 330i
Join Date: Jan 2012
Location: Between Jack Daniels and Bonnaroo

iTrader: (0)

Quote:
Originally Posted by Trooper9009 View Post
I was in the same situation few months ago and ended up spending $1300...I beleive someone local here in Atlanta got it done for less than 800 ..check regional section and u might find it
I realize not everybody has the proper tools or place to work, but this this is a very doable diy project. The parts cost me $450 (thermostat, water pump and coolant) and I did the work myself. I would gladly help somebody do this, unfortunately I live in a small town and I'm not sure if there are any forum members nearby. Feel free to hit me up if you are though.

$800 (including parts) still a little high imo. This job should not take a shop more than 2 hours. Of course they'll probably bill you for 4+ hours.

Last edited by sisspc; 06-06-2012 at 02:52 PM.
Appreciate 0
      06-06-2012, 01:00 PM   #54
Cir14
Private First Class
1
Rep
107
Posts

 
Drives: 07 328xi Montego Blue Sedan
Join Date: Oct 2011
Location: Ambler pa

iTrader: (0)

My 2 cents / recent experience:
2007 328xi
~76,000 miles
Coolant light appeared a few months ago causing me to check the coolant reservoir which very low, well duh the light came on. Took it to the dealer and they topped it off no problem. I had a feeling that the water pump was approaching the end of its life.

Fast forward ~3 months, Friday 6:00PM, very congested area in rush hour Friday traffic. Yellow coolant, immediately following by a Red warning light then limp mode. Managed to get it into a nearby strip mall, donít ask me how but it wouldnít go above ~1-2K RPM's. Itís a manual transmission so after trying to start it (even though you're not supposed to) it would stall (1st restart). Waited a minute or two (freaking out the entire time) then started again revved it to like 2K and it moved <5mph off the road.

Got it towed to dealer, fixed for $53 under certified pre-owner warranty. They said that it would have been ~$1,100 to repair had it not been covered under the CPO.
Appreciate 0
      06-07-2012, 09:08 PM   #55
omerfar23
First Lieutenant
United_States
7
Rep
363
Posts

 
Drives: 2008 E92 335i, 2014 Corolla LE
Join Date: May 2007
Location: Baltimore, MD

iTrader: (0)

Quote:
Originally Posted by Cir14 View Post
My 2 cents / recent experience:
2007 328xi
~76,000 miles
Coolant light appeared a few months ago causing me to check the coolant reservoir which very low, well duh the light came on. Took it to the dealer and they topped it off no problem. I had a feeling that the water pump was approaching the end of its life.

Fast forward ~3 months, Friday 6:00PM, very congested area in rush hour Friday traffic. Yellow coolant, immediately following by a Red warning light then limp mode. Managed to get it into a nearby strip mall, donít ask me how but it wouldnít go above ~1-2K RPM's. Itís a manual transmission so after trying to start it (even though you're not supposed to) it would stall (1st restart). Waited a minute or two (freaking out the entire time) then started again revved it to like 2K and it moved <5mph off the road.

Got it towed to dealer, fixed for $53 under certified pre-owner warranty. They said that it would have been ~$1,100 to repair had it not been covered under the CPO.
Well my dealer quoated me 1600 for stat and water pump. When you are under warranty they do not tell you the correct prices.

When I had the HPFF replaced the dealer told its only 2 hours of labor, BS. if i was paying for it would have been at least 5 hours of labor.
__________________
********** 2008 BMW 335i TT******
Appreciate 0
      07-12-2012, 12:01 PM   #56
Rookie83
First Lieutenant
Rookie83's Avatar
6
Rep
380
Posts

 
Drives: 2009 335i 6mt cpe
Join Date: May 2011
Location: DFW

iTrader: (1)

Damn, just got yellow coolant light by itself a few days ago. Topped it off and has been fine since. After reading this thread it sounds like i will be forced to replace a W/P in the near future.
Appreciate 0
      07-12-2012, 12:09 PM   #57
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,361
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Not exactly. Mine turned on last year, added coolant and has not light up again ever since, hope this makes u feel better... cheers!!
Appreciate 0
      08-08-2012, 12:48 PM   #58
MMOTION
Lieutenant Colonel
MMOTION's Avatar
24
Rep
1,722
Posts

 
Drives: like you'll never drive again
Join Date: Feb 2009
Location: uptown

iTrader: (21)

Quote:
Originally Posted by sisspc View Post
While driving on the freeway the yellow temp light and chime came on followed quickly by the red light and chime. Also the fan had been louder than usual for a couple days but I hadn't had time to investigate. When i pulled over and opened the hood coolant had sprayed everywhere. The car would start and run but I only drove from the driveway (where the tow truck driver set it down) into the garage, 30-40 feet max.

Btw, my car is an '06 330i with 130,000 miles.
^ just happened to me over the long weekend. I got a e90 330xi w/175k kms.

Had to have the waterpump/tstat replaced. Also had the coolant system bled since i added distilled water just to get me home when this happened on the freeway. Worst part they also had to replace some module for the throttle ($320) b/c my car would keep overreving after bleeding the system.
Appreciate 0
      08-08-2012, 02:13 PM   #59
33beto
Second Lieutenant
33beto's Avatar
United_States
4
Rep
278
Posts

 
Drives: R.I.P. 08 E90 328i/GM 6L45E
Join Date: May 2011
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Cir14 View Post
My 2 cents / recent experience:
2007 328xi~76,000 miles

Got it towed to dealer, fixed for $53 under certified pre-owner warranty. They said that it would have been ~$1,100 to repair had it not been covered under the CPO.
Glad they didnt pull the old: OH NO, THATS A WEAR AND TEAR ITEM. NOT COVERED. SORRY! bs line they always say when under warranty still.
__________________

R.I.P 10/14/12
Appreciate 0
      08-08-2012, 02:42 PM   #60
bas2000
AMG LOL
bas2000's Avatar
United_States
1
Rep
121
Posts

 
Drives: 6MT like you stole it!!
Join Date: May 2009
Location: INDY

iTrader: (2)

Send a message via MSN to bas2000
I got a quote from a local shop for water pump and tstat intall at $90 an hour

3 hours for water pump = $270
2.5 hours for tstat = $225

total labor = $495
Appreciate 0
      08-08-2012, 03:17 PM   #61
UltraRacer13
Wannabe Track Rat
UltraRacer13's Avatar
British Virgin Islands
19
Rep
911
Posts

 
Drives: 08 335xi e92 MT
Join Date: Mar 2010
Location: Texas

iTrader: (1)

Same symptoms as others- yellow followed by quick red. I was able to drive the car 5 miles to dealer by staying under 1500rpm. If red came on i would just coast with clutch depressed until it went back to yellow. My oil temps never got that high, not sure if that means I avoided damage or not. Covered under GOLD warranty. car has 55k miles- 2008 335xi. I paid like 3k for the warranty, almost paid for in 5k miles. Feeling good about that purchase. I track my car, wonder if that played a role in it going so early.
__________________

XI | COBB | AST | Vorshlag | PFC | STETT | StopTech | Apex | DCI
Appreciate 0
      08-10-2012, 06:14 AM   #62
Efthreeoh
Brigadier General
United_States
48
Rep
3,693
Posts

 
Drives: E90
Join Date: May 2012
Location: MARLAND

iTrader: (0)

Quote:
Originally Posted by bas2000 View Post
I got a quote from a local shop for water pump and tstat intall at $90 an hour

3 hours for water pump = $270
2.5 hours for tstat = $225

total labor = $495
They are ripping you off. The T-stat is bolted to the water pump. The T-stat is removed during the water pump replacement procedure, so they should not charge you any labor to replace the T-stat. 3 hours for the water pump is about an hour too long IMO, but $270 for that work is not a bad price.
Appreciate 0
      08-13-2012, 10:13 PM   #63
bas2000
AMG LOL
bas2000's Avatar
United_States
1
Rep
121
Posts

 
Drives: 6MT like you stole it!!
Join Date: May 2009
Location: INDY

iTrader: (2)

Send a message via MSN to bas2000
Quote:
Originally Posted by Efthreeoh View Post
They are ripping you off. The T-stat is bolted to the water pump. The T-stat is removed during the water pump replacement procedure, so they should not charge you any labor to replace the T-stat. 3 hours for the water pump is about an hour too long IMO, but $270 for that work is not a bad price.
thanks for the info dude! i thought that was strange how shops want to quote them separate since they are attached.

VS Motorsports did the same thing, they told me 4 + 2 >_<
Appreciate 0
      08-14-2012, 12:13 AM   #64
DimSum
Banned
Canada
60
Rep
2,743
Posts

 
Drives: SLOW
Join Date: May 2008
Location: LITTLEBIMMER.COM

iTrader: (10)

Quote:
Originally Posted by lux.sh View Post
Guess I should update.

It was the damn electric water pump. It was $990 to replace.
Should have bought it from TISHERBMW they sell it for much cheaper.
Appreciate 0
      11-06-2012, 12:20 PM   #65
e36mmm
Second Lieutenant
5
Rep
216
Posts

 
Drives: 335i M Sport
Join Date: Dec 2009
Location: Australia

iTrader: (0)

Add me to the list guys. 2008 335i vert. Same thing happened out of no where fan working on high in an abnormal way, 5 kms later, yellow warning followed by red another 5 km after. Computer told to drive moderately to cool engine down, did that and then when red warning came up, i pulled over to turn to engine off for safety and called a tow truck. Got it towed to my house an hour ago. Tomorrow is going to be a costly day. Temperature was running below normal and car went into limp mode which was weird for me but i guess its normal to keep engine safe. Definitely wstermpump, thermostat or including a leak from coolant. I checked coolant level after cool off period but no decrease, it was upto level. Mileage 46000 miles. First oil gasket needed replacing last month after I saw a leak from a failed gasket which was a cheap fix. This is the second issue I have faced in 2 years of ownership. I guess it's not too bad of a problem and common with these cars but damn frustrating and it's going to make me sell it if I face a third issue. Knock on wood. I love this car but it's so upsetting.
Appreciate 0
      01-03-2013, 08:07 PM   #66
alps
Registered
0
Rep
1
Posts

 
Drives: 2008 e93 335i
Join Date: Jan 2013
Location: Sydney Australia

iTrader: (0)

Mine bombed out just before christmas, same fashion everyone else's has on the freeway first yellow temp warning followed by a red after 3 seconds with nowhere to stop.. Just got it back after 2 grand, everything is expensive here in australia.
Appreciate 0
Reply

Bookmarks

Tags
tischer, waterpump

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:24 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST