E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > iPod changing to FM by itself... (iDrive)



Reply
 
Thread Tools Search this Thread
      06-25-2007, 12:23 AM   #1
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Unhappy iPod changing to FM by itself... (iDrive)

So Ive had my car for about a week now. I will be listening to a song on my ipod and the thing just changes to FM. I am not touching any buttons at all. It just switches...

Has anyone else experienced this? I havent updated my iPod for a while. So I will do that soon. Its a video ipod so its not that old. It could be the firmware in the iPod or even the iDrive.

Anyone know anything about this???

Definitive
__________________
Appreciate 0
      06-25-2007, 12:43 AM   #2
jamb
Lieutenant
jamb's Avatar
United_States
8
Rep
466
Posts

 
Drives: Driving u crazy
Join Date: Apr 2006
Location: USA

iTrader: (4)

Garage List
2006 325i  [0.00]
Try to disconnect your ipod, update its software and the reconnect it... it should fix the issue..
__________________
BMW E90 325i Monaco Blue - Beige Dakota, Steptronic, Premium Package, Adaptive Xenons
MODS: AC Schnitzer Body Kit, 19" CSL Wheels, Quad Exhaust ,Aluminum Pedals and an E92
Appreciate 0
      06-25-2007, 10:33 AM   #3
japac1
Major
japac1's Avatar
12
Rep
1,100
Posts

 
Drives: 2007 335 xi
Join Date: May 2007
Location: Longview, TX

iTrader: (0)

Garage List
2007 335xi  [0.00]
__________________
[font="Garamond"]2007 E90 335 xi, Monaco Blue, Beige, Prem, Cold, Step, Navi, Sat, iPod
Appreciate 0
      06-25-2007, 02:45 PM   #4
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
thanks Jamb. ill try it tonight.

jpac; I did several searches on this and did not find anything. so if you can find something on it. by all means help me out.

the first this I always do is search...

definitive
__________________
Appreciate 0
      06-25-2007, 03:58 PM   #5
sbdoc
MTFO
sbdoc's Avatar
United_States
0
Rep
6
Posts

 
Drives: 335i E92 Monaco Blue
Join Date: Jun 2007
Location: Texas

iTrader: (0)

Quote:
Originally Posted by Definitive View Post
So Ive had my car for about a week now. I will be listening to a song on my ipod and the thing just changes to FM. I am not touching any buttons at all. It just switches...

Has anyone else experienced this? I havent updated my iPod for a while. So I will do that soon. Its a video ipod so its not that old. It could be the firmware in the iPod or even the iDrive.

Anyone know anything about this???

Definitive
Definitive - I have had the exact problem that you described with your iPod. In addition, my iDrive is quite slow. My E92 is at the dealer as we speak being tortured. I will be very interested if the iPod update helps. Keep us posted, and I'll let you know if the dealer has any ideas
Appreciate 0
      06-25-2007, 08:42 PM   #6
bud001
That Guy
bud001's Avatar
United_States
1
Rep
165
Posts

 
Drives: E90 330i
Join Date: Jul 2006
Location: Red Sox Nation (in spirit), Miami (for real)

iTrader: (0)

Garage List
2006 330i (E90)  [0.00]
What is your iPod model and your firmware version?
Appreciate 0
      06-25-2007, 08:58 PM   #7
sbdoc
MTFO
sbdoc's Avatar
United_States
0
Rep
6
Posts

 
Drives: 335i E92 Monaco Blue
Join Date: Jun 2007
Location: Texas

iTrader: (0)

I have a Nano hooked up that has up-to-date software, but as to the firmware version - don't know.
Appreciate 0
      06-25-2007, 09:00 PM   #8
bud001
That Guy
bud001's Avatar
United_States
1
Rep
165
Posts

 
Drives: E90 330i
Join Date: Jul 2006
Location: Red Sox Nation (in spirit), Miami (for real)

iTrader: (0)

Garage List
2006 330i (E90)  [0.00]
mmmmmm.... i have a full iPod video and i got my MOST kit today and not a problem yet. Are you referring to MOST or 6FL?
Appreciate 0
      06-25-2007, 09:14 PM   #9
sbdoc
MTFO
sbdoc's Avatar
United_States
0
Rep
6
Posts

 
Drives: 335i E92 Monaco Blue
Join Date: Jun 2007
Location: Texas

iTrader: (0)

Quote:
Originally Posted by bud001 View Post
mmmmmm.... i have a full iPod video and i got my MOST kit today and not a problem yet. Are you referring to MOST or 6FL?
I believe it is 6FL with the USB port in the console which was ordered as an option when I ordered the E92 from the factory
Appreciate 0
      06-26-2007, 09:57 AM   #10
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Ok, So I am a little bummed... I am running the 6FL and my iPod is up to date. I have version 1.2.1
It is a Video iPod. So I guess there is nothing I can do at this point.

sbdoc: Please let me know if the dealer can fix the issue...

Definitive
__________________
Appreciate 0
      06-26-2007, 10:39 AM   #11
japac1
Major
japac1's Avatar
12
Rep
1,100
Posts

 
Drives: 2007 335 xi
Join Date: May 2007
Location: Longview, TX

iTrader: (0)

Garage List
2007 335xi  [0.00]
this is a problem that's been going on for some time (the 6FL is a new option). As far as I know, there are no service bulletins yet, but BMW is working on the issue. It has happened to me about 5 times. Very frustrated also...but keep checking back here for new info. There are several threads here that discuss this problem...
__________________
[font="Garamond"]2007 E90 335 xi, Monaco Blue, Beige, Prem, Cold, Step, Navi, Sat, iPod
Appreciate 0
      06-28-2007, 11:07 PM   #12
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Anyone else having this problem???

Definitive
__________________
Appreciate 0
      06-29-2007, 04:08 PM   #13
sbdoc
MTFO
sbdoc's Avatar
United_States
0
Rep
6
Posts

 
Drives: 335i E92 Monaco Blue
Join Date: Jun 2007
Location: Texas

iTrader: (0)

Hey Definitive - I did a search on this problem and it seems that others are having the same issue. (one in London and another in Louisiana among others) My E92 is back from the dealer- no fix yet- "waiting on a part"- although I don't have great faith that this will be the fix. I'll let you know if we figure it out.
Appreciate 0
      06-30-2007, 01:59 PM   #14
1clean335i
Perf BMW mag issue 147, 159
1clean335i's Avatar
Vietnam
155
Rep
6,754
Posts

 
Drives: Project Estoril
Join Date: Feb 2007
Location: Central Florida

iTrader: (30)

Garage List
There are plenty of other cars with this issue...

Currently no fix available yet but there might be one with a new software version. So for the time being just sit tight till something is out
__________________
'13 Estoril Blue 335i M-sport
*Don't PM me!* Message me here- http://www.facebook.com/ProjectEstoril
Appreciate 0
      07-11-2007, 12:00 PM   #15
Stinger
Major
Stinger's Avatar
United_States
33
Rep
1,039
Posts

 
Drives: 2007 335i Convertible
Join Date: Apr 2007
Location: Southern California

iTrader: (1)

Garage List
2007 335i E93  [3.50]
1993 318is  [0.00]
1996 Z3 1.9  [0.00]
I have only had my car for ~2 days now and have been using my iPod video and iPhone interchangably and have not had this problem yet. I have iDrive and 6FL (factory installed of course.)
__________________
Appreciate 0
      07-11-2007, 12:38 PM   #16
SoYank
Major General
SoYank's Avatar
United_States
88
Rep
7,504
Posts

 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
Maybe your car just doesn't like your choice of music.
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
Appreciate 0
      07-11-2007, 01:14 PM   #17
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Ok, So the other day I came out to my car and my iPod was totally dead. It wouldent even come on when the car was turned on. I had to take it into my house to charge it. I have never had this problem with my iPod in any other car I have had.

I think this is because I do not drive very far on a daily basis, and since it does not charge the ipod when the car is off, the battery is never fully charged.

I am wondering if this might be my issue. Maybe when the iPod gets very low, it disconnects from the iDrive. Then when I choose the iPod again it comes back on because the battery get a little charge...

Does this sound like it could be the problem?

Definitive
__________________
Appreciate 0
      07-11-2007, 05:20 PM   #18
msimon18
Retired
msimon18's Avatar
United_States
9
Rep
868
Posts

 
Drives: Z4 s30i
Join Date: Mar 2007
Location: The Villages, FL

iTrader: (0)

Garage List
Definitive,

Several of us have the same issue. DOes not happen when iPod out of car.

Seems that after 90 seconds with car turned off the power is removed formt eh iPod. Ocassionally the iPod DOES NOT SHUT DOWN as it should 90 seconds later.

Has to be something in the connections that keeps it turned on (with backlight off) and eventually it destroys the battery !!

No fix yet !!
__________________

M3 GTR - 1/5 scale - 4.2 HP w/ Collari hydraulic brakes - would you believe ~80 MPH on straightaway !!
Appreciate 0
      07-11-2007, 05:49 PM   #19
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Yea... and that's another issue aside from it changing to the radio by itself...

And the two are not related as I just charged my ipod up all the way. and it did it two minutes after I started driving.

The worst part is that its intermitant. Sometimes it won't do it at all. And sometimes its every 2 minutes...

D
__________________
Appreciate 0
      07-18-2007, 11:59 AM   #20
Definitive
definitivecars.com
Definitive's Avatar
United_States
94
Rep
3,793
Posts

 
Drives: Elsa - 2015 F80 M3 - YMB/SS
Join Date: Aug 2006
Location: So Cal

iTrader: (3)

Garage List
Send a message via AIM to Definitive Send a message via MSN to Definitive
Good News guys!!!!! Just spoke to the dealer, and there is a recall for this issue that was released yesterday!!! Its a software upgrade! I already made my apt to get it done...

I hope it fixes everything!

Definitive
__________________
Appreciate 0
      07-18-2007, 12:31 PM   #21
SoYank
Major General
SoYank's Avatar
United_States
88
Rep
7,504
Posts

 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
Quote:
Originally Posted by Definitive View Post
The worst part is that its intermitant. Sometimes it won't do it at all. And sometimes its every 2 minutes...

D
...and how many songs are two minutes or less in length?
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
Appreciate 0
      07-18-2007, 10:39 PM   #22
YVR335i
Enlisted Member
0
Rep
32
Posts

 
Drives: E92 335i Graphite
Join Date: Feb 2007
Location: Vancouver

iTrader: (0)

Definitive,

I had talked to BMW Customer Service in Canada last week and they indicated that a fix may be released this week. Your info appears to confirm this - great news! Thanks for letting us know. Do you know if there's a reference number or file number for the recall? Before I call my dealer, I'd like to have some info for them to look up.

Funny thing - when I brought this issue to their attention last week, my dealer said it was the first they heard of it. I gave them the PUMA file number that someone else had posted on Bimmerfest, they took a day or two, and then they called back and said "Yes, there is a problem but no fix."

Again, as someone else had posted, it's a shame that we have to call the service department and tell them about fixes to our (in my case, brand new) cars.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST