E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Misfire/stumble at cold start



Reply
 
Thread Tools Search this Thread
      05-12-2016, 01:00 PM   #1
YoungBlood
Private First Class
16
Rep
167
Posts

Drives: e90 335i Alpine White
Join Date: Mar 2016
Location: Utah

iTrader: (0)

Misfire/stumble at cold start

I recently did plugs, and a coil, due to a misfire. Now, on cold starts, for the first minute or so while I let the car warm up, I can feel a misfire, or stumble. No code or anything. If I run a log at idle with MHD, would I be able to determine if it's a leaking injector(s)? Is this a symptom of a bad injector? I plan to pull the injectors and check soon, but if I can run a log to diagnose the bad one that would be sweet. What should I look for in an idle/cold start log? Fwiw, plugs looked fine, and just did an oil change and it seemed normal (no fuel smell)
Appreciate 0
      05-12-2016, 01:29 PM   #2
bigdnno98
Lieutenant Colonel
bigdnno98's Avatar
United_States
97
Rep
1,672
Posts

Drives: 335is DCT
Join Date: Jul 2011
Location: Clarksville, TN

iTrader: (8)

It is definitely a sign of a leaky injector. Let the car sit overnight. In the morning before you start it, pull the spark plugs. See if any are wet or smell like gas. Should be a tell tale sign. You may be able to see visual signs of failing injectors by pulling them and looking at the tips but this is not always the case.
__________________
2011 335is DCT, JB4 MHD BEF, stage 2 LPFP, e50 50/50 meth, FBO, MT ET Streets when needed
Appreciate 0
      05-12-2016, 01:41 PM   #3
YoungBlood
Private First Class
16
Rep
167
Posts

Drives: e90 335i Alpine White
Join Date: Mar 2016
Location: Utah

iTrader: (0)

That's what I figured.. Holy shit I've had this car for 2 months and had every issue in the book haha. Hpfp, WG rattle, vanos, coil, and now injectors. Sigh... I would've traded it right back in if it showed these issues earlier on. I'll try the plug test. Are there any other ways of diagnosing this?
Appreciate 0
      05-12-2016, 03:29 PM   #4
bigdnno98
Lieutenant Colonel
bigdnno98's Avatar
United_States
97
Rep
1,672
Posts

Drives: 335is DCT
Join Date: Jul 2011
Location: Clarksville, TN

iTrader: (8)

Quote:
Originally Posted by YoungBlood View Post
That's what I figured.. Holy shit I've had this car for 2 months and had every issue in the book haha. Hpfp, WG rattle, vanos, coil, and now injectors. Sigh... I would've traded it right back in if it showed these issues earlier on. I'll try the plug test. Are there any other ways of diagnosing this?
I'll never own a BMW out of warranty LOL. Not really on the injectors.
__________________
2011 335is DCT, JB4 MHD BEF, stage 2 LPFP, e50 50/50 meth, FBO, MT ET Streets when needed
Appreciate 0
      05-12-2016, 03:34 PM   #5
YoungBlood
Private First Class
16
Rep
167
Posts

Drives: e90 335i Alpine White
Join Date: Mar 2016
Location: Utah

iTrader: (0)

Well, hpfp was warrantied, and plugs and coil were $150, and vanos I just cleaned out, so not bad as far as cost, but headache/ work, that's another story haha
Appreciate 0
      05-12-2016, 03:41 PM   #6
bigdnno98
Lieutenant Colonel
bigdnno98's Avatar
United_States
97
Rep
1,672
Posts

Drives: 335is DCT
Join Date: Jul 2011
Location: Clarksville, TN

iTrader: (8)

Quote:
Originally Posted by YoungBlood View Post
Well, hpfp was warrantied, and plugs and coil were $150, and vanos I just cleaned out, so not bad as far as cost, but headache/ work, that's another story haha
I've been drag racing Mitsubishis for years. I'd rather be replacing coils, plugs and injectors on an N54, than transmissions, axles and transfer cases on Mitsubishis LOL.
__________________
2011 335is DCT, JB4 MHD BEF, stage 2 LPFP, e50 50/50 meth, FBO, MT ET Streets when needed
Appreciate 0
      05-12-2016, 03:55 PM   #7
Drummin335i
New Member
0
Rep
12
Posts

Drives: 2009 335i E90
Join Date: Jan 2016
Location: DFW, TX

iTrader: (0)

Same issue started recently for me. In for results.

Would valve cover gasket cause the rough idle/stumble on cold start? I am about to replace my VCG this weekend due to leakage.
Appreciate 0
      05-12-2016, 03:58 PM   #8
ritzzzzzwik
Lieutenant
ritzzzzzwik's Avatar
53
Rep
441
Posts

Drives: 2007 335i MT
Join Date: Oct 2014
Location: NOVA

iTrader: (0)

curious. how many miles?
__________________
2007 335i E92 MT | MHD/Wedge Tuned 93Oct | Stg2 lpfp BoostConcepts | VRSF DPs | VRSF 5" SteppedFMIC | DCI | VRSF CP | BMW SSK | Koni FSD | M3 Control Arms | Whiteline Rear SF Inserts | M219s + PSS | PE Mod
Appreciate 0
      05-17-2016, 04:25 PM   #9
YoungBlood
Private First Class
16
Rep
167
Posts

Drives: e90 335i Alpine White
Join Date: Mar 2016
Location: Utah

iTrader: (0)

90k, however, I noticed it was just a small misfire at idle all the time, even warm start. Ran a thing on techron through it and its a bit better. Need to check my plugs for leaking injectors, and walnut blast.. 90k and no walnut blast, might be part of the issue, or my one coil of a different brand
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:39 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST