E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > BMW 335i Long Crank/Carbon buildup/Rough Idling/Service Engine Light



Reply
 
Thread Tools Search this Thread
      05-10-2012, 12:50 PM   #1
dr09
Registered
 
Drives: 335i
Join Date: May 2012
Location: Toronto

Posts: 2
iTrader: (0)

BMW 335i Long Crank/Carbon buildup/Rough Idling/Service Engine Light

I have a 2007 335i which I bought used last year. Since then I have had tremendous problems with the car. Initially, it was just the long crank, which would only happen occasionally, and usually after it had been cold for 12+ hours, combined with kicking out black exhaust, and a carbon build-up in the engine. It eventually progressed into RPMs when I turned on the car, and rough idling when sitting at a light, and then moved on to a more significant "shuddering" and a service engine light.

Initially, I had thought it was the HPFP, and had it replaced. Now, the service engine light has come on several times spitting out a code that sayis a different cylinder is misfiring each time. I have replaced the misfiring coils in the various cylinders that have errored, and all the spark plugs. However, since then it has spit out a new "Service Engine Soon" light. I have constantly felt like they keep fixing the symptom, without thinking about the underlying cause.

The current hypothesis on the underlying cause is that the fuel injectors are leaking into the engine, causing the it burn off the excess fuel (which leads to the high RPMs and rough idling), as well as the black exhaust.

Does this sound like the right diagnosis? Has anyone had similar issues and had different issues that I might also need to address?

Thanks!
dr09 is offline  
0
Reply With Quote
      05-10-2012, 01:51 PM   #2
djjasper
Lieutenant
 
djjasper's Avatar
 
Drives: 2007 E92 335i 6MT
Join Date: Dec 2011
Location: PA

Posts: 512
iTrader: (0)

You may have wasted your time on the coils and plugs if you didn't pin down the problem. SES light is common when an injector is going bad but the same error code is reported- misfire on cylinder x.
__________________
djjasper is offline   United_States
0
Reply With Quote
      05-10-2012, 08:22 PM   #3
philiphilip
New Member
 
philiphilip's Avatar
 
Drives: Graphite 2008 BMW 335i SP
Join Date: Jan 2012
Location: Springfield, VA

Posts: 27
iTrader: (0)

I had the same thing exactly. It took 5 months and 4 dealer appointments between 2 different dealers to find the issue. first the did software update - no change. Then new hpfp - no change. New spark plugs - no change. Finally got all the injectors replaced last november, its been running like a dream ever since. So good chance same thing will help you out.
philiphilip is offline   United_States
0
Reply With Quote
      05-11-2012, 10:11 AM   #4
GRLPWR
Lieutenant
 
GRLPWR's Avatar
 
Drives: '07 335i
Join Date: Aug 2010
Location: Durham, NC

Posts: 488
iTrader: (0)

Garage List
2007 335i  [0.00]
+1 on injectors. I had the same shuddering/misfire problem and it ended up being due to a previous mechanic failing to install the decouplers when replacing the injectors. I also recently had a carbon cleaning. Runs great.

2007 335i approx 86k miles.
GRLPWR is offline   United_States
0
Reply With Quote
      05-11-2012, 02:14 PM   #5
PTinVT
armchair enthusiast
 
PTinVT's Avatar
 
Drives: 07 328xi, 02 325Cic
Join Date: Feb 2009
Location: Burlington, VT

Posts: 579
iTrader: (1)

Can't help, but just wondering how many miles on OP car.
__________________
07 328xi coupe SG/Dakota leather, 6-speed manual, sport/premium/cold
02 325Cic vert AW/Montana leather, 5-speed manual, premium/removable hardtop
93 850Ci Oxford Green/Parchment, auto
71 Buick Riviera, 455 V8 land yacht
PTinVT is offline   United_States
0
Reply With Quote
      07-12-2012, 12:34 PM   #6
dr09
Registered
 
Drives: 335i
Join Date: May 2012
Location: Toronto

Posts: 2
iTrader: (0)

Approximately 62000 miles.

Replaced 2 fuel injectors that were associated with the misfiring cylinders. SES went away and long crank is gone. However there is still some shuddering when I start it up, which eventually goes away if I drive long enough. Could this mean there are still faulty injectors, or something else?
dr09 is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
335i, fuel injectors, hpfp, long cranks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:07 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST