E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > My wastegate rattle



Reply
 
Thread Tools Search this Thread
      05-02-2014, 09:54 AM   #1
oshusttoley
Captain
7
Rep
678
Posts

 
Drives: 2008 335i sedan
Join Date: Mar 2012
Location: New Jersey

iTrader: (0)

My wastegate rattle

So I have brand new turbos that have less then 1k miles on them. When I had the stock down pipes on no jb4 I had zero rattle. I put downpipes on with jb4, now every time I do light throttle from 2k to 3k I get this horrible rattle noise . If I rev not in gear, no rattle. No matter what setting I put menu 10 and 12. It doesn't help. If I put menu 10 to saying 20 on tach, I instantly get horrible rattle. Any ideas?
__________________
// JB4 ISO // Running Meth // Full FBO // E85 user //
Appreciate 0
      05-02-2014, 10:03 AM   #2
Cloud9blue
Lieutenant Colonel
Cloud9blue's Avatar
United_States
35
Rep
1,614
Posts

 
Drives: avoiding the potholes
Join Date: Aug 2008
Location: Chicago, IL

iTrader: (11)

Seems to be a relatively widespread issue on the newest firm of JB4. Which hardware if your JB? Is it the G5 ISO?

I have similar issue, but only a faint rattle at partial throttle acceleration that can only be heard in a quite parking garage. I felt the WG actuator rod the other day, it seems to have very minimal play... Oh well, just waiting to get my new exhaust mounted so it can drown out the noise.

But if your rattle is really bad, you can try adjusting them through this guide: http://www.e90post.com/forums/showthread.php?t=176269 However, I still think the proper to adjust the actuator rod is with the downpipe off and have a vacuum pulling the WG closed so you can see how much adjustment you actually need. For me, it is just not worth the trouble.
__________________
09 E92 335i AT: Monaco Blue / Saddle Brown / Grey Poplar
JB4 / BMS Flash / AE / DP/FMIC / TC Kline DA / M3/Megan / Wavetrac / Powerflex/Whiteline / Dinan OC / Aux. Radiator / Apex PS-7
07 BMW R1200S: Shine Yellow / Akrapovic Slip-on / Ohlins
Appreciate 0
      05-02-2014, 12:35 PM   #3
iturbo_bmw
Captain
iturbo_bmw's Avatar
United_States
9
Rep
634
Posts

 
Drives: 2009 335i e92
Join Date: Oct 2012
Location: Bay Area, CA

iTrader: (0)

hhm so maybe the jb4 is the culprit.. but how? I kinda want to try a cobb tune to see if it would get rid of the rattle but not sure the price is worth it for this experiment
__________________
09 335i e92 n54 | AW on CR | AT w/ Alpina Flash | JB4 G5 ISO w/ e85 BMS flash| BMS DCI | ETS 5" FMIC | VRSF DP | TCK SA Coilovers | Vorshlag Camber Plates | M3 CAs | ARC 8 18x9 F 18x9.5R | 255/35 275/35 mich pss |
Appreciate 0
      05-02-2014, 12:40 PM   #4
oshusttoley
Captain
7
Rep
678
Posts

 
Drives: 2008 335i sedan
Join Date: Mar 2012
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by iturbo_bmw
hhm so maybe the jb4 is the culprit.. but how? I kinda want to try a cobb tune to see if it would get rid of the rattle but not sure the price is worth it for this experiment
Idk but I have brand new turbos that didn't make a peep until I put the jb4 and downpipes back on. Could the rod need to be adjusted for the extra flow?
__________________
// JB4 ISO // Running Meth // Full FBO // E85 user //
Appreciate 0
      05-02-2014, 12:41 PM   #5
oshusttoley
Captain
7
Rep
678
Posts

 
Drives: 2008 335i sedan
Join Date: Mar 2012
Location: New Jersey

iTrader: (0)

Quote:
Originally Posted by Cloud9blue
Seems to be a relatively widespread issue on the newest firm of JB4. Which hardware if your JB? Is it the G5 ISO?

I have similar issue, but only a faint rattle at partial throttle acceleration that can only be heard in a quite parking garage. I felt the WG actuator rod the other day, it seems to have very minimal play... Oh well, just waiting to get my new exhaust mounted so it can drown out the noise.

But if your rattle is really bad, you can try adjusting them through this guide: http://www.e90post.com/forums/showthread.php?t=176269 However, I still think the proper to adjust the actuator rod is with the downpipe off and have a vacuum pulling the WG closed so you can see how much adjustment you actually need. For me, it is just not worth the trouble.
Yes newest firmware. Also have the newest firmware from BMW too. Never had a problem until jb4 and down pipes. Specially on brand new turbos... And with out jb4 my turbos were rattle free 100%
__________________
// JB4 ISO // Running Meth // Full FBO // E85 user //
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:46 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST