E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Misfire reoccur??



Reply
 
Thread Tools Search this Thread
      05-13-2012, 04:27 PM   #1
Chrisred
Captain
 
Chrisred's Avatar
 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

Posts: 738
iTrader: (0)

Can a misfire reoccur on same cylinder if all spark plugs been replaced and that same injector and coil have also been replaced.

Changed cyl 2&3 coils and injectors like 8 months ago. Just reinstalled tune and now a misfire on cyl 3 plus loss of power on wot with increased boost. Also sounds like. Subaru with exhaust lol
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Chrisred is offline   Canada
0
Reply With Quote
      05-13-2012, 04:44 PM   #2
skim7x
Use it or Lose it
 
skim7x's Avatar
 
Drives: 335i e92
Join Date: Sep 2006
Location: Clifton, NJ

Posts: 2,461
iTrader: (4)

Garage List
2007 335i  [5.00]
Quote:
Originally Posted by Chrisred View Post
Can a misfire reoccur on same cylinder if all spark plugs been replaced and that same injector and coil have also been replaced.

Changed cyl 2&3 coils and injectors like 8 months ago. Just reinstalled tune and now a misfire on cyl 3 plus loss of power on wot with increased boost. Also sounds like. Subaru with exhaust lol
You might have to change spark plugs again... I had my plugs replaced by BMW and only about 12,000 miles later, I started getting misfires. Replaced spark plugs and misfires are completely gone. And the plug that was in the misfiring cylinder was visibly worn down more than the other spark plugs.
__________________
'07 Space Gray 335i coupe w/ Sports Package | Comfort Access

Cobb S1+ | PTF e30 custom tune | AMS | CP-e | BMS OCC | Quaife
[Newark Photoshoot #1]
skim7x is offline   United_States
0
Reply With Quote
      05-13-2012, 05:37 PM   #3
GeorgiaTech335coupe
Lieutenant Colonel
 
Drives: Black BMW 335i coupe
Join Date: Mar 2007
Location: USA

Posts: 1,884
iTrader: (0)

Could be fuel pump too. But to answer your question, yes, it could be one of the same parts again. It sucks, but it could happen.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
GeorgiaTech335coupe is offline  
0
Reply With Quote
      05-13-2012, 06:24 PM   #4
Chrisred
Captain
 
Chrisred's Avatar
 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

Posts: 738
iTrader: (0)

Could bad O2 sensors also cause this?? I also get random shaking while driving....
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Chrisred is offline   Canada
0
Reply With Quote
      05-13-2012, 06:35 PM   #5
Eracer76
Second Lieutenant
 
Eracer76's Avatar
 
Drives: 2008 E92 335xi
Join Date: Nov 2011
Location: IL

Posts: 239
iTrader: (5)

Who installed the parts? Do you know for sure if the injectors were coded properly, or if the coupler rings were installed on the injectors? You'd be surprised how even BMW dealers miss those things. Because even a non coded injector with a missing coupler ring will still work ok for awhile, but throw a tune on it, and will go bad quickly... Dont ask me how I know... Let's just say now that my car is out of warranty, it's never going back to a dealer again!
__________________
Gone >2008 BMW 335xi E92: 11.988 @ 114.080 MPH
BMS JB4 G5, WW meth kit, OCC ~ Stett CAI ~ Helix FMIC ~ ER Charge Pipe w/Tial BOV ~AR Catless DP~ Aero Front Lip ~ BMS LED Angel Eyes ~ Black Kidney Grills ~ Painted Lower Grills
Painted Reflectors ~ Aluminum Pedals ~ 35% window tint ~ Painted Calipers/Rotors ~ KW V1 Coilovers ~ 19" Avant Garde M310's 235/35 & 275/30 G-Max AS-03 tires
Eracer76 is offline   United_States
0
Reply With Quote
      05-13-2012, 06:38 PM   #6
Chrisred
Captain
 
Chrisred's Avatar
 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

Posts: 738
iTrader: (0)

Quote:
Originally Posted by Eracer76
Who installed the parts? Do you know for sure if the injectors were coded properly, or if the coupler rings were installed on the injectors? You'd be surprised how even BMW dealers miss those things. Because even a non coded injector with a missing coupler ring will still work ok for awhile, but throw a tune on it, and will go bad quickly... Dont ask me how I know... Let's just say now that my car is out of warranty, it's never going back to a dealer again!
BMW mech actually
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Chrisred is offline   Canada
0
Reply With Quote
      05-14-2012, 03:11 PM   #7
Chrisred
Captain
 
Chrisred's Avatar
 
Drives: BMW 335xi coupe
Join Date: Jan 2010
Location: Montreal, Canada

Posts: 738
iTrader: (0)

Update. Did a couple pulls today on map 5. I got that reduced power feeling and CEL flashing. Codes are misfires on 4 5 6 cyl and on multiple cyl plus the obvious lambda codes. Yesterday the misfire was only on cyl 3. Weird.....
__________________
JB4 cp-e IC AMS exhaust BMS DCI AR DP's METH
19" VMR VB3 Stoptech BBK TC KLINE VORSHLAG
Chrisred is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:49 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST