E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 330i Transmission problem on switching back to 1st gear



Reply
 
Thread Tools Search this Thread
      03-21-2013, 11:54 AM   #23
yaskonb
New Member
0
Rep
8
Posts

 
Drives: 2006 325i
Join Date: Feb 2013
Location: Orange County

iTrader: (0)

I had the same thing happen of my 2006 325i. INPA resets would only help for about two weeks and then the problem would come back. Ended up getting a new valve body and it's been 4 months with no problems so far. Valve body is an expensive job, so I would only do it if nothing else works and you can't live with the jolt. After mine was fixed I did hear that setting the idle values ~100 rpm higher can fix the problem but I never got the chance to try this.
Appreciate 0
      03-23-2013, 02:19 PM   #24
RyanBMW
Private
United_States
0
Rep
51
Posts

 
Drives: 2011 F10 550i
Join Date: Dec 2011
Location: Plano, TX

iTrader: (0)

I have an 08 328i w/ 55K miles and it does it sometime too, it scares the shit out of me the first time because l almost rear ended the car in front of me. Mine does it very randomly so l do not know when to expect, very annoying and scary. I have searched on this forum and people said it's a common problem with the N52 tranny. Some said they feel like they got rear ended when that happens. I have not flushed my tranny fluid yet..!!

I hope that helps..You're not the only bro!! Bimmer

Planning to keep my Bimmer another year and then getting the Lexus GS-F, not planning to deal with all the Bimmer headaches!

BMW=nice car, drives great, but too many problems!! I guess the myth is true!
Appreciate 0
      03-31-2013, 05:22 AM   #25
testdriver
Private
2
Rep
65
Posts

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK

iTrader: (0)

Quote:
Originally Posted by nirgutman View Post
Hi Testdriver,

I've been searching every website to see if anyone else had this problem. My 328i sport does the same exact thing ! It kicks/jumps right as i slow down to the 10mph mark. Every time, I took it to the dealer and drove with a mechanic. It stopped doing it right then and there. As soon as I left the lot it returned and has gotten really bad, sometimes the whole car shakes.

Have you figured out what it is yet? It's driving me crazy.

Not yet..... but I believe it has something to do with software.
Appreciate 0
      03-31-2013, 05:25 AM   #26
testdriver
Private
2
Rep
65
Posts

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK

iTrader: (0)

Quote:
Originally Posted by evssss1 View Post
Same symptom in my 05 325i. Try resetting the adaptation in INPA which will help. But it is just a matter of time this weird jump is coming back and then another reset will help for a period.

Let me know if changing ATF will oil pan helps.....
Although I believe it has to do with software, one shop insist I should change the ATF with oil pan......... job completed and the Problem is same like yesterday.

I can 90% sure it has something to do with software.
Appreciate 0
      03-31-2013, 05:28 AM   #27
testdriver
Private
2
Rep
65
Posts

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK

iTrader: (0)

Quote:
Originally Posted by yaskonb View Post
I had the same thing happen of my 2006 325i. INPA resets would only help for about two weeks and then the problem would come back. Ended up getting a new valve body and it's been 4 months with no problems so far. Valve body is an expensive job, so I would only do it if nothing else works and you can't live with the jolt. After mine was fixed I did hear that setting the idle values ~100 rpm higher can fix the problem but I never got the chance to try this.
INPA reset? I guess my shop reset my ecu many times but I didn't feel a thing different.

As for the Valve Body change..... can you tell me more about that.

Thank you.
Appreciate 0
      03-31-2013, 04:52 PM   #28
Tony v
Second Lieutenant
Tony v's Avatar
2
Rep
232
Posts

 
Drives: bmw 330i benz cls500
Join Date: Jan 2013
Location: bay area

iTrader: (0)

mine just started with this to i was also thinking transmission mounts worn ? but seems more on software side
Appreciate 0
      03-31-2013, 05:32 PM   #29
yaskonb
New Member
0
Rep
8
Posts

 
Drives: 2006 325i
Join Date: Feb 2013
Location: Orange County

iTrader: (0)

Quote:
Originally Posted by testdriver View Post
INPA reset? I guess my shop reset my ecu many times but I didn't feel a thing different.

As for the Valve Body change..... can you tell me more about that.

Thank you.
As far as I understand, the valve body is what controls the transmission. Some parts of it are made of plastic so they wear out over time. This leads to rougher shifts, such as the rough downshift from 2-1. I already had an aftermarket warranty on my car(through EasyCare) and luckily they paid for the new valve body because it was like a $3000 job. Hope this helps
Appreciate 0
      04-02-2013, 06:08 PM   #30
kosherthunder
New Member
0
Rep
8
Posts

 
Drives: 2013 BMW 328i Sport Line
Join Date: Nov 2012
Location: Los Angeles

iTrader: (0)

Turns out it was the Heat Exchange that was leaking tfluid which caused the jerky shifting :P
Appreciate 0
      04-06-2013, 01:10 AM   #31
testdriver
Private
2
Rep
65
Posts

 
Drives: E92 M3
Join Date: Jan 2012
Location: HK

iTrader: (0)

Quote:
Originally Posted by nirgutman View Post
Turns out it was the Heat Exchange that was leaking tfluid which caused the jerky shifting :P
You mean leaking tranny fluid? That may not be my case as I don't see any drops of fluids on my garage floor.

Anyway, I'm glad you solve the problem on yours.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST