E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > N54 Water Pump



Reply
 
Thread Tools Search this Thread
      05-31-2012, 12:36 AM   #1
tropical335i
Private
 
tropical335i's Avatar
 
Drives: 335i LCI MSPORT
Join Date: Oct 2007
Location: mauritius

Posts: 98
iTrader: (0)

N54 Water Pump

Hi Guys just wanted to know how often the N54 water pump fails,if this is a common issue and if BMW have come up with a fix for that.
Cheers.
tropical335i is offline   Mauritius
0
Reply With Quote
      05-31-2012, 04:13 AM   #2
BES335xi
Colonel
 
BES335xi's Avatar
 
Drives: FBO+ N54xi
Join Date: Mar 2008
Location: Queens, NYC

Posts: 2,133
iTrader: (4)

Garage List
03/07 E90 335xi  [0.50]
Failed on me once so far i'm at 50k, seems like they fail once and then ur good for another 50 or so im assuming lol
__________________
JB4+usb | P3 Vent Boost Gauge v2 | BMS OCC | BMS DCI | AMS FMIC | AR xi CL DP's | BT Tool | Edibias/NCSExpert/INPA BMW Coding | Cyba Quad Exhaust tips | M-Tech Rear & M3 Front Bumper | Red Cyba Air Scoops | Blacklines | Vinyl Overlays | ACS Roof Spoiler | Matte Black Grilles | LED Side Mirrors | Rear Euro Fogs | etc..
.
BES335xi is offline   Albania
0
Reply With Quote
      05-31-2012, 06:09 AM   #3
Randomaccess335
Captain
 
Randomaccess335's Avatar
 
Drives: 07' 335I
Join Date: Mar 2011
Location: boynton beach, Fl

Posts: 674
iTrader: (9)

My went out @ 50k also
__________________

JB4 G5 ISO , BMS DCI's, Stock Guted DP's, DO Meth kit Trunk Mount, ETS 5" Intercooler, M6 Rims, ER Charge Pipe, Fordged DV's
Cybe 3.8" chrome Tips, Lux Angel Eyes
**********12.07 @ 116***1.99 60'**********
Randomaccess335 is offline  
0
Reply With Quote
      05-31-2012, 06:50 AM   #4
Zasquatch
Captain
 
Zasquatch's Avatar
 
Drives: '07 BMW 335i
Join Date: Sep 2010
Location: CT

Posts: 621
iTrader: (15)

Garage List
2007 BMW 335i  [0.00]
Mine is still runnging strong (i hope) 60k
Zasquatch is offline   United_States
0
Reply With Quote
      05-31-2012, 07:28 AM   #5
Lulz_M3
Banned
 
Drives: AW 335i 6MT
Join Date: Oct 2011
Location: Jax, Fl

Posts: 1,029
iTrader: (0)

Quote:
Originally Posted by Zasquatch View Post
Mine is still runnging strong (i hope) 60k
Yours will probably fail in the next 5k miles, you may want to order one from tischer to have on standby lol.. Seems like they often fail at 63k.
Lulz_M3 is offline   United_States
0
Reply With Quote
      05-31-2012, 07:43 AM   #6
Juiced46
Major
 
Drives: 03 Turbo Cobra, 2011 335xi
Join Date: Jun 2010
Location: Wallingford CT

Posts: 1,023
iTrader: (3)

Quote:
Originally Posted by Lulz_M3 View Post
Yours will probably fail in the next 5k miles, you may want to order one from tischer to have on standby lol.. Seems like they often fail at 63k.
Yes BMW programmed the pumps to fail at exactly 63k lol
Juiced46 is offline  
0
Reply With Quote
      05-31-2012, 07:51 AM   #7
Lulz_M3
Banned
 
Drives: AW 335i 6MT
Join Date: Oct 2011
Location: Jax, Fl

Posts: 1,029
iTrader: (0)

Quote:
Originally Posted by Juiced46 View Post
Yes BMW programmed the pumps to fail at exactly 63k lol
Obviously thats not the case, but i just helped my friend replace his waterpump and thermostat on his 535 and spent a few hours reading all of the threads on waterpump replacement to get a feel for how difficult it was. Most of the people commenting in those threads said theirs failed at 63k miles, i see no harm in assuming mine, as well as others will fail around that mark.
Lulz_M3 is offline   United_States
0
Reply With Quote
      05-31-2012, 08:24 AM   #8
Laid Black 335i
BMW
 
Laid Black 335i's Avatar
 
Drives: 2007 BMW 335i (6MT)
Join Date: Mar 2011
Location: MD

Posts: 975
iTrader: (7)

Quote:
Originally Posted by Juiced46 View Post
Yes BMW programmed the pumps to fail at exactly 63k lol
Oh shiet... I'm at 62,470 right now... yes, I just hopped out of my car and that's the exact mileage.
__________________
Laid Black 335i is offline   United_States
0
Reply With Quote
      05-31-2012, 08:40 AM   #9
Jason@Tischer
BimmerPost Supporting Vendor

 
Jason@Tischer's Avatar
 
Drives: 2012 Civic Si Coupe
Join Date: Jul 2007
Location: Silver Spring, MD

Posts: 3,208
iTrader: (14)

Send a message via AIM to Jason@Tischer
We've assembled complete E9X Water Pump/Thermostat Kits on special here on this page of our site.

Prices include Free Ground Shipping w/in the US.

In stock and ready to go!
__________________
Jason Reighard
Internet Parts Manager, getBMWparts.com

Email getHelp@getBMWparts.com AIM: Jason at Tischer
Follow us on: FaceBook | Twitter | YouTube
Jason@Tischer is offline   United_States
0
Reply With Quote
      05-31-2012, 09:08 AM   #10
BoostedE90
Lieutenant Colonel
 
BoostedE90's Avatar
 
Drives: e90 335i 6MT
Join Date: Nov 2007
Location: Tampa/Gainesville, FL

Posts: 1,623
iTrader: (5)

This thread is making me nervous. About to clock 60k on mine.
BoostedE90 is offline   United_States
0
Reply With Quote
      05-31-2012, 09:16 AM   #11
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,344
iTrader: (86)

I just passed 80K with no issues

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      05-31-2012, 09:17 AM   #12
bigairjohn
New Member
 
Drives: 335xi
Join Date: Oct 2011
Location: Michigan

Posts: 5
iTrader: (0)

Went to the dealer had brake fluid changed drive home an pump failed on the way, 52k
bigairjohn is offline  
0
Reply With Quote
      05-31-2012, 09:23 AM   #13
bimmertt
Lieutenant Colonel
 
bimmertt's Avatar
 
Drives: 2007 e92 335i
Join Date: Nov 2008
Location: Earth

Posts: 1,671
iTrader: (7)

Not sure of there is a correlation, but it might be helpful to list if you've ever changed the coolant.
bimmertt is offline  
0
Reply With Quote
      05-31-2012, 09:38 AM   #14
tropical335i
Private
 
tropical335i's Avatar
 
Drives: 335i LCI MSPORT
Join Date: Oct 2007
Location: mauritius

Posts: 98
iTrader: (0)

Thanks for your input guys,mine failed at 52k so was thinking of buying 2 pieces so i will be quiet till i retire the car LOL.
tropical335i is offline   Mauritius
0
Reply With Quote
      05-31-2012, 09:40 AM   #15
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Mine went out at 108K miles.

The waterpump has always been a weak link with BMWs. I had it go up on my E36 (common problem), they've gone out on E46s as well.
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      05-31-2012, 09:41 AM   #16
zanelefko
Lieutenant
 
zanelefko's Avatar
 
Drives: E92 335i
Join Date: Jan 2012
Location: So Fla

Posts: 404
iTrader: (0)

im at 94k with zero problems..FBO too if that matters
__________________
VRSF DP / DCI / JB4 / ETS FMIC / ETS Charge pipe / Tial BOV /
zanelefko is offline  
0
Reply With Quote
      05-31-2012, 09:51 AM   #17
ETS Michael
 
ETS Michael's Avatar
 
Drives: 335i
Join Date: May 2009
Location: Vancouver, WA

Posts: 1,160
iTrader: (4)

Send a message via AIM to ETS Michael
Failed last night at 66k. :\ No warning signs... went to the gym the radiator fan was running really loud and it was only 70 deg. outside. Came back out from the gym, the car was still warm?! Ohhh really.. went grocery shopping across the street, back out side... car still warm?! on the way home orange coolant light, than immediate red light.. Limp mode. Lucky i only live less than 2 miles from the gym. Limped the car home have several cool downs. Seems right at 250 deg. the car freaks out into limp mode.
ETS Michael is offline   United_States
0
Reply With Quote
      05-31-2012, 09:54 AM   #18
TwinTurboXI
Major
 
Drives: 2011 135i
Join Date: Mar 2008
Location: Pittsburgh

Posts: 1,365
iTrader: (9)

75k on the original thermostat and pump.
TwinTurboXI is offline  
0
Reply With Quote
      05-31-2012, 10:57 AM   #19
ETS Michael
 
ETS Michael's Avatar
 
Drives: 335i
Join Date: May 2009
Location: Vancouver, WA

Posts: 1,160
iTrader: (4)

Send a message via AIM to ETS Michael
I could see how this could screw someone over. Especially with the limp mode during rush hour or on the freeway where you have no shoulder.
ETS Michael is offline   United_States
0
Reply With Quote
      05-31-2012, 11:03 AM   #20
ZJP
Lieutenant Colonel
 
Drives: F10 535xi / JK Wrangler
Join Date: Jan 2008
Location: LI, NY

Posts: 1,758
iTrader: (7)

Mine failed somewhere around 44k miles.
ZJP is offline   United_States
0
Reply With Quote
      05-31-2012, 12:42 PM   #21
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Quote:
Originally Posted by ETS Michael View Post
I could see how this could screw someone over. Especially with the limp mode during rush hour or on the freeway where you have no shoulder.
This.

Happened to me on the highway on Rt 100 and I had to cut over a couple lanes while I still had power and then blam.

Luckily my mechanic was 1-2 miles away but it took me 15 minutes because I had to shut down every couple minutes.
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      05-31-2012, 12:52 PM   #22
ETS Michael
 
ETS Michael's Avatar
 
Drives: 335i
Join Date: May 2009
Location: Vancouver, WA

Posts: 1,160
iTrader: (4)

Send a message via AIM to ETS Michael
Quote:
Originally Posted by Jed View Post
This.

Happened to me on the highway on Rt 100 and I had to cut over a couple lanes while I still had power and then blam.

Luckily my mechanic was 1-2 miles away but it took me 15 minutes because I had to shut down every couple minutes.
I wish i could find a DIY for this, I'm just going to man up and do it, but instructions are always nice.
ETS Michael is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:19 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST