E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > N54 water pump issues by model year.



Reply
 
Thread Tools Search this Thread
      05-31-2012, 08:22 PM   #23
themyst
Major General
 
themyst's Avatar
 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

Posts: 6,598
iTrader: (8)

Send a message via AIM to themyst
Well when I did turbos on my car I did observe my water pump is plastic... Is that a good thing?
__________________
E90 LCI N54 6AT
themyst is offline   South Korea
0
Reply With Quote
      05-31-2012, 08:42 PM   #24
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
4/07 7000 miles!! Piece of shit crap out on me
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      05-31-2012, 08:51 PM   #25
Carl Morris
Captain
 
Drives: 2008 335xi 6MT
Join Date: Feb 2012
Location: Boulder, CO

Posts: 626
iTrader: (0)

08 335xi, built in late 07. Went out at 60k. Replacement didn't make it out of the shop and another one had to be ordered. It's been fine so far.

I got to inspect the original. The impeller looked fine and the bearing were not loose. It was very hard to turn by hand, though.
Carl Morris is offline  
0
Reply With Quote
      05-31-2012, 08:53 PM   #26
jpsimon
Team Zissou
 
jpsimon's Avatar
 
Drives: 335xi Coupe 6MT
Join Date: Dec 2006
Location: CT

Posts: 8,982
iTrader: (4)

Quote:
Originally Posted by Carl Morris View Post
08 335xi, built in late 07. Went out at 60k. Replacement didn't make it out of the shop and another one had to be ordered. It's been fine so far.

I got to inspect the original. The impeller looked fine and the bearing were not loose. It was very hard to turn by hand, though.
my xi is right around the same as yours. I'm at almost 80k miles on the original water pump.
__________________
www.datazap.me - fast, free, interactive data log viewing / PROcede+OpenFlash, PWM meth + ADVAN in-boot meth tank, Vargas S2 Turbos, AMS fmic, catless (ur+ae), SPEC clutch/flywheel, KW V3 coilovers, thule flat-top 6 ski rack, etc etc etc...

jpsimon is offline   United_States
0
Reply With Quote
      05-31-2012, 08:59 PM   #27
themyst
Major General
 
themyst's Avatar
 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

Posts: 6,598
iTrader: (8)

Send a message via AIM to themyst
Quote:
Originally Posted by cn555ic View Post
4/07 7000 miles!! Piece of shit crap out on me
Damn garage queen.
__________________
E90 LCI N54 6AT
themyst is offline   South Korea
0
Reply With Quote
      05-31-2012, 09:03 PM   #28
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 15,580
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by themyst View Post
Well when I did turbos on my car I did observe my water pump is plastic... Is that a good thing?
Traditionally on the E36 the water pump was plastic and the upgrade was metal. This might not help in this case but just something to work with.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      05-31-2012, 09:06 PM   #29
jlcolon2001
Second Lieutenant
 
Drives: 335i Coupe 2007
Join Date: May 2011
Location: Puerto Rico

Posts: 200
iTrader: (0)

I replaced the water pump/thermostat combo @ 39k miles aprox. My car is a 335i 2007 (Build Date 07/06).
jlcolon2001 is offline   Puerto Rico
0
Reply With Quote
      06-01-2012, 07:38 AM   #30
ADVANT123
Second Lieutenant
 
Drives: 1M
Join Date: Jul 2009
Location: NJ

Posts: 267
iTrader: (0)

Waterpump/Thermostat failed on my 09 335xi @ 65k miles. Cost $800 in parts and $600 in labor to replace at dealer...
__________________
2011 Valencia Orange 1M - Weekend Warrior
2013 Acura RDX - Daily
ADVANT123 is offline  
0
Reply With Quote
      06-01-2012, 07:48 AM   #31
2doubleeagle
New Member
 
Drives: 2008 335i Sedan White/Terra
Join Date: Nov 2010
Location: Sorrento, Fl.

Posts: 28
iTrader: (0)

2008 E90 -- 8/2007 production, failed at 51k miles, replaced under cpo
2doubleeagle is offline   United_States
0
Reply With Quote
      06-01-2012, 08:31 AM   #32
omerfar23
First Lieutenant
 
Drives: 2008 E92 335i, 2014 Corolla LE
Join Date: May 2007
Location: Baltimore, MD

Posts: 352
iTrader: (0)

2008 335i failed at 40k. sucks
__________________
********** 2008 BMW 335i TT******
omerfar23 is offline   United_States
0
Reply With Quote
      08-12-2012, 06:02 AM   #33
SPJ
Private First Class
 
SPJ's Avatar
 
Drives: 2007 335i
Join Date: Dec 2011
Location: Melb

Posts: 149
iTrader: (0)

07 335 failed at 62k
SPJ is offline  
0
Reply With Quote
      08-12-2012, 07:53 AM   #34
flexinator
Lieutenant
 
flexinator's Avatar
 
Drives: 2008 335xi coupe
Join Date: Oct 2007
Location: Syracuse, NY

Posts: 442
iTrader: (2)

Garage List
2008 335xi  [0.00]
08 335xi. Changed at 56k
flexinator is offline   United_States
0
Reply With Quote
      08-12-2012, 08:20 AM   #35
Zebra99
Colonel
 
Zebra99's Avatar
 
Drives: 2011 335is E93
Join Date: Aug 2011
Location: Ontario

Posts: 2,168
iTrader: (4)

Garage List
Ok so is there any confirmation of parts being changed or a re-design?

I'm at 82k km and I'm thinking mine has issues because my temps tend do go over 115-120 celcius on a 30 degree day which is ridiculous. Doesn't happen all the time, but it causes limp mode.

I have crazy WG rattle and figured if do the water pump too since adjusting them thy has to come out.

What do you guys think? Anyone have part #'s of what's needed?

Edit: 03/08 build.
Zebra99 is offline   Canada
0
Reply With Quote
      08-12-2012, 08:38 AM   #36
07bmw335iguy
Second Lieutenant
 
Drives: 2007 BMW 335i Sedan
Join Date: Sep 2011
Location: South Carolina

Posts: 227
iTrader: (4)

07 e90 335i at 98k
07bmw335iguy is offline   United_States
0
Reply With Quote
      08-12-2012, 08:39 AM   #37
bceagle1991
Private
 
Drives: 335ix
Join Date: May 2011
Location: Boston

Posts: 65
iTrader: (4)

2010 335i failed at 43k. Also just this week at 45k my valve cover cracked, another plastic part that probably should not be plastic due to the heat under the hood.
bceagle1991 is offline  
0
Reply With Quote
      08-12-2012, 08:51 AM   #38
ADVANT123
Second Lieutenant
 
Drives: 1M
Join Date: Jul 2009
Location: NJ

Posts: 267
iTrader: (0)

09 335xi (07/2009 build) failed at 65k miles - 100% stock from day 1
__________________
2011 Valencia Orange 1M - Weekend Warrior
2013 Acura RDX - Daily
ADVANT123 is offline  
0
Reply With Quote
      08-12-2012, 10:33 AM   #39
Smokn944
Enlisted Member
 
Smokn944's Avatar
 
Drives: BMW 335xi
Join Date: Aug 2011
Location: Maryland

Posts: 37
iTrader: (0)

10/07 build water pump at 33000 then thermostat 400 miles later. Was still under 4/50k. Dealer changed both. Water pump failed, dealer said thermostat was fine. Then temp was never passing 180, 400 miles later went back and dealer said thermostat was stuck open.
__________________
01' M5 24K Sold 5/09 (Moved) Current 08' 335xi
94' 325is 175K Sold 5/08
83' 944 110K+ Sold 7/02
Smokn944 is offline  
0
Reply With Quote
      08-12-2012, 02:48 PM   #40
VNeBLOB42
Lieutenant Colonel
 
VNeBLOB42's Avatar
 
Drives: 14' GMC Terrain SLT-2
Join Date: May 2011
Location: Folsom, Ca

Posts: 1,678
iTrader: (0)

Garage List
007 335i E92  [3.83]
Send a message via Skype™ to VNeBLOB42
this thread is depressing. i just hit 50k, July 07 build E92.

knock on wood, no water pump issues yet.

my buddy on here hit 52k water pump left him stranded, 07 E90 just a couple months ago.
__________________

SOLD:: PTF Pro eTune by Dzenno / COBB S1+ E50
Alpina B3 Flash / ETS FMIC / ER CP / CPE DCI
VNeBLOB42 is offline   United_States
0
Reply With Quote
      08-12-2012, 05:03 PM   #41
b00sted4v
Private First Class
 
Drives: 2008 335xi
Join Date: May 2011
Location: boston,ma

Posts: 107
iTrader: (2)

08 335xi 57k miles waterpump went
b00sted4v is offline   United_States
0
Reply With Quote
      08-12-2012, 06:07 PM   #42
GeorgiaTech335coupe
Lieutenant Colonel
 
Drives: Black BMW 335i coupe
Join Date: Mar 2007
Location: USA

Posts: 1,884
iTrader: (0)

08 MT, production date - 10/07. Pump went out around 40k miles.
__________________
Legal Disclaimer: Anything I or anyone else says about my vehicle on this website(e90post.com or any affiliated or nonaffiliated sites), pertaining to modifications, is only to gain acceptance from my/our peers, and does not actually represent anything actually existing on my car, and thus, cannot be held against me in any issues, i.e. warranty claims, that may arise.
GeorgiaTech335coupe is offline  
0
Reply With Quote
      08-12-2012, 07:10 PM   #43
335(EX)(EYE)
Banned
 
Drives: e90 n54 & n55 / e46 330ci DD
Join Date: Oct 2011
Location: Harrisburg PA

Posts: 1,499
iTrader: (14)

water pump just replaced, 2008 335xi sedan, 80k miles
335(EX)(EYE) is offline   United_States
0
Reply With Quote
      08-12-2012, 07:14 PM   #44
vereak82
Second Lieutenant
 
vereak82's Avatar
 
Drives: 6-spd e92 335i
Join Date: May 2011
Location: michigan

Posts: 287
iTrader: (0)

07/80k FML just installed new updated pump And thermostat housing also found a blown fuse in the DME housing 40a relating to the water pump failure
__________________
2008 135i 6-speed current stock for now
1995 e36 M3 5-speed
Jb4 G5//CM-FX400//FBO//Meth// 12.06@118 6-speed manual sold summer 2013
vereak82 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST