E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > N54 water pump issues by model year.



Reply
 
Thread Tools Search this Thread
      12-07-2012, 11:01 PM   #67
kushtrim
Major
Albania
26

 
kushtrim's Avatar
 
Drives: AW 335i coupe
Join Date: Dec 2008
Location: bronx N.Y


Posts: 1,091
iTrader: (3)

Garage List
2008 335i coupe  [5.00]
2008 failed at 54K miles
__________________
M-tech front and rear bumpers /M3 style side skirts/gloss black painted roof/ black window trim/Matt black grill/35%tints/4"dimisaTips/CF splitters/M3 style trunk spoiler/VMR V70s/JB4/BMS dci/AMS FMIC/H&R sport with BMW performance shocks.
Thanx Sal and he's crew@AutoCoutureMotoring
Appreciate 0
      12-07-2012, 11:13 PM   #68
Mahhvinn
EUROPROJEKTZ
United_States
110

 
Mahhvinn's Avatar
 
Drives: backwards
Join Date: Dec 2008
Location: San Jose, CA (Bay Area)


Posts: 7,940
iTrader: (15)

Garage List
2008 E90 335i  [3.50]
12/07 Pump and Thermostat replaced around 50k and again around 65k
__________________
LTMW|SPEEDELEMENT|EUROPROJEKTZ

#TeamStretchNPoke
Appreciate 0
      12-09-2012, 04:10 PM   #69
elig0nzal3z
Private First Class
7

 
Drives: 2007 335i
Join Date: Oct 2012
Location: tampa fl


Posts: 155
iTrader: (0)

Garage List
2007 bmw 335i  [0.00]
:(

07 In The Process Of Replaceing It At 99,000
Appreciate 0
      12-09-2012, 06:17 PM   #70
danniexi
Colonel
South Korea
46

 
danniexi's Avatar
 
Drives: 2008 AW E92 335xi
Join Date: May 2008
Location: NJ


Posts: 2,085
iTrader: (14)

MY 01/2008, replaced pump/thermostat at 66,000 miles.
Appreciate 0
      12-14-2012, 10:55 PM   #71
DanielGonz
Lieutenant
14

 
Drives: AW E92 335i 6 speed
Join Date: Apr 2012
Location: SoCal (OC)


Posts: 564
iTrader: (0)

MY 12/2006 E92 335

Water pump/t-stat just took a shit at 89,xxx miles. Getting it towed in a few minutes to FSR Motorsports.
__________________

07 AW E92 335 6MT [18" OEM 193's For Sale, PM me]
OEM Aero Lip | OEM Gloss Black Kidney Grills | KW V2 | Vorsteiner CSL trunk | M-Tech Rear Bumper | LCI Rear Taillights | Angel ibright Angel Eyes | 3000K HID fogs | 6000k HID low beams | AFE DCI | Full LED conversion
Appreciate 0
      12-15-2012, 12:18 AM   #72
Spoolin1
Private First Class
United_States
7

 
Spoolin1's Avatar
 
Drives: 2007 335i
Join Date: Dec 2010
Location: Sellersburg, IN


Posts: 180
iTrader: (1)

What actually goes bad with the pump? What occurs that you know it's going out? Mine is an 11/07 MY if I remember correctly.
__________________
07 335i
-AMS intercooler with Cobb AP stage 1+ 93 tune.
02 Honda S2000
-741 whp 471 wtq (dynojet) @ 29.6 psi on e85; now on 34 psi, 800+ whp.
Appreciate 0
      12-15-2012, 11:41 AM   #73
n54dragon
New Member
0

 
Drives: 2008 335xi
Join Date: May 2012
Location: New York


Posts: 9
iTrader: (0)

'08 335xi.... replaced at 31k
Appreciate 0
      12-19-2012, 10:54 PM   #74
MRVBC
Enlisted Member
United_States
0

 
Drives: E92
Join Date: Jan 2010
Location: Southwest


Posts: 44
iTrader: (0)

o8 e92 just failed tonight at 40k
Appreciate 0
      12-20-2012, 01:01 AM   #75
dominick
Private First Class
1

 
Drives: 08 335i
Join Date: Jun 2011
Location: S. Florida


Posts: 116
iTrader: (2)

08 335i about 45,000
Appreciate 0
      12-20-2012, 01:55 AM   #76
ign335i
Second Lieutenant
7

 
Drives: 335i e92
Join Date: Nov 2012
Location: CA


Posts: 287
iTrader: (3)

Ridiculous the amount of failures. This cost me like $1300 to repair when all said and done.
Appreciate 0
      12-20-2012, 02:16 PM   #77
KC335
Private First Class
Canada
3

 
Drives: E93 335i
Join Date: Feb 2011
Location: Vancouver


Posts: 134
iTrader: (1)

07 335i Cab - tstat and water pump replaced at 80 xxx km
Appreciate 0
      12-21-2012, 12:33 PM   #78
JO3
Lieutenant
9

 
Drives: a lot
Join Date: Mar 2006
Location: CA


Posts: 567
iTrader: (8)

03/08 production date. It just failed on me at 77k miles.

Left me stranded on the side of the freeway, in the middle of nowhere, late at night. Seriously considering replacing every 50-60k miles as preventative maintenance.
Appreciate 0
      12-26-2012, 08:06 AM   #79
vase330
Colonel
United_States
53

 
vase330's Avatar
 
Drives: E92 335i ; 14 RangeRover SSC
Join Date: Jan 2007
Location: Arlington, Va


Posts: 2,676
iTrader: (1)

06/07 335i - mine failed at 32K miles.
__________________
E92 335 | Space Gray | Saddle Brown Dakota | Dark Burl Trim | ZPP | ZSP | AT | Idrive | 6FL | FBO | Dinan CAI | Quaife LSD | STG3 PROCede.
Appreciate 0
      12-26-2012, 12:50 PM   #80
DetectiveLoki
First Lieutenant
10

 
DetectiveLoki's Avatar
 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL


Posts: 301
iTrader: (4)

2008 e93 335i water pump failed at 45k miles
Appreciate 0
      12-26-2012, 11:22 PM   #81
Werked M fizzle
Private
2

 
Drives: E39 M5
Join Date: Sep 2010
Location: Queens NYC


Posts: 48
iTrader: (1)

08 535i water pump failure at ~60k miles
Appreciate 0
      01-03-2013, 03:15 AM   #82
vexx786
Second Lieutenant
20

 
vexx786's Avatar
 
Drives: BMW E39 530i
Join Date: Mar 2009
Location: California


Posts: 205
iTrader: (0)

So it happens randomly buts it pretty much guaranteed to fail?
Appreciate 0
      01-03-2013, 06:50 AM   #83
Josh1a1h
Banned
United Kingdom
112

 
Drives: AzuriteBlack 335i E92
Join Date: Aug 2011
Location: Central North to West London


Posts: 3,836
iTrader: (2)

When it does fail, do codes come up? Will it let you know? Or do you just watch the temps rise out of control?
Appreciate 0
      01-03-2013, 09:32 AM   #84
335iaz
Cause their greeaaaaat!!!!
United_States
24

 
Drives: SBM E90 335i
Join Date: Nov 2009
Location: Peoria, AZ


Posts: 718
iTrader: (14)

Send a message via AIM to 335iaz
Well I am getting my thermostat replaced next week, it threw a stuck open fault code ... not getting the water pump replaced though ... wife doesn't agree getting it replaced if it hasn't "failed" yet ... women sometimes don't understand .. I am currently at 105k miles on the original water pump!
__________________
Appreciate 0
      01-03-2013, 04:55 PM   #85
ManyMoonsAgo
Second Lieutenant
United_States
5

 
ManyMoonsAgo's Avatar
 
Drives: 2008 BMW 335i Coupe
Join Date: Oct 2007
Location: Pinellas County, Florida, USA


Posts: 239
iTrader: (0)

2008 e92 Coupe 10/2007 manufacture date. Pump began to throw failure codes last September at 22K miles. Replaced pump and thermostat out of warranty.

My car had participated in numerous driving events at Sebring and various AutoX's leading up to that. One session at Sebring the month before the failure particularly thrashed my coolant system, so I was not terribly surprised when the pump started throwing the death codes.

Though we are not sure exactly what failed, looking at the old pump, the circuitry and insulation around the circuitry did not look all that healthy, heat damage was apparent. The pump itself seemed okay, so my mechanic and I suspected the pump's circuitry failed rather than the mechanical aspect of the pump.
__________________
Montego Blue / Saddle Brown / Gray Poplar
6-speed Manual (CDV-free) / BMW Performance Exhaust / Dinan Intercooler / Dinan Stage 2 / Dinan Cold Air Intake
BMW Performance Suspension / Dinan LSD / 19" Forgestar F14s / Front and Rear M3 Bushings & Arms / Rear Sway / Dinan Monoballs
Appreciate 0
      01-03-2013, 10:11 PM   #86
mspec
New Member
0

 
Drives: 2008 335i
Join Date: Jun 2012
Location: ACT


Posts: 8
iTrader: (0)

Quote:
Originally Posted by themyst View Post
Please post only if you had a water pump replaced. If you did, let us know what model year.

in the workshop now.
waterpump (and theromostat)
2008 e92 335i
60,xxx km
Appreciate 0
      01-04-2013, 12:53 PM   #87
islandboy_671
///BA
United_States
1

 
islandboy_671's Avatar
 
Drives: 08 335i premium sport package
Join Date: Dec 2011
Location: NOVA


Posts: 14
iTrader: (0)

Garage List
2008 335i replaced at 44k and right now I Just hit 47k. Under Warranty with dealer though.
Appreciate 0
      01-04-2013, 01:09 PM   #88
GoRomeo
Colonel
35

 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA


Posts: 2,344
iTrader: (0)

Garage List
2006 330i  [2.83]
Quote:
Originally Posted by 335iaz View Post
Well I am getting my thermostat replaced next week, it threw a stuck open fault code ... not getting the water pump replaced though ... wife doesn't agree getting it replaced if it hasn't "failed" yet ... women sometimes don't understand .. I am currently at 105k miles on the original water pump!

Why not just wait till Water Pump fails? Are you getting any symptoms from a bad thermostat? I ve got a SES light with a bad thermostat code but just cleared it. I dont have any issues. I will just wait till water pump fails to replace both. You should do the same.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST