E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > e93 and roof problems - anyone else?



Reply
 
Thread Tools Search this Thread
      07-05-2007, 07:40 PM   #1
bimmerchild
Private First Class
 
Drives: 06 330iSport
Join Date: Oct 2005
Location: Boston

Posts: 116
iTrader: (0)

e93 and roof problems - anyone else?

2 days after I got my e93 335i, I am having problems shutting the roof. Opening is no problem, but when I shut it, it gets stuck right at the end. After a few minute I press the button again and it shuts ok. I can reproduce it at will on my car
going to call dealer tommorow for an appt to get this thing fixed...
__________________
08 BMW 335i Cabrio ED (June 2008 - yes - managed to sell the first and do another ED)
07 BMW 335i Cabrio ED (May 2007)
06 SG 330i - SP - Stick - sold
03 BMW 325cic - retired -
04 MB c230K - retired - girl's car...
bimmerchild is offline  
0
Reply With Quote
      07-05-2007, 09:34 PM   #2
urnone
Major
 
urnone's Avatar
 
Drives: Black Sapphire 335i E92
Join Date: May 2007
Location: Miami, Floriduhhh

Posts: 1,015
iTrader: (2)

my fear of buying an E93....which is why i got an E92... that sucks... dealer needs to fix that fast....
__________________
Mods: Painted Reflectors, GP Thunder Angels, Rear Fogs, 20% Tints, Front Aero Lip, Alarm, Black Layovers, Pearlescent Brake Handle, Debadge, ACS Roofspoiler, LED license plate, 6000k HID & HID Fogs, LED footwell mod
Click to see my BMW plate collection

urnone is offline   United_States
0
Reply With Quote
      07-05-2007, 10:01 PM   #3
clc5174
Private
 
Drives: 2007 328i 'vert
Join Date: Mar 2007
Location: SF Bay Area

Posts: 86
iTrader: (0)

No problems after seven weeks and 2300 miles.
clc5174 is offline   United_States
0
Reply With Quote
      07-06-2007, 12:12 PM   #4
preacher
Enlisted Member
 
preacher's Avatar
 
Drives: 07' 328i vert
Join Date: Jun 2007
Location: so-cal

Posts: 35
iTrader: (0)

Quote:
Originally Posted by clc5174 View Post
No problems after seven weeks and 2300 miles.
Ditto... well sorta, eight weeks- 1200 miles with no problems
preacher is offline  
0
Reply With Quote
      07-06-2007, 12:14 PM   #5
miopyk
First Lieutenant
 
miopyk's Avatar
 
Drives: 987 Boxster & R56 Cooper S
Join Date: Oct 2006
Location: UK

Posts: 351
iTrader: (0)

I've had mine more than 3 months and have had no problems with the roof so far.

Miopyk
miopyk is offline   United Kingdom
0
Reply With Quote
      07-06-2007, 12:22 PM   #6
ejazbmw
blahhh
 
ejazbmw's Avatar
 
Drives: 2011 E92 335i
Join Date: Apr 2007
Location: NJ/NY

Posts: 6,349
iTrader: (7)

i think if i were to buy an E93 i would of waited after a year after they came out, so that they could fix all the problems the previous year had, but thats just my .02.....
ejazbmw is offline  
0
Reply With Quote
      07-06-2007, 02:07 PM   #7
Docray1
Private
 
Drives: 2007 BMW 335 Convertible
Join Date: Oct 2006
Location: Detroit, MI

Posts: 68
iTrader: (0)

My only issues so far has been some of the rubber seals along those folding pivots moving out of place when the top is opened and closed; I can tell there will be long-term issues with them. No motor or solenoid issues though.
Docray1 is offline  
0
Reply With Quote
      07-06-2007, 03:40 PM   #8
msimon18
Retired
 
msimon18's Avatar
 
Drives: Z4 s30i
Join Date: Mar 2007
Location: The Villages, FL

Posts: 868
iTrader: (0)

Garage List
No problems after 4 weeks.

I did run across an interesting one at my dealership last week though. Seems a guy from North Carolina in a 335i E93 had a problem putting his top up while on a trip to Western NY. He had to get towed about 50 miles to the dealership for help with the top in the boot and trunk halfway open.

Seems he had a umbrella under the right side of the boot area (where you are supposed to have NOTHING) and it got crushed and skewed the top so it would not open correctly.

He learned an expensive lesson - tow cost and a $95.00 fee for service not to mention the hotel ....... oh well... the top did not fail though ... but the driver did !!
__________________

M3 GTR - 1/5 scale - 4.2 HP w/ Collari hydraulic brakes - would you believe ~80 MPH on straightaway !!
msimon18 is offline   United_States
0
Reply With Quote
      07-06-2007, 03:43 PM   #9
achien
AC
 
Drives: E90 Post Members Crazy
Join Date: May 2007
Location: Toronto, Canada

Posts: 2,378
iTrader: (0)

Check the Canada thread. We have two (2) cars here in Toronto having their E93s roof leaking.
__________________
Your Supreme Leader

Last edited by achien; 07-06-2007 at 09:15 PM.
achien is offline   Canada
0
Reply With Quote
      07-07-2007, 01:51 AM   #10
adamr
Major
 
adamr's Avatar
 
Drives: 997 GT3 RS
Join Date: Dec 2006
Location: Johannesburg

Posts: 1,032
iTrader: (0)

Garage List
... mmm ... no problems for now .... touch wood ... but u guys are making me worried ...
__________________


2007 Porsche 997 GT3 RS
|PCM with NAV and GSM|Roll Cage|PCCB|Xenons|Sports Chrono Plus|PASM|Leather Pack|Silver Seat-belts|
adamr is offline   South Africa
0
Reply With Quote
      07-07-2007, 02:27 AM   #11
soph1aa
Colonel
 
soph1aa's Avatar
 
Drives: e93
Join Date: Jun 2007
Location: oc,ca

Posts: 2,231
iTrader: (1)

Garage List
2007 328i  [0.00]
Send a message via AIM to soph1aa
seriously....
one week away from getting mine delivered , and i'm planning on having my top down often which means it will be used alot...

i hope nothing happens to mine...
soph1aa is offline  
0
Reply With Quote
      07-07-2007, 06:26 AM   #12
AlanIOW
Private First Class
 
AlanIOW's Avatar
 
Drives: E93 320d M Sport Convertible
Join Date: Apr 2007
Location: Isle of Wight, UK.

Posts: 134
iTrader: (0)

Had mine since 1st June and no problems at all, we have more rain in the last month than most of last year and not a sign of a leak. The roof has worked flawlessly even though on one occasion I had a small box where it should not have been in the boot when I was opening the top, luckily I noticed the roof mechanism twist slightly as it went into the boot and I stopped pressing the button. No damage done but I am sure you could quite easily if you were not paying attention. Don't put anything at all in the sides of the boot if you are going to open the top and be careful if the is anything very close to the rear bumper as the boot lid swngs back about 4-5" past the bumper.
AlanIOW is offline   United Kingdom
0
Reply With Quote
      07-13-2007, 12:33 AM   #13
preacher
Enlisted Member
 
preacher's Avatar
 
Drives: 07' 328i vert
Join Date: Jun 2007
Location: so-cal

Posts: 35
iTrader: (0)

Quote:
Originally Posted by preacher View Post
Ditto... well sorta, eight weeks- 1200 miles with no problems
I totally jinxed myself!!

The top did what the op is talking about... not completely finishing its closing cycle. I had to turn the car off and back it up and close it again. Fortunately it worked..I will definitely keep my eye on this.
preacher is offline  
0
Reply With Quote
      07-13-2007, 07:11 AM   #14
keithIOW
Second Lieutenant
 
Drives: E93 325 SE
Join Date: Oct 2006
Location: Isle of Wight, U.K.

Posts: 222
iTrader: (0)

I've had this a couple of times. The roof seems to close but does'nt 'tension' up. If I release the button and then immidiately press it again the roof tightens up and the cycle completes. I've not been to concerned until now, but it'll be interesting to see what your stealer has to say. Good luck
__________________

E93 325 SE, Sparkling Graphite, Black Dakota, hi-gloss black trim, 230's, Folding Mirrors, C/A, Sat Nav, Sport Seats, Front Seat Heating, prof Hi-Fi
keithIOW is offline   England
0
Reply With Quote
      07-13-2007, 08:05 AM   #15
stefano7171
Lieutenant
 
stefano7171's Avatar
 
Drives: BMW e93 335i Msport
Join Date: Dec 2006
Location: torino, Italy

Posts: 467
iTrader: (0)

Quote:
Originally Posted by keithIOW View Post
I've had this a couple of times. The roof seems to close but does'nt 'tension' up. If I release the button and then immidiately press it again the roof tightens up and the cycle completes. I've not been to concerned until now, but it'll be interesting to see what your stealer has to say. Good luck
The problem I had with the roof is the following: after opening it while it was still wet for a rainstorm, when I closed it, it made starnge squeaks for a while (days!), I took it to service, they were not able to hear anything, we tested it together and the noises did disappear. The advice is: open it only when is dry!!!!
__________________
Current: e93 335 Msport, black sapphire on sanbeige, MT, 19" rims 225m, satnav, usb, CA, voice control, HBA, windstop, heated seats.
stefano7171 is offline  
0
Reply With Quote
      07-13-2007, 08:07 AM   #16
sonic03inSC
Private First Class
 
sonic03inSC's Avatar
 
Drives: 2011 M3 E93
Join Date: Jul 2007
Location: SC

Posts: 135
iTrader: (0)

Quote:
Originally Posted by Docray1 View Post
My only issues so far has been some of the rubber seals along those folding pivots moving out of place when the top is opened and closed; I can tell there will be long-term issues with them. No motor or solenoid issues though.
Same here with just under 500 miles.
__________________
2011 M3 E93 DCT
sonic03inSC is offline  
0
Reply With Quote
      07-13-2007, 09:13 AM   #17
bimmerchild
Private First Class
 
Drives: 06 330iSport
Join Date: Oct 2005
Location: Boston

Posts: 116
iTrader: (0)

Problem fixed - with new sensor (or something like that)...
__________________
08 BMW 335i Cabrio ED (June 2008 - yes - managed to sell the first and do another ED)
07 BMW 335i Cabrio ED (May 2007)
06 SG 330i - SP - Stick - sold
03 BMW 325cic - retired -
04 MB c230K - retired - girl's car...
bimmerchild is offline  
0
Reply With Quote
      07-13-2007, 09:16 AM   #18
JD76
New Member
 
JD76's Avatar
 
Drives: 2007 328xi
Join Date: Nov 2006
Location: NYC

Posts: 7
iTrader: (0)

I went to the dealership to get my iDrive updated and when I got the car back, within 5 mins of driving, I got a warning message that my roof is messed up. I tried opening it and it doesnt open all the way and it stops and goes back to close. Its all jacked up. I have to bring the car back. They said its been happening often with this series.
JD76 is offline  
0
Reply With Quote
      07-13-2007, 09:21 AM   #19
Babe
Test here
 
Babe's Avatar
 
Drives: 2007 335i Alpine White
Join Date: Jun 2007
Location: Ann Arbor

Posts: 374
iTrader: (0)

There is a fix I was told by my brother that has one. It has to do with a switch.

He got it fixed.
Babe is offline  
0
Reply With Quote
      07-13-2007, 02:26 PM   #20
halB
Colonel
 
halB's Avatar
 
Drives: W211 E350 4M MkV GTI 987.2 S
Join Date: Jan 2007
Location: Just north of Toronto

Posts: 2,384
iTrader: (0)

2 weeks old and no problem so far, except that it leaks a little when I put it thru a touchless car wash. But the dealer had warned me about that already - Hand wash or soft cloth automatic wash. No touchless. Low pressure power wash only if you really have to.
__________________
07 E93 335i - Returned at lease end
09 W211 E350 4Matic Avant Garde - Blk/Blk, AMG pkg w/18". Sport Susp. F1 Asym. Debadged.
09 MkV GTI w/Leather & 18" Huffs. F1 Asym

10 987.2 S w/Leather sport seat, Sport Chrono, 19" Carrera S II wheels
halB is offline   Canada
0
Reply With Quote
      07-15-2007, 07:59 AM   #21
Orcus
Registered
 
Drives: E93 335i Barbera Red/Grey
Join Date: Mar 2007
Location: NoVA

Posts: 3
iTrader: (0)

Two issues so far. First, a seal came loose and had to be replaced. Second, when closing the roof, maybe one in five times, it would slam down in the last half foot or so and stop. needed to open it up again a little and reclose to finish the cycle. Needed a micoswitch replaced. Working fine. The price you pay for the cool factor of a first year model.
Orcus is offline   United_States
0
Reply With Quote
      05-16-2012, 08:29 AM   #22
surrey 335i
Second Lieutenant
 
Drives: 335i coupe manual and 325d E91
Join Date: Jan 2012
Location: surrey

Posts: 227
iTrader: (0)

I've got water leaking into the boot on an 2007 E93 convetible.

If you have the boot open and look in you can see the water running in from the left handside - it runs down the carpet that covers the strut/wheel arch


anyone fixed this? what seal is causing this have had a look and not sure.
surrey 335i is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:55 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST