E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Can someone with HFS-3 meth please HELP!



Reply
 
Thread Tools Search this Thread
      07-06-2012, 10:25 AM   #1
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Can someone with HFS-3 meth please HELP!

Ok my car is at a local shop getting the aquamist HFS-3 meth kit installed on my 335i. The installer followed the directions and soldered the control unit as the directions indicated. But as soon as the car is started the meth flows and doesnt stop. He was in contact with Aquamist and they seem to be no help. Does anyone have any pictures or diagrams as to how the HFS-3 system needs to be soldered in the control unit in order for it to work properly? Please I need any help I can get. I need my car back and this is holding them back from doing the pro tune. Any help or pics of your HFS-3 controller and what needs to be soldered would be greatly appreciated.
__________________
2009 E92 BMW M3.

Last edited by woptang22; 07-06-2012 at 10:32 AM.
woptang22 is offline  
0
Reply With Quote
      07-06-2012, 10:38 AM   #2
3-Serious
Lieutenant
 
Drives: AP e92 335i
Join Date: Dec 2008
Location: New york

Posts: 456
iTrader: (1)

How do you know it won't stop flowing? Doess the gauge say so or during the test it kept spraying?
__________________
Cobb JR Tune, HFS-4, DCI, AMS Intercooler, Vishnu CP, Forge DV's, AR DP's, RPI exhaust, AR OCC, BMW STS, Spec stage 3+ clutch, CDV delete, H&R Coil overs, Quaife LSD, DefiV Lock down kit, WOTbox.
3-Serious is offline   United_States
0
Reply With Quote
      07-06-2012, 10:50 AM   #3
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Quote:
Originally Posted by nickkg37s View Post
How do you know it won't stop flowing? Doess the gauge say so or during the test it kept spraying?
While they were testing it at the shop before the Pro Tune , as soon as they start the car the meth starts flowing and wont stop unless they turn the meth off with the failsafe. They followed the instructions exactly and the problem continues and aquamist seems to be giving them attitude and not helping.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-06-2012, 11:00 AM   #4
rader1
Banned
 
Drives: Cobb Stage 2+ 135i
Join Date: Apr 2011
Location: Roanoke, VA

Posts: 2,197
iTrader: (0)

Quote:
Originally Posted by woptang22 View Post
While they were testing it at the shop before the Pro Tune , as soon as they start the car the meth starts flowing and wont stop unless they turn the meth off with the failsafe. They followed the instructions exactly and the problem continues and aquamist seems to be giving them attitude and not helping.
I'll get in touch with the shop that did my install and see what issue it was they had(I think it was the issue you're having) and see how they fixed. No promises though, they're SUPER busy right now.
rader1 is offline  
0
Reply With Quote
      07-06-2012, 11:49 AM   #5
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Thank you. Youve been a great help with everything. That would be awsome if you could give it a try to see if they have a few minutes to explain to you. Im not sure what to do at this point. Its going to be 3 weeks I just need my car back. And aquamist seems to be no help to my tuner. And they have been representing aquamist for a long time. thanks for the help.

Quote:
Originally Posted by rader1 View Post
I'll get in touch with the shop that did my install and see what issue it was they had(I think it was the issue you're having) and see how they fixed. No promises though, they're SUPER busy right now.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-06-2012, 12:35 PM   #6
rader1
Banned
 
Drives: Cobb Stage 2+ 135i
Join Date: Apr 2011
Location: Roanoke, VA

Posts: 2,197
iTrader: (0)

Quote:
Originally Posted by woptang22 View Post
Thank you. Youve been a great help with everything. That would be awsome if you could give it a try to see if they have a few minutes to explain to you. Im not sure what to do at this point. Its going to be 3 weeks I just need my car back. And aquamist seems to be no help to my tuner. And they have been representing aquamist for a long time. thanks for the help.
Aquamist has a site and a message board. You may be able to get in touch with Richard@aquamist directly. I'm not saying or suggesting akuma isn't doing all they can, but it's never a bad idea to cover your basis and verify things yourself.
rader1 is offline  
0
Reply With Quote
      07-06-2012, 12:38 PM   #7
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Quote:
Originally Posted by rader1 View Post
Aquamist has a site and a message board. You may be able to get in touch with Richard@aquamist directly. I'm not saying or suggesting akuma isn't doing all they can, but it's never a bad idea to cover your basis and verify things yourself.
Very true, I was going to contact Richard but I didnt want to step on Akumas toes by doing so. But I may have to contact him to see if he gives me any help.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-06-2012, 03:37 PM   #8
cstavaru
Brigadier General
 
cstavaru's Avatar
 
Drives: 2009 335i M Sport Sedan 6MT
Join Date: Aug 2008
Location: Bucharest, Romania

Posts: 3,235
iTrader: (0)

I hope the SYS jumper that puts the board in pump test mode is not enabled, right ? Please check the ducumentation. Also try to disconnect the green connector and see if the problem still persists. If not, you have connected the car injector wires wrongly.

Last edited by cstavaru; 07-06-2012 at 03:53 PM.
cstavaru is offline  
0
Reply With Quote
      07-06-2012, 05:02 PM   #9
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Quote:
Originally Posted by cstavaru View Post
I hope the SYS jumper that puts the board in pump test mode is not enabled, right ? Please check the ducumentation. Also try to disconnect the green connector and see if the problem still persists. If not, you have connected the car injector wires wrongly.
Thank you Ill pass this on to the shop.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-06-2012, 05:11 PM   #10
3-Serious
Lieutenant
 
Drives: AP e92 335i
Join Date: Dec 2008
Location: New york

Posts: 456
iTrader: (1)

Any news on this, I wonder if this is happening to my car? My pump is always on it sounds like but the flow meter only goes up when I accelerate? Did you find out the problem op?
__________________
Cobb JR Tune, HFS-4, DCI, AMS Intercooler, Vishnu CP, Forge DV's, AR DP's, RPI exhaust, AR OCC, BMW STS, Spec stage 3+ clutch, CDV delete, H&R Coil overs, Quaife LSD, DefiV Lock down kit, WOTbox.
3-Serious is offline   United_States
0
Reply With Quote
      07-06-2012, 05:25 PM   #11
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Quote:
Originally Posted by nickkg37s View Post
Any news on this, I wonder if this is happening to my car? My pump is always on it sounds like but the flow meter only goes up when I accelerate? Did you find out the problem op?
No they didnt figure the problem out yet. A guy named Richard from Aquamist is supposed to get a hold of my tuner and go through it all to find out whats wrong. But it seems like Im getting nowhere close to getting my car. My tuner followed the instructions from aquamist but has this issue. But then aquamist said theres updates to the way its wired, but for some reason no one can get to the proper way of having it wired. From my understanding, as soon as the car is started, the meth starts spraying and doesnt stop until they shut it off. I dont know what to do at this point.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-07-2012, 09:02 AM   #12
3-Serious
Lieutenant
 
Drives: AP e92 335i
Join Date: Dec 2008
Location: New york

Posts: 456
iTrader: (1)

Quote:
Originally Posted by woptang22 View Post
No they didnt figure the problem out yet. A guy named Richard from Aquamist is supposed to get a hold of my tuner and go through it all to find out whats wrong. But it seems like Im getting nowhere close to getting my car. My tuner followed the instructions from aquamist but has this issue. But then aquamist said theres updates to the way its wired, but for some reason no one can get to the proper way of having it wired. From my understanding, as soon as the car is started, the meth starts spraying and doesnt stop until they shut it off. I dont know what to do at this point.
That sucks man hopefully they figure it out soon! I ordered my meth kit around the time you did as well, and was having problems also. My problem was that one of the conectors had a thin plastic piece on it that he didn't see!! I hope your problem is as simple as mine was! And keep us posted.
__________________
Cobb JR Tune, HFS-4, DCI, AMS Intercooler, Vishnu CP, Forge DV's, AR DP's, RPI exhaust, AR OCC, BMW STS, Spec stage 3+ clutch, CDV delete, H&R Coil overs, Quaife LSD, DefiV Lock down kit, WOTbox.

Last edited by 3-Serious; 07-07-2012 at 09:15 AM.
3-Serious is offline   United_States
0
Reply With Quote
      07-07-2012, 09:46 AM   #13
TLO03
Second Lieutenant
 
Drives: E61
Join Date: Jun 2010
Location: CT

Posts: 204
iTrader: (0)

there is a mode you can put it in to make that happen (test). I have always had good luck with Jeff at howerton and Richard @ aquamist, have you tried to contact them your self?

when i had problems with a shop install richard would call me sometimes twice a day from england, meantime the shop said they couldn't get a hold of him..
TLO03 is offline  
0
Reply With Quote
      07-07-2012, 10:39 AM   #14
Lulz_M3
Banned
 
Drives: AW 335i 6MT
Join Date: Oct 2011
Location: Jax, Fl

Posts: 1,029
iTrader: (0)

I bet it has the settings for port injection dialed in, not direct injection. Are they wiring it up to activate off injector duty cycle or boost only?
Lulz_M3 is offline   United_States
0
Reply With Quote
      07-07-2012, 01:25 PM   #15
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

I did try contacting Jeff Howerton but he told me he couldnt give tech advice for another aquamist dealer. And I didnt try to contact richard from aquamist but my tuner has been emailing him. I also just talked to my tuner and they said their tech is on the phone with richard from aquamist and they are trying to figure out whats going on. So hopefully this gets it all taken care of. Im missing my car big time at this point.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-07-2012, 02:44 PM   #16
woptang22
Major
 
woptang22's Avatar
 
Drives: 2009 E92 BMW M3
Join Date: Nov 2011
Location: Bristol Pa

Posts: 1,046
iTrader: (1)

Well it turns out the circuit board in the controller was bad and Aquamist is sending the tuner a new one. So looks like my car will be there a few more days. But at least they got that figured out.
__________________
2009 E92 BMW M3.
woptang22 is offline  
0
Reply With Quote
      07-11-2012, 09:36 PM   #17
badfish718
Second Lieutenant
 
badfish718's Avatar
 
Drives: 13 F30 335i M-Sport EB2
Join Date: Nov 2011
Location: Staten Island, NY

Posts: 235
iTrader: (5)

i actually saw your car outside Akuma today, was there getting my DPs put in correctly. im interested in doing the same set up eventually so please keep us posted how it all turns out
__________________
13 F30 335i M-Sport EB-II/Black

Prev:
07 E92 335i Montego/Saddle - Stage 2+
badfish718 is offline   United_States
0
Reply With Quote
      04-24-2013, 11:20 AM   #18
tinnsoldaten
Captain
 
tinnsoldaten's Avatar
 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

Posts: 664
iTrader: (1)

OP: where did you hook up the purple wire from the power harness/cable?
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|Cobb stage2+ agressive FMIC LT|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
tinnsoldaten is offline   Norway
0
Reply With Quote
      04-24-2013, 12:29 PM   #19
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,558
iTrader: (5)

Quote:
Originally Posted by tinnsoldaten View Post
OP: where did you hook up the purple wire from the power harness/cable?
Are you talking about the auto dimming wire? I don;t know of anyone hooking that one up(I'm sure someone did) , I didn't
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      04-24-2013, 12:45 PM   #20
tinnsoldaten
Captain
 
tinnsoldaten's Avatar
 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

Posts: 664
iTrader: (1)

Yeah , I got in touch with Richard @ Aquamist , solved the mystery .

Red to DME +
black and the white wire go to ground
purple if used , go to red and grey wire from ashtray area (remove center console)
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|Cobb stage2+ agressive FMIC LT|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
tinnsoldaten is offline   Norway
0
Reply With Quote
      04-24-2013, 12:46 PM   #21
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,558
iTrader: (5)

Quote:
Originally Posted by tinnsoldaten View Post
Yeah , I got in touch with Richard @ Aquamist , solved the mystery .

Red to DME +
black and the white wire go to ground
purple if used , go to red and grey wire from ashtray area (remove center console)
Oh I could have helped if I knew what you;re looking for. I've installed this a couple fo times already
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      04-24-2013, 12:50 PM   #22
tinnsoldaten
Captain
 
tinnsoldaten's Avatar
 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

Posts: 664
iTrader: (1)

Thanks Marv , Im done now , this was the only 4 wires left. Now of to buy meth(substitute) and destilled water.

Will test run the system once I get back from work... 6th of May.

Just unhook methline before FAV and let it run for a while ?

Any details on that procedure ?
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|Cobb stage2+ agressive FMIC LT|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
tinnsoldaten is offline   Norway
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:36 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST