E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Bluetooth audio disconnects after USB usage



Reply
 
Thread Tools Search this Thread
      07-17-2012, 02:21 PM   #1
dwaynedelario
New Member
0
Rep
9
Posts

Drives: '11 328ia Sedan M-Sport
Join Date: Jul 2012
Location: Los Angeles

iTrader: (0)

Bluetooth audio disconnects after USB usage

Hey All,

Just bought my first BMW! LeMans blue 2011 e90 (only 1800 miles!) with the M Sport and Sport packages. LOVE IT.

Anyway, for the last few days I have been playing music from my iPhone 4S wirelessly via bluetooth and it has been great (other than the fact that it automatically starts playing after a phone call). Today, in order to charge my phone, I plugged it into the USB port in the center console and I got a warning that bluetooth audio would be disconnected. Ok fine... but later on when I wanted to "reconnect," I had to go digging way into the phone settings and tell the car that it was ok to use the phone as an audio device, then select it in the External devices menu.

Is there any way around this nuisance?

Thanks for any advice!!!!
Appreciate 0
      07-17-2012, 06:03 PM   #2
Technic
Lieutenant General
Technic's Avatar
United_States
484
Rep
12,208
Posts

Drives: 2015 320i
Join Date: Apr 2005
Location: Ft Lauderdale, Florida

iTrader: (18)

Normal functionality, as in BMW needs to release a software update to fix this bad UI.

One thing is to disable BT Audio in the phone when USB is connected, another is to de-select a phone setting in the iDrive after the fact.
Appreciate 0
      07-17-2012, 08:18 PM   #3
dwaynedelario
New Member
0
Rep
9
Posts

Drives: '11 328ia Sedan M-Sport
Join Date: Jul 2012
Location: Los Angeles

iTrader: (0)

Thanks Technic. To disable BT audio on the iPhone before connecting, how do I do that? Do you mean turn off bluetooth functionality altogether (phone and audio?). Or is there some way to do that in the settings on the iPhone itself before it connects? Perhaps hitting that blue symbol in iTunes before connecting USB.

Do you happen to know why I might be getting distortion when playing over USB connection only? I see the ability to change the gain staging for the aux port in the options, but I thought USB only would be decoded by the stereo itself.

Thanks again.
Appreciate 0
      07-18-2012, 11:01 AM   #4
cptcrunch
Captain Crunch
cptcrunch's Avatar
4
Rep
373
Posts

Drives: 2011 335D
Join Date: May 2011
Location: Cincinnati

iTrader: (0)

To save your self some headaches, you might want to get one of these: http://www.monoprice.com/products/pr...seq=1&format=2 They have a 2 usb model as well from griffin: http://www.amazon.com/Griffin-Powerj...uct/B0042B9U8Q. I have the griffin one and it works great for charging my phone while having another port open for a passenger.
__________________
On Order: European Delivery - 2016 340i EBII/Saddle - ZMP | ZCW | ZDA | ZLP | ZTP | M Adaptive | Rear Shades
Current: 2011 335D Space Grey/Black - ZSP | ZPP | ZCW | 6FL | Sat Radio | Nav | $600 Base Audio Upgrade
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:31 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST