E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 2008 335i not starting up



Reply
 
Thread Tools Search this Thread
      01-19-2014, 04:33 AM   #1
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Exclamation 2008 335i not starting up

Okay, so my car is not starting up since yesterday except every electronic in the car after I got it back from the mechanic (I started it up over there with no problem). I've done some research in this forum and people are pointing at the battery at first. Since I have been having problem with my battery so I decided to change it. I went to Autozone and got the duralast battery for $169 I put it in and it still has the same problem. So I tried push start the car, it worked perfectly. I charged the car for about an hour and drove for 10 miles just to make sure the battery is good. I pulled over on the hill and shut off the car, I couldn't turn it back on. So I'm pretty sure it's the starter problem. But before spending more money and doing a lot of engine work, I just want to get your opinions. Do you think this is the starter problem? Or it is something else? Because the weird thing is I didn't notice any bad starter symptoms since I bought the car.

Little more information from my car, it was in the mechanic almost a month for turbo replacement. I added a P3 boost gauge right after I got back home, I wanted to test it out so that was the first time that my car couldn't turn on. (It worked perfectly after I pushed start the car). I will bring it back to the mechanic for sure on Tuesday, but I think it will be good to get some information from here first.

Thanks in advance

Kalvin
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 07:43 AM   #2
Opo
Private First Class
 
Drives: 2007 BMW 335i E92 (12/2006)
Join Date: Apr 2013
Location: Canada

Posts: 129
iTrader: (0)

I had a similar problem recently.. Car wouldn't start but would bump start no problem. Sounds like your starter but could also maybe be your clutch switch.

Did the starter ever make any odd noise? Slow cranking? At all? Seems odd that it would have just flat out died

Have a read through this:

http://www.e90post.com/forums/showthread.php?t=925280

Starter is pretty easy to do yourself and you can clean your intake ports & valves at the same time, makes a world of difference
Opo is offline  
0
Reply With Quote
      01-19-2014, 02:43 PM   #3
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by Opo View Post
I had a similar problem recently.. Car wouldn't start but would bump start no problem. Sounds like your starter but could also maybe be your clutch switch.

Did the starter ever make any odd noise? Slow cranking? At all? Seems odd that it would have just flat out died

Have a read through this:

http://www.e90post.com/forums/showthread.php?t=925280

Starter is pretty easy to do yourself and you can clean your intake ports & valves at the same time, makes a world of difference
I just read it and I'm thinking about the clutch switch, at least I should give it a shot before taking everything apart. Tapping the stater is a must do
If I get what you got when I tap the starter I mean I'm 100% sure it's the starter.
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 03:11 PM   #4
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by Opo View Post
I had a similar problem recently.. Car wouldn't start but would bump start no problem. Sounds like your starter but could also maybe be your clutch switch.

Did the starter ever make any odd noise? Slow cranking? At all? Seems odd that it would have just flat out died

Have a read through this:

http://www.e90post.com/forums/showthread.php?t=925280

Starter is pretty easy to do yourself and you can clean your intake ports & valves at the same time, makes a world of difference
OMG you are a life saver man. I just remember that when I was fishing the vacuum line from the bottom to the engine bay and my arm accidentally loosen the clutch switch harness, I just plug it back it. And now the car sounds like a beast again
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 03:44 PM   #5
Opo
Private First Class
 
Drives: 2007 BMW 335i E92 (12/2006)
Join Date: Apr 2013
Location: Canada

Posts: 129
iTrader: (0)

Good stuff, glad you got it sorted out man. Didn't make sense that the starter would have stopped working with no warning signs first, pretty rare for that to happen.
Opo is offline  
0
Reply With Quote
      01-19-2014, 03:58 PM   #6
WedgePerformance
BimmerPost Supporting Vendor

 
WedgePerformance's Avatar
 
Drives: '07 e92 AT Sport Montego Blue
Join Date: Oct 2013
Location: Portland, OR

Posts: 452
iTrader: (0)

Garage List
Quote:
Originally Posted by Kalvin View Post
OMG you are a life saver man. I just remember that when I was fishing the vacuum line from the bottom to the engine bay and my arm accidentally loosen the clutch switch harness, I just plug it back it. And now the car sounds like a beast again
heheh... I think Marv85 and CWarren had that issue once...
WedgePerformance is offline   United_States
0
Reply With Quote
      01-19-2014, 04:13 PM   #7
Dos Plunder
Private
 
Dos Plunder's Avatar
 
Drives: 2007 BMW 335i Montego Blue
Join Date: Jan 2013
Location: Boise Id

Posts: 64
iTrader: (0)

Now go return that $165 battery! Lol
Dos Plunder is offline  
0
Reply With Quote
      01-19-2014, 10:12 PM   #8
Bimmer-M3
Captain
 
Bimmer-M3's Avatar
 
Drives: e90
Join Date: Aug 2013
Location: ---

Posts: 606
iTrader: (0)

Where can I find the clutch switch ?
Bimmer-M3 is offline  
0
Reply With Quote
      01-19-2014, 10:43 PM   #9
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by Opo View Post
Good stuff, glad you got it sorted out man. Didn't make sense that the starter would have stopped working with no warning signs first, pretty rare for that to happen.
Thanks! That's what I thought too!
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 10:44 PM   #10
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by WedgePerformance View Post
heheh... I think Marv85 and CWarren had that issue once...
Haha, that happened just taught me a lesson LOL
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 10:46 PM   #11
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by Dos Plunder View Post
Now go return that $165 battery! Lol
I think I will stick with this battery, because I had Autozone checked the battery out and it was a bad battery.
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 10:51 PM   #12
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by nebrou View Post
Where can I find the clutch switch ?
It's behind the clutch when you take out the cover under the steering wheel.

PS: Picture is from Google

Kalvin is offline   Hong Kong
0
Reply With Quote
      01-19-2014, 11:57 PM   #13
Bimmer-M3
Captain
 
Bimmer-M3's Avatar
 
Drives: e90
Join Date: Aug 2013
Location: ---

Posts: 606
iTrader: (0)

I got it thanks. For some reason I thought it is in engine bay !
Bimmer-M3 is offline  
0
Reply With Quote
      01-20-2014, 12:05 AM   #14
dlbrooks18
Brigadier General
 
dlbrooks18's Avatar
 
Drives: e90 335i
Join Date: Nov 2008
Location: Los Angeles

Posts: 3,565
iTrader: (2)

Did you have the battery cable recall done yet?
__________________

2008 E90 335
dlbrooks18 is offline  
0
Reply With Quote
      01-20-2014, 01:22 AM   #15
Kalvin
Slow driver
 
Kalvin's Avatar
 
Drives: 08' 335i
Join Date: Feb 2012
Location: Lynnwood, WA

Posts: 121
iTrader: (0)

Garage List
Quote:
Originally Posted by dlbrooks18 View Post
Did you have the battery cable recall done yet?
According to the maintenance record from the previous owner he had the battery terminal recall done in April 13, 2013. Is this the one you were talking about?
Kalvin is offline   Hong Kong
0
Reply With Quote
      01-21-2014, 01:47 AM   #16
dlbrooks18
Brigadier General
 
dlbrooks18's Avatar
 
Drives: e90 335i
Join Date: Nov 2008
Location: Los Angeles

Posts: 3,565
iTrader: (2)

Yes.. ok hope you get it figured out.
__________________

2008 E90 335
dlbrooks18 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:15 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST