E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Engine Cuts Out!!



Reply
 
Thread Tools Search this Thread
      07-30-2012, 10:23 PM   #1
JelloXI
0
Private
 
JelloXI's Avatar
 
Drives: e90 330XI
Join Date: Jan 2012
Location: fairfax, va

Posts: 60
iTrader: (1)

Engine Cuts Out!!

so the other day took off the air box to replace filter and removed MAF, put everything back.

coincidentally little while after sitting at the red light, foot on clutch and in first gear, waiting for light to turn green, i hit the gas and and nothing....

look down at the cluster and RPM is at 0 and service light is on (hmmm weir i guess i stalled out??) press down on clutch and start the motor and drive off.

later that night taking and exit ramp down shift into second while turning and then RPM drops to 0 again and service light comes on again this time also with windshield washer fluid light and now crap! since car is off power steering is out(this happened while rolling)

this morning rolling then making a right turn in second happens again!!!!

then someone said "clean your MAF" so i got home from work and cleaned and drive again, seems fine and happened again this time like the first while stationary at a redlight again clutch down in first waiting for light to change.

WTFFFFFFFFF is GOING ON??? driving me nuts?

so far...

cleaned MAF

about to....

disconnect MAF and drive a few days and see if it happens again?

for all the techies, any other ideas?
JelloXI is offline  
Appreciate 0
Reply With Quote
      07-31-2012, 03:30 AM   #2
Cisco661
0
Cisco661
 
Cisco661's Avatar
 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California

Posts: 921
iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
How did you clean it? Its a very sensitive piece and could've possibly gotten damaged.
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Cisco661 is offline   United_States
Appreciate 0
Reply With Quote
      07-31-2012, 07:59 AM   #3
JelloXI
0
Private
 
JelloXI's Avatar
 
Drives: e90 330XI
Join Date: Jan 2012
Location: fairfax, va

Posts: 60
iTrader: (1)

CRC MAF cleaner. sprayed once the MAF has been outta the car for at least an hour
JelloXI is offline  
Appreciate 0
Reply With Quote
      08-16-2012, 02:27 PM   #4
JelloXI
0
Private
 
JelloXI's Avatar
 
Drives: e90 330XI
Join Date: Jan 2012
Location: fairfax, va

Posts: 60
iTrader: (1)

so new MAF and same issue occurred FML any feedback?
JelloXI is offline  
Appreciate 0
Reply With Quote
      08-16-2012, 02:51 PM   #5
RupertPupkin
0
Lieutenant Colonel
 
RupertPupkin's Avatar
 
Drives: Freak Beast
Join Date: Aug 2011
Location: East

Posts: 1,534
iTrader: (5)

Had this problem in my old Prelude. It would just turn off while driving with no pattern. Turned out to be the ignition switch. I would maybe check your on/off button or key connection, etc.
RupertPupkin is offline   United_States
Appreciate 0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST