E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Idrive dead after battery reset. Help needed



Reply
 
Thread Tools Search this Thread
      08-05-2012, 02:45 PM   #1
Autobahn335i
Lieutenant Colonel
Autobahn335i's Avatar
Luxembourg
28
Rep
1,600
Posts

 
Drives: E92 335i
Join Date: Mar 2009
Location: Luxembourg

iTrader: (5)

Idrive dead after battery reset. Help needed

So I disconnected the battery (black terminal) for 30 minutes, reconnected it and now the Idrive is dead: black screen, controller moving freely. Radio isn't working either. And I also get a "SOS not working" symbol in the dashboard when starting the car.

What can I do to fix this??
__________________
Performance Seats, Exhaust, Splitters, Pedals, Steering Wheel / RB Turbos / M3 CF Roof / Brembo GT BBK 355/345 / Rollcage / Forge FMIC / Quaife LSD / Íhlins Road & Track / M3 Suspension Parts / Powerflex Bushings / Vorshlag Camberplates / Megan Racing Toe Links / LeatherZ Gauges / Extended M3 DCT Paddles / ER Sports OC / AR OC / Aux Radiator / AR DPs / Alpina TCU / COBB Pro-Tune
Appreciate 0
      08-07-2012, 11:35 AM   #2
Autobahn335i
Lieutenant Colonel
Autobahn335i's Avatar
Luxembourg
28
Rep
1,600
Posts

 
Drives: E92 335i
Join Date: Mar 2009
Location: Luxembourg

iTrader: (5)

Disconnecting the battery again for some time fixed it Phew.
__________________
Performance Seats, Exhaust, Splitters, Pedals, Steering Wheel / RB Turbos / M3 CF Roof / Brembo GT BBK 355/345 / Rollcage / Forge FMIC / Quaife LSD / Íhlins Road & Track / M3 Suspension Parts / Powerflex Bushings / Vorshlag Camberplates / Megan Racing Toe Links / LeatherZ Gauges / Extended M3 DCT Paddles / ER Sports OC / AR OC / Aux Radiator / AR DPs / Alpina TCU / COBB Pro-Tune
Appreciate 0
      08-07-2012, 12:08 PM   #3
onebadmofo
Banned
Russian Federation
54
Rep
2,394
Posts

 
Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

iTrader: (14)

Yep, was about to say to give it some time or unplug the battery again. Had issues with dead idrive after the car been sitting for months and the battery went. Thought the whole thing was dead but it started working next day on its own.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:27 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST