E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > red warning lights in dash...not sure what it means?? pls help



Reply
 
Thread Tools Search this Thread
      08-11-2012, 03:24 PM   #1
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Question red warning lights in dash...not sure what it means?? pls help

Hi Guys....just today when I started my car I get a combination of these two warning lights...is this an indication that my brake pads are worn out? or low brake fluid? or something else to do with starter or electronic failure..pls let me know, thanks..pls see the attached pic..
Attached Images
 
satish_141 is offline  
0
Reply With Quote
      08-11-2012, 03:36 PM   #2
nicktyler
Major
 
Drives: 335i (sadly gone)
Join Date: Jan 2012
Location: Essex

Posts: 1,159
iTrader: (3)

Garage List
It's the handbrake on and seatbelt not fastened.
nicktyler is offline   United Kingdom
0
Reply With Quote
      08-11-2012, 03:42 PM   #3
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by nicktyler View Post
It's the handbrake on and seatbelt not fastened.

sorry I took the pic when the car was stopped..I had to lean forward to take close pic so didnt put the seat belt on...

I think for hand brake on you get a "P" in the middle...guess this is something else..
satish_141 is offline  
0
Reply With Quote
      08-11-2012, 08:39 PM   #4
DuckySpud
Lieutenant
 
DuckySpud's Avatar
 
Drives: 320D Touring
Join Date: Jul 2012
Location: Sheffield

Posts: 569
iTrader: (1)

A quick search brought up a PDF of all the symbols, think that combo is showing worn brake pads
DuckySpud is offline   United Kingdom
0
Reply With Quote
      08-12-2012, 03:04 AM   #5
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by DuckySpud
A quick search brought up a PDF of all the symbols, think that combo is showing worn brake pads
thank you :-)
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 04:08 AM   #6
mistryn
Lieutenant Colonel
 
mistryn's Avatar
 
Drives: BMW 335D
Join Date: Oct 2011
Location: Mids

Posts: 1,981
iTrader: (7)

Whats the condition of your brake pads like?
Looks like to me the sensor has been activated for low brake pad
Check also your brake fluid level (looking at engine bay remove top left plastic cover and the resovoir is located underneath)
mistryn is offline  
0
Reply With Quote
      08-12-2012, 05:14 AM   #7
alzieboy
First Lieutenant
 
alzieboy's Avatar
 
Drives: 318d LCI exclusive edition
Join Date: Feb 2012
Location: Norfolk moved from East London

Posts: 340
iTrader: (1)

My Wifes 118d kept showing the identical (RED car on ramp) , after a couple of visits back to dealership it was found to be a Can Bus error , this was caused by the Parrot hands free kit installed in car. Once the hand free kit was removed the error never showed up again.
alzieboy is offline   United Kingdom
0
Reply With Quote
      08-12-2012, 06:49 AM   #8
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by mistryn View Post
Whats the condition of your brake pads like?
Looks like to me the sensor has been activated for low brake pad
Check also your brake fluid level (looking at engine bay remove top left plastic cover and the resovoir is located underneath)

hi thank you...the brakes seem to be working fine and I remember I have had the rear brake discs and pads done 1.5 years ago and front brake disc and pads done a year ago..so not sure...but yes I will check the brake fluid level now...may be it is the brake fluid gone down...
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 06:51 AM   #9
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by alzieboy View Post
My Wifes 118d kept showing the identical (RED car on ramp) , after a couple of visits back to dealership it was found to be a Can Bus error , this was caused by the Parrot hands free kit installed in car. Once the hand free kit was removed the error never showed up again.
ok..but I havent got any parro kit installed...so guess it is either to with brake pads or brake fluid..will get it checked tomorrow as it is sunday today...only worry is to drive till the garage...may need to go very slowly...
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 06:53 AM   #10
mistryn
Lieutenant Colonel
 
mistryn's Avatar
 
Drives: BMW 335D
Join Date: Oct 2011
Location: Mids

Posts: 1,981
iTrader: (7)

Who did you get your brakes replaced by?
did they use new sensor or replaced old one?

If you have a quick look through your alloys at the condition of the pads this should give you a rough indication. If they are ok (unless you have been doing some heavy braking) I think the garage may not have reset the brake service indicator
mistryn is offline  
0
Reply With Quote
      08-12-2012, 07:16 AM   #11
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by mistryn View Post
Who did you get your brakes replaced by?
did they use new sensor or replaced old one?

If you have a quick look through your alloys at the condition of the pads this should give you a rough indication. If they are ok (unless you have been doing some heavy braking) I think the garage may not have reset the brake service indicator
hi when I got the rear brakes done it was SYTNER BMW sunningdale and when I got the front brakes done it was SYTNER BMW Maidenhead...will check the brake pad condition physically now...I couldn't locate where I could find the brake fluid under the bonnet
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 07:18 AM   #12
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,836
iTrader: (47)

This sometime happens if you disconnect your battery / update your module and system loose the track of your date and time. So computer thinks your services is due.
First thing, check your date and time. If that is correct, move on to next.

Go to service history and see which things are red? Is there anything else which is red other than this sign, and that will answer your question.

If this is only red sign, then check which one is nearest service coming and that may give your clue. If that is your brake pads, then as mistryn and other suggested, worth of checking your pads / sensors.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      08-12-2012, 07:56 AM   #13
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
This sometime happens if you disconnect your battery / update your module and system loose the track of your date and time. So computer thinks your services is due.
First thing, check your date and time. If that is correct, move on to next.

Go to service history and see which things are red? Is there anything else which is red other than this sign, and that will answer your question.

If this is only red sign, then check which one is nearest service coming and that may give your clue. If that is your brake pads, then as mistryn and other suggested, worth of checking your pads / sensors.
hi thank you...checked the date and time and it is correct...then checked the items in the service history and all the items are YELLOW, none of them shows RED...but my car is due for a MOT end of august so it could be warning that as a vehicle check? because the sign with car on the ramp is for vehicle check I think...either way I will get the brake pads and fluid checked tomorrow....
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 08:29 AM   #14
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

also What about the handbrake light constantly being on though on the dash? Does that tie in with it just being a standard check?
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 10:34 AM   #15
greatbm
Captain
 
greatbm's Avatar
 
Drives: F33 428i M-Sport convertible
Join Date: Feb 2007
Location: North East UK

Posts: 807
iTrader: (0)

Quote:
Originally Posted by satish_141 View Post
also What about the handbrake light constantly being on though on the dash? Does that tie in with it just being a standard check?
No, should be no handbrake. Looks like brake pads to me.
greatbm is online now   United Kingdom
0
Reply With Quote
      08-12-2012, 11:20 AM   #16
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Question

Quote:
Originally Posted by greatbm View Post
No, should be no handbrake. Looks like brake pads to me.
ok...will get new brake pads..

one question...would it be a rear brake pads ten? as the front ones I only got them changed last year?
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 11:45 AM   #17
makkan00
Major General
 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex

Posts: 6,836
iTrader: (47)

Quote:
Originally Posted by greatbm View Post
No, should be no handbrake. Looks like brake pads to me.
What he said.

Out of brake pads, if rears have less life, then start with them.
__________________
makkan00 is offline   United Kingdom
0
Reply With Quote
      08-12-2012, 12:35 PM   #18
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
What he said.

Out of brake pads, if rears have less life, then start with them.
thank you..makes sense..
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 12:39 PM   #19
Kerr
Brigadier General
 
Drives: 08' 335i Coupe
Join Date: Dec 2010
Location: Aberdeen

Posts: 3,530
iTrader: (0)

When my brakes were needing replaced it goes amber first.

Why don't you check what the status of the brake wear is on your display?

Is will show if it is indeed the brakes that need done rather than guessing.
Kerr is offline   Scotland
0
Reply With Quote
      08-12-2012, 12:53 PM   #20
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
Presumably the OP has taken the photograph whilst the handbrake is engaged. Hence the handbrake symbol is lit. Presumably the seatbelt wasn't fastened - hence the seatbelt sign is lit.

The vehicle on the ramp symbol means a "Vehicle Check" is due. This is a straightforward visual inspection undertaken by the dealer for which you will be charged an inordinate amount of money for the actual time spent.

I would double check these symbols in the manual before assuming that you need to replace the brakes. All of the symbols are explained in the manual.
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
      08-12-2012, 01:08 PM   #21
satish_141
Second Lieutenant
 
Drives: 320D
Join Date: Nov 2010
Location: Reading

Posts: 261
iTrader: (0)

i am not worried about the car on ramp sign...as it is vechicle check..what is worrying is i get the red hand brake indicator on dash while driving and handbrake is put down.....
satish_141 is offline  
0
Reply With Quote
      08-12-2012, 01:16 PM   #22
tmarshall57
Lieutenant
 
Drives: E90 330d
Join Date: Apr 2008
Location: Bury, Lancs, UK

Posts: 452
iTrader: (0)

Garage List
Defective "handbrake on" switch/sensor? I'm sure that circle with the exclamation mark in the centre means the car thinks that the handbrake is on.
__________________
e90 330d, Montego Blue, Beige Dakota Leather, Auto, Nav Pro, Bluetooth Prep, BMW Connected Drive, Voice Control, Sports Seats, Split Rear Seat, 18" Ellipsoid Wheels Style 162 Burr Walnut Trim
tmarshall57 is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:42 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST