E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Rough Idle



Reply
 
Thread Tools Search this Thread
      07-24-2012, 02:42 PM   #1
Nocomment328
New Member
0

 
Drives: 3
Join Date: Sep 2011
Location: USA


Posts: 7
iTrader: (0)

Rough Idle

Hello. First I want to say thanks to everyone's posts. I've been able to search just about every problem I've had with my car and get it fixed without all the extra guess work. However I'm having an issue I cant seem to resolve.

07 e90. 328xi

Car drives beautiful with 120k miles now except it has a strange rough idle. I've has o2 sensors changed. Spark plugs changed, and then had the gaps rechecked. Belts and battery were replaced. Etc.

Here's the part that I'm hoping someone can help to diagnose. If I roll forward with foot on the brake, the roughness goes away. Soon as at a complete standstill, roughness returns. I don't hear any noises anywhere - just feel it throughout the car and steering wheel. It's noticeably less if not existent when the air conditioner is on as opposed to it being off. I've tried fuel Injector cleaner. Use only 93 octane gas. I don't know what else to look at.

Any ideas????
Appreciate 0
      07-24-2012, 06:30 PM   #2
BKV122
Major
United_States
14

 
BKV122's Avatar
 
Drives: E90
Join Date: Feb 2009
Location: NY


Posts: 1,094
iTrader: (1)

Garage List
2006 330xi  [4.75]
Do you get a Service engine light?
__________________

Monaco Blue 330xi - Terra Interior/6-MT/Sport/Premium/Cold/CSL's/M3 Spoiler Lip/Black Kidney's
Appreciate 0
      08-15-2012, 10:14 PM   #3
Nocomment328
New Member
0

 
Drives: 3
Join Date: Sep 2011
Location: USA


Posts: 7
iTrader: (0)

Yeah I had a cel and it ended up being the two front end o2 sensors. Car still idles rough (vibrates)...
Appreciate 0
      08-16-2012, 08:57 AM   #4
bigtracing
Second Lieutenant
United_States
3

 
bigtracing's Avatar
 
Drives: 2008 ///M3
Join Date: Apr 2011
Location: CT


Posts: 208
iTrader: (1)

When my 08 did this they replaced the MAF sensor. It came up as that when they scanned the car.
Appreciate 0
      09-10-2012, 12:39 PM   #5
kashanova
Private
0

 
Drives: bmw
Join Date: Feb 2012
Location: United States


Posts: 61
iTrader: (0)

My 08 is doing this now, I only have 29k miles. Is it unusual for a low miledge vechile to have a rough idle?
Appreciate 0
      10-05-2012, 10:09 PM   #6
dylim
Second Lieutenant
3

 
Drives: 328xi
Join Date: Mar 2012
Location: bay area


Posts: 240
iTrader: (3)

Quote:
Originally Posted by bigtracing View Post
When my 08 did this they replaced the MAF sensor. It came up as that when they scanned the car.
Did that fix the problem? When I took it to the dealer, they replaced the VANOS solenoids - about $650, but the problem still exists. Very rough idle when AC off. When AC on, much better. 08 328xi.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:48 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST