E90Post
 


The Tire Rack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Help needed on installation issue with android CCC idrive screen replacement



Reply
 
Thread Tools Search this Thread
      09-13-2017, 04:16 PM   #1
-DK-
Registered
0
Rep
3
Posts

Drives: E91 335i M-Sport
Join Date: May 2017
Location: Hamilton, New Zealand

iTrader: (0)

Help needed on installation issue with android CCC idrive screen replacement

Hi Guys,

Need help,

Bought an android screen for my 2006 e91 CCC idrive.

https://www.aliexpress.com/item/8-8-...311.0.0.y5gs2S

The seller assured me it will work not only with the e60 but also for the E9x

pretty straight forward installation, plug and play harness, only need to move the optic fiber plug from the original connector to the new harness connector from the rear of the HU.

my issue, after i installed, i hooked up the negative battery terminal. the wipers and washer pumps then immediately starts running out of control, no response from the ignition button etc. only way to stop it was to pull the neg battery terminal off.

so i reinstalled the old screen all back to normal, and everything seems good again. i retry'd the installation and same issue.

the seller assured me the unit will work for my car....

i had this same issue before a long time ago when i had my old reverse camera interface box installed, when i didn't have the LVDS shield ground connected...

i could replicate this issue with the standard screen by just pulling out the LVDS connector from the rear of the screen.

or is there something up with my canbus, or optic fiber network..

where do i start?

thanks in advance

Cheers

Dieter
Appreciate 0
      09-14-2017, 07:20 PM   #2
dreyo27
Second Lieutenant
38
Rep
277
Posts

Drives: 2007 335i e92
Join Date: Aug 2015
Location: Sacramento CA

iTrader: (3)

Picture of the screen? is it touchscreen?

Also do you have JB4 installed?

Sounds like a can bus issue.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:51 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST