E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > 330i broke down today :/



Reply
 
Thread Tools Search this Thread
      08-15-2012, 07:44 PM   #1
KDynastyE90
Enlisted Member
0
Rep
38
Posts

 
Drives: Silver Metallic E90 330i
Join Date: Jan 2009
Location: New Jersey

iTrader: (1)

330i broke down today :/

Left work. Drove maybe a quarter mile to the highway. As i accelerated i felt loss of power and service engine soon light came on. Pulled over ad engine was sputtering and idle jumping up and down. I had it towed to the dealer where i must wait til tomorrow morning to call. Anyone have ideas what it could be? Im pretty scared as the car is out of warranty for a year now. No previous issues
Appreciate 0
      08-15-2012, 09:17 PM   #2
monkey_wrench
Caught the Bimmer-Bug
monkey_wrench's Avatar
No_Country
10
Rep
660
Posts

 
Drives: '06 330i
Join Date: Aug 2011
Location: Florida

iTrader: (10)

Garage List
2006 330i  [0.00]
How many miles? Could be as simple as a coil gone out.

Perhaps you should get a cable and a little laptop to check your error codes yourself. You can at least determine if it's something you can do yourself or if you need to have it done.
Appreciate 0
      08-15-2012, 10:05 PM   #3
KDynastyE90
Enlisted Member
0
Rep
38
Posts

 
Drives: Silver Metallic E90 330i
Join Date: Jan 2009
Location: New Jersey

iTrader: (1)

The car has almost 68k miles on it. Hopefully it is something simple. I had it towed to the dealer so I'm going to give them a call tomorrow morning and hopefully get a response/estimate later on in the day. I feel so bummed out right now, the car never gave me any issues.
Appreciate 0
      08-15-2012, 10:42 PM   #4
cc_bavarian
First Lieutenant
cc_bavarian's Avatar
Hong Kong
6
Rep
316
Posts

 
Drives: 2007+ E90 330i
Join Date: Nov 2010
Location: Hong Kong

iTrader: (0)

Garage List
2007 E90 330i  [0.00]
Same thing happened to me once. You have the bms powerbox installed? Could be loose wiring. That was my problem.

Quote:
Originally Posted by KDynastyE90 View Post
Left work. Drove maybe a quarter mile to the highway. As i accelerated i felt loss of power and service engine soon light came on. Pulled over ad engine was sputtering and idle jumping up and down. I had it towed to the dealer where i must wait til tomorrow morning to call. Anyone have ideas what it could be? Im pretty scared as the car is out of warranty for a year now. No previous issues
Appreciate 0
      08-16-2012, 09:19 AM   #5
Dracon
BimmerPost Supporting Vendor
United_States
29
Rep
1,075
Posts


 
Drives: 2006 330i E90
Join Date: Apr 2009
Location: Nashville, TN

iTrader: (20)

Could be a bad ignition coil. As far as cost, you can buy a new coil for ~40$ from Tischer and it'll take maybe 30 minutes to replace. Dealership will cost you around $70 for the coil and probably an hours labor on top of any diagnostic fee they may have.
Appreciate 0
      08-16-2012, 10:23 AM   #6
flexbrah
hehe ty men
flexbrah's Avatar
4
Rep
124
Posts

 
Drives: :|
Join Date: Jul 2012
Location: Tampa, FL

iTrader: (1)

it could be either a bad coil or plugs. you can do both yourself in your garage in less than 30 mins if you've never done it before. easiest DIY by far... so i wouldn't get the stealership to do it for you.
Appreciate 0
      08-31-2012, 04:38 PM   #7
index1489
Colonel
index1489's Avatar
United_States
29
Rep
2,116
Posts

 
Drives: Out of warranty BMW
Join Date: Sep 2008
Location: Chino, CA

iTrader: (7)

Quote:
Originally Posted by Dracon View Post
Could be a bad ignition coil. As far as cost, you can buy a new coil for ~40$ from Tischer and it'll take maybe 30 minutes to replace. Dealership will cost you around $70 for the coil and probably an hours labor on top of any diagnostic fee they may have.
Lol dealers want 90-100 for a ignition coil out here.
45 or so from tischer
__________________
Gotta pay to play.
Appreciate 0
      08-31-2012, 06:40 PM   #8
Benjie
New Member
Benjie's Avatar
United_States
0
Rep
14
Posts

 
Drives: 2006 325I
Join Date: Feb 2011
Location: California

iTrader: (1)

same thing happened to me about a year ago at around the same mileage. i had a bad ignition coil. found out that my battery was going out and was a common problem for our cars. changed both and replaced the plugs while at it. car feels like super smooth now.
Appreciate 0
      09-01-2012, 03:53 PM   #9
e93boy
VP
e93boy's Avatar
United_States
0
Rep
80
Posts

 
Drives: Black on Tan leather E93,
Join Date: May 2012
Location: So Cal

iTrader: (2)

Quote:
Originally Posted by KDynastyE90
Left work. Drove maybe a quarter mile to the highway. As i accelerated i felt loss of power and service engine soon light came on. Pulled over ad engine was sputtering and idle jumping up and down. I had it towed to the dealer where i must wait til tomorrow morning to call. Anyone have ideas what it could be? Im pretty scared as the car is out of warranty for a year now. No previous issues
I had a similar issue with my e60. Was freaked out till I found out it was coil as well, wasn't as scary as I thought. turned out to be 2 coils and while I was at it I changed the spark plugs as well. It was good as new
Appreciate 0
      09-04-2012, 06:28 AM   #10
parrp
Private First Class
parrp's Avatar
United Kingdom
2
Rep
140
Posts

 
Drives: 3er
Join Date: Oct 2011
Location: UK

iTrader: (0)

Not sure what year your car is but BMW have just changed all the ignition coils on my 330i as a recall.
Appreciate 0
      09-04-2012, 08:04 AM   #11
BudVlad
Old Geezer
BudVlad's Avatar
Czech_Republic
47
Rep
1,001
Posts

 
Drives: 08 E92 N53B30
Join Date: Jul 2007
Location: Budweis

iTrader: (0)

Garage List
2008 E92 N53B30  [0.00]
My ignition coils were changed last week as a recall. Before the recall I had to replace ignition coil twice.
__________________
Appreciate 0
      09-05-2012, 07:48 AM   #12
Cisco661
Cisco661
Cisco661's Avatar
United_States
13
Rep
921
Posts

 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California

iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
Quote:
Originally Posted by parrp
Not sure what year your car is but BMW have just changed all the ignition coils on my 330i as a recall.
Ate these coils replaced under a recall only if under warranty? I have an 06 330i and have had multiple coils go out. Info would be appreciated.
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Appreciate 0
      09-05-2012, 09:23 AM   #13
BudVlad
Old Geezer
BudVlad's Avatar
Czech_Republic
47
Rep
1,001
Posts

 
Drives: 08 E92 N53B30
Join Date: Jul 2007
Location: Budweis

iTrader: (0)

Garage List
2008 E92 N53B30  [0.00]
My car is out of warranty and the coils were replaced free of charge.
__________________
Appreciate 0
      09-05-2012, 05:07 PM   #14
Cisco661
Cisco661
Cisco661's Avatar
United_States
13
Rep
921
Posts

 
Drives: 2006 Monaco Blue 330I
Join Date: Jul 2011
Location: California

iTrader: (17)

Garage List
2006 BMW 330i  [0.00]
good to hear but i see you and parrp are from out of the country. ima go to dealer and find out. i wouldnt mind getting some free new coils. i just replaced the spark plugs last week.
__________________
2006 330i/ Monaco Blue/ ZSP/ ZPP/ I Drive/ Burl Walnut Trim/ Steptronic/ Xenon Adaptives/ Logic7/ CF Mirror Caps/ Matte Black Grills
Appreciate 0
      09-06-2012, 12:57 PM   #15
BoogeyMan'sBMW
Major
BoogeyMan'sBMW's Avatar
Bangladesh
18
Rep
1,380
Posts

 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

iTrader: (3)

sounds like a misfire

might be loose wiring if you have a pbx, if not still a rather easy fix.

could be coils or plugs you can check it for yourself in your garage in like 10 min. waiting to see what ridiculous diagnosis the stealership gives you
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:54 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST