E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Service indicator



Reply
 
Thread Tools Search this Thread
      09-12-2012, 02:45 PM   #1
douwe22
dual Afe intake/ cobb/ forge dv's/ 94 oct.
 
douwe22's Avatar
 
Drives: 2008 bmw 335xi, 2008 x5 4.8i
Join Date: Mar 2012
Location: niagara region

Posts: 309
iTrader: (1)

Service indicator

I tried searching but no luck, my service indicator for the front brakes wont reset, it keeps saying -15000, brakes are new and fluid too, brake sensor seems okay ad well, any ideas? Here is a pic,
Attached Images
 

Last edited by douwe22; 09-12-2012 at 07:12 PM.
douwe22 is offline   Canada
0
Reply With Quote
      09-12-2012, 06:30 PM   #2
DrSeuss99
Enlisted Member
 
Drives: PimpMobile
Join Date: Jan 2012
Location: Left Bank

Posts: 46
iTrader: (0)

can't see the pics
DrSeuss99 is offline  
0
Reply With Quote
      09-12-2012, 07:15 PM   #3
douwe22
dual Afe intake/ cobb/ forge dv's/ 94 oct.
 
douwe22's Avatar
 
Drives: 2008 bmw 335xi, 2008 x5 4.8i
Join Date: Mar 2012
Location: niagara region

Posts: 309
iTrader: (1)

Quote:
Originally Posted by douwe22 View Post
I tried searching but no luck, my service indicator for the front brakes wont reset, it keeps saying -15000, brakes are new and fluid too, brake sensor seems okay as well, any ideas? Here is a pic,
bump, got picture now
douwe22 is offline   Canada
0
Reply With Quote
      09-12-2012, 07:45 PM   #4
Built My Way
Lieutenant
 
Built My Way's Avatar
 
Drives: mls ----------
Join Date: Apr 2011
Location: The Friendly Maritimes

Posts: 457
iTrader: (0)

Garage List
I'm thinking your brake sensor is not OK. Take it off and check for wear or for $30, just go buy a new one. My 2c.
__________________
My girl is inherently balanced. Lucky me!
Built My Way is offline   Canada
0
Reply With Quote
      09-12-2012, 07:55 PM   #5
douwe22
dual Afe intake/ cobb/ forge dv's/ 94 oct.
 
douwe22's Avatar
 
Drives: 2008 bmw 335xi, 2008 x5 4.8i
Join Date: Mar 2012
Location: niagara region

Posts: 309
iTrader: (1)

Quote:
Originally Posted by Built My Way
I'm thinking your brake sensor is not OK. Take it off and check for wear or for $30, just go buy a new one. My 2c.
Thanx i guess for 30 bucks its worth a shot, hopefully that will fix it, diy 2 morrow and see what happens
douwe22 is offline   Canada
0
Reply With Quote
      09-13-2012, 01:12 AM   #6
Garik
New Member
 
Garik's Avatar
 
Drives: 2010 335iM
Join Date: Sep 2012
Location: Bellevue, WA

Posts: 24
iTrader: (0)

Brake sensor must be replaced if the light went off. If you replace pads before light goes off, then sensor would be saved...
__________________
2010 335i M+PPK
Garik is offline   United_States
0
Reply With Quote
      09-13-2012, 06:02 AM   #7
douwe22
dual Afe intake/ cobb/ forge dv's/ 94 oct.
 
douwe22's Avatar
 
Drives: 2008 bmw 335xi, 2008 x5 4.8i
Join Date: Mar 2012
Location: niagara region

Posts: 309
iTrader: (1)

Quote:
Originally Posted by Garik
Brake sensor must be replaced if the light went off. If you replace pads before light goes off, then sensor would be saved...
Thank you, thats what i did, replaced brakes before light came on a couple of months ago, my pads are fine, going to change sensor today, see what happens, can always keep it for a spare if it don't fix my problem i guess
douwe22 is offline   Canada
0
Reply With Quote
      09-13-2012, 08:43 AM   #8
douwe22
dual Afe intake/ cobb/ forge dv's/ 94 oct.
 
douwe22's Avatar
 
Drives: 2008 bmw 335xi, 2008 x5 4.8i
Join Date: Mar 2012
Location: niagara region

Posts: 309
iTrader: (1)

Replaced brake sensor, tried resetting service indicator, now it worked fine, no more warnings on dash anymore, problems fixed, thanx for the suggestions and replies
douwe22 is offline   Canada
0
Reply With Quote
      09-13-2012, 09:38 AM   #9
Built My Way
Lieutenant
 
Built My Way's Avatar
 
Drives: mls ----------
Join Date: Apr 2011
Location: The Friendly Maritimes

Posts: 457
iTrader: (0)

Garage List
Hey, good stuff! FYI I dont use the sensors. Since I do all my brake work myself, I just tie them back out of the way and check the pads from time to time. Easy!
__________________
My girl is inherently balanced. Lucky me!
Built My Way is offline   Canada
0
Reply With Quote
      09-13-2012, 10:54 AM   #10
DrSeuss99
Enlisted Member
 
Drives: PimpMobile
Join Date: Jan 2012
Location: Left Bank

Posts: 46
iTrader: (0)

Glad you figured it out...
DrSeuss99 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:03 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST