E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > please help! misfire on cylinder 3



Reply
 
Thread Tools Search this Thread
      09-11-2012, 07:31 PM   #1
eseng
Second Lieutenant
United_States
2
Rep
200
Posts

 
Drives: 07 SGM 335i coupe
Join Date: Mar 2010
Location: rialto, ca

iTrader: (10)

Send a message via AIM to eseng
please help! misfire on cylinder 3

please help.

i keep getting a misfire on cycliner three and don't know what to do next.

i have changed all my spark plugs less than 2000 miles ago. i have replaced the coil for cylinder 3.

still getting the same fault code.

what would the next step be?? injector??

your help is much appreciated.
Appreciate 0
      09-11-2012, 07:39 PM   #2
335xi Kevo
Lieutenant
335xi Kevo's Avatar
7
Rep
502
Posts

 
Drives: 2008 335xi
Join Date: Jan 2012
Location: CT

iTrader: (3)

Injector, more then likely could also be build up.
__________________
08' 335xi 6MT
Space Metallic Grey
Premium, Nav, Cold weather, Sport
Procede 2.5, DCI, Forge DV, PWM, Scoops, KW V1, ETS 5" FMIC, VRSF Downpipes, M3 Skirts
Appreciate 0
      09-11-2012, 07:55 PM   #3
themyst
Major General
themyst's Avatar
South Korea
86
Rep
6,602
Posts

 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
or lately as some have found, a bad DME.
__________________
E90 LCI N54 6AT
Appreciate 0
      09-11-2012, 07:58 PM   #4
eseng
Second Lieutenant
United_States
2
Rep
200
Posts

 
Drives: 07 SGM 335i coupe
Join Date: Mar 2010
Location: rialto, ca

iTrader: (10)

Send a message via AIM to eseng
Quote:
Originally Posted by themyst View Post
or lately as some have found, a bad DME.
dme sounds expensive....

well my car does have 85k miles...maybe i should try walnut blasting
Appreciate 0
      09-11-2012, 09:09 PM   #5
Manny_World
Colonel
Manny_World's Avatar
United_States
32
Rep
2,380
Posts

 
Drives: e92 335i, e34 525i & e60 530i
Join Date: Aug 2011
Location: N Las Vegas

iTrader: (12)

Garage List
2007 BMW 335i  [4.00]
2007 BMW 530i  [4.33]
1994 BMW 525i  [0.00]
Having same the issue, I think it's my rear o2 sensor since I'm getting a lambda probe trim code.
__________________
Appreciate 0
      09-12-2012, 09:05 PM   #6
eseng
Second Lieutenant
United_States
2
Rep
200
Posts

 
Drives: 07 SGM 335i coupe
Join Date: Mar 2010
Location: rialto, ca

iTrader: (10)

Send a message via AIM to eseng
Quote:
Originally Posted by Manny_World View Post
Having same the issue, I think it's my rear o2 sensor since I'm getting a lambda probe trim code.

let me know if that fixes ur problems.
Appreciate 0
      09-12-2012, 10:52 PM   #7
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Quote:
Originally Posted by eseng
please help.

i keep getting a misfire on cycliner three and don't know what to do next.

i have changed all my spark plugs less than 2000 miles ago. i have replaced the coil for cylinder 3.

still getting the same fault code.

what would the next step be?? injector??

your help is much appreciated.
I had the same problem, I changed the injector from 2 to 3 and the misfire moved. Try that, if the misfire moves that means the injector is bad. Also make sure you have the decoupling element of the injector 3, that was my issue as well
Appreciate 0
      09-14-2012, 12:00 PM   #8
eseng
Second Lieutenant
United_States
2
Rep
200
Posts

 
Drives: 07 SGM 335i coupe
Join Date: Mar 2010
Location: rialto, ca

iTrader: (10)

Send a message via AIM to eseng
Quote:
Originally Posted by Gfabry View Post
I had the same problem, I changed the injector from 2 to 3 and the misfire moved. Try that, if the misfire moves that means the injector is bad. Also make sure you have the decoupling element of the injector 3, that was my issue as well
do i have to code the injectors after i switch them? because im not that savy in engine repair.....

thanks
Appreciate 0
      09-14-2012, 12:13 PM   #9
GAM
Lieutenant
GAM's Avatar
8
Rep
466
Posts

 
Drives: 2011 E92 M3
Join Date: Mar 2012
Location: Palm Beach

iTrader: (1)

Quote:
Originally Posted by eseng View Post
do i have to code the injectors after i switch them? because im not that savy in engine repair.....

thanks
The correct procedure is to take the car to a shop and have the injector coded, between 60 to 90, I didn't do it on mine, yet. Some people say you should, some other are saying that the car will adapt no problem
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:31 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST