E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > "Service Engine Soon" Question



Reply
 
Thread Tools Search this Thread
      09-17-2012, 11:41 AM   #1
Pharaoh2716
Private First Class
Pharaoh2716's Avatar
United_States
23
Rep
148
Posts

 
Drives: 2011 BMW 335i Coupe
Join Date: Oct 2010
Location: Bay Area, California

iTrader: (0)

"Service Engine Soon" Question

I was driving down to Santa Barbara from the bay area, and was going about 100 in the middle of nowhere when my "service engine soon" light popped on. I arrived in Santa Barbara, left my car for a couple hours, then got back in and turned it on. The light was not illuminated any more. Do I have anything to be concerned about? Thanks!
__________________
Stage One N55 Burger Motorsports Tune
Appreciate 0
      09-17-2012, 12:10 PM   #2
E90Company
Major General
E90Company's Avatar
No_Country
72
Rep
6,140
Posts

 
Drives: Car
Join Date: Mar 2012
Location: FL

iTrader: (2)

Read codes. Probably a misfire
Appreciate 0
      09-17-2012, 02:52 PM   #3
JStreet_EAC2
EAC TN Chapter
United_States
0
Rep
5
Posts

 
Drives: E92 335i
Join Date: Sep 2012
Location: Clarksville, TN

iTrader: (0)

Garage List
2007 335i  [0.00]
Had the same issue. Most likely a misfire. Ran my DME codes while datalogging. Pulled a missfire code. Replaced all the spark plugs. Problem solved.
Appreciate 0
      09-17-2012, 05:42 PM   #4
bumere90
Grozniy
United_States
52
Rep
2,601
Posts

 
Drives: Carless
Join Date: Jan 2009
Location: FL

iTrader: (12)

a misfire? his car is almost brand new
__________________
-fatman
Appreciate 0
      09-17-2012, 10:31 PM   #5
tsensational
New Member
0
Rep
9
Posts

 
Drives: 328i Coupe
Join Date: Sep 2012
Location: United States

iTrader: (0)

First thing to do is to scan the code. If it went away, its probably not too much to worry about, but you want to know just in case. Could be crappy gas, O2 sensor being stupid, or a bunch of easy to fix issues. Either way, code first.
Appreciate 0
      09-17-2012, 11:24 PM   #6
manutdas11
EL JIMMY NEURON
manutdas11's Avatar
United_States
13
Rep
1,209
Posts

 
Drives: Jet Black E90
Join Date: Aug 2012
Location: in the Napa Valley/SJ...

iTrader: (0)

Your car was just looking out for you and was trying to get your attention to keep it below 60mph.........





Just Kidding!
__________________
2007 Jet Black E90 328i
Thread: http://www.e90post.com/forums/showthread.php?t=825249
Instagram: manutd_as
Appreciate 0
      09-18-2012, 11:18 AM   #7
vapore0n
Lieutenant
4
Rep
470
Posts

 
Drives: 2010 335i
Join Date: Jul 2011
Location: MA

iTrader: (0)

My car had a low coolant light, which went away after a restart of the car.
Next day I get the service engine soon... damn it.

Got an appointment on Fri to check it out.
Any way I can read the code from the panel? I though there was a way to see this using the speedometer buttons etc.
Appreciate 0
      09-18-2012, 12:00 PM   #8
Tom K.
Major General
Tom K.'s Avatar
United_States
55
Rep
5,416
Posts

 
Drives: '07 328iT, '13 Boxster
Join Date: Mar 2008
Location: Maryland

iTrader: (0)

Happened to my 128i while on a vacation trip. Came on after about 3 hours cruising at 80 mph and stayed lit for two days. Then went off and my dealer found no codes by the time I got home about two weeks later.

I wouldn't worry about it.

Tom
Appreciate 0
      09-18-2012, 12:08 PM   #9
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,369
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Mine turned on a couple of weeks ago. Not sure what triggered it, micro filter due (which i already changed and reset light) DS mode stopped working (already fixed due only to some cut wires) Spark Plugs are due in 6k miles? Is there a way we can reset and turn OFF this Service Engine Soon light? Not sure
Appreciate 0
      09-18-2012, 08:16 PM   #10
chromisdesigns
Lieutenant Colonel
21
Rep
1,754
Posts

 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

iTrader: (0)

Did you leave your gas cap loose after filling the tank?
Appreciate 0
      09-19-2012, 12:22 PM   #11
Pharaoh2716
Private First Class
Pharaoh2716's Avatar
United_States
23
Rep
148
Posts

 
Drives: 2011 BMW 335i Coupe
Join Date: Oct 2010
Location: Bay Area, California

iTrader: (0)

Thanks for all the input guys. Gas cap was secure. Drove the car all yesterday without the light on.
__________________
Stage One N55 Burger Motorsports Tune
Appreciate 0
      10-21-2012, 12:06 AM   #12
edelossantos
EDS328i
edelossantos's Avatar
United_States
1
Rep
70
Posts

 
Drives: 2011 Space Gray 328i Coupe
Join Date: Aug 2010
Location: Irvine, CA

iTrader: (0)

SES Light

Well my CPO'd 07 335i has been at the dealer for the past week with a SES light that came on when I was on my to work early last week. They say there is a vacumn leak somewhere.

I had my oil changed last month and they also replaced both wastegates. Car was running fine until the SES light.

Let's hope they get my car fixed this week.
Appreciate 0
      10-23-2012, 10:15 PM   #13
edelossantos
EDS328i
edelossantos's Avatar
United_States
1
Rep
70
Posts

 
Drives: 2011 Space Gray 328i Coupe
Join Date: Aug 2010
Location: Irvine, CA

iTrader: (0)

Update on SES Light

Well, took my car in 10/16/12 and picked it this afternoon. After a week of diagnosis, they ended up doing a couple of things:

Replaced all fuel injectors

My car was running lean so they "smoked" the exhaust and found that both catalytic converter gaskets to be leaking. So they replaced the gaskets.

Afterward they test drove and found that the car was still running lean, so they "smoked" the intake and found that the intake manifold was leaking. Replaced all the gaskets.

Car appears to run fine now.
Appreciate 0
Reply

Bookmarks

Tags
328, 335, bmw, e90, e92

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:30 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST