E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > check engine light + ticking noise



Reply
 
Thread Tools Search this Thread
      05-27-2014, 08:56 PM   #1
ady9
Private
Australia
1
Rep
87
Posts

Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

iTrader: (0)

check engine light + ticking noise

hey guys i was driving on the freeway last night after about 50kms going at constant 100km/h I went over a few small bumps and the check engine light came on, it read "engine fault! reduced power" now prior to this I had warmed the car up before driving and i drove it like a granny, not once did i punch it (so tempted to though!!).

Now at this point i was shitting my dacks, so i baby-ed it home which was another 20kms, didnt really push it so i didnt notice any back fire, or rough idle, car didnt shake or anything else that was abnormal. turned off the car when i got home went inside to get a flash light and turned the car back on. check engine light is off and the message is gone. a bit of relief but what the hell happened ?

background info on the car

-2008 335i e92
-recently had major service done+safety check at souther bm
-new plugs and coil packs
-full tank of gas
-JB4 - map 1
-i had a mate who worked at bmw he said my injectors was a recall item so they were changed at some stage already
-i found out my battery is non amg so its not programmable but i think my model is meant to have one? this could cause faults in electric shit ?
-my positive battery cable campaign is a recall item but has yet to be changed - again can cause faults in electrical shit? will be organising a fix with bmw soon
-i occasionally get the "increase battery discharge" so maybe my battery is a problem

i did a and read a few things, some people say it could be misfiring etc but ive changed plugs and coil packs. read it could be HFPF which i hope its not, vanos solenoid or the carbon build up which will need walnut blasting. anyone in Australia can shed some light on the matter? ill be bringing to bmw or someone like worx automotive or southern bm to have it looked at but for the time being i want some peace of mind !

my other problem is a ticking noise coming from the engine bay, car sounds like a diesel (sorta).... quietens down when its warm but is still evident, and i can actuallly notice it in the car now if its really quite. ive read that its common - nothing to be worried about - had my bmw buddy have a look and he says its normal, and it could possibly the lifters?, its def no wastegate rattle. and i only noticed the ticking noise after i had changed the BMS DCI to a stock airbox for RWC - could i have knocked something for it to suddenly sound like this? or am i just being paranoid ?


basically i just wanna hear what people think to ease my paranoia but i will be bringing the car in for diagnostic testing, HPFP and water pump are on the list to have done but i only just recently bought the car and its bloody expensive to do.

Andy - apologize if its a most of my reading was from the states or uk

Last edited by ady9; 05-27-2014 at 09:09 PM.
Appreciate 0
      05-27-2014, 09:16 PM   #2
naynay
Admiral of the Fleet
Australia
41
Rep
821
Posts

Drives: 2006 E92 335i FBO
Join Date: May 2013
Location: Melbourne Australia

iTrader: (0)

HI ANDY
Appreciate 0
      05-27-2014, 09:22 PM   #3
naynay
Admiral of the Fleet
Australia
41
Rep
821
Posts

Drives: 2006 E92 335i FBO
Join Date: May 2013
Location: Melbourne Australia

iTrader: (0)

im planning to do a diy walnut blast.
Appreciate 0
      05-27-2014, 09:44 PM   #4
_ink
Major
_ink's Avatar
Australia
23
Rep
1,282
Posts

Drives: 335i 09' DCT M-Sport
Join Date: May 2012
Location: Sydney, Australia

iTrader: (0)

I'm guessing injectors here mate.

In the recall, they may have only changed the affected individual ones - not all of them.

There has been like 2-3 different revisions with the injectors, and it seems to be a pretty common problem.

When you try and start the car, what happens?
__________________
... Check out the garage
Appreciate 0
      05-28-2014, 12:22 AM   #5
ady9
Private
Australia
1
Rep
87
Posts

Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

iTrader: (0)

Quote:
Originally Posted by _ink View Post
I'm guessing injectors here mate.

In the recall, they may have only changed the affected individual ones - not all of them.

There has been like 2-3 different revisions with the injectors, and it seems to be a pretty common problem.

When you try and start the car, what happens?
ill chase that up to see if they were all replaced or not, cold start is obviously loud and quietens down after a few minutes - car sorta does sound like a diesel/tractor like (very minimal/moderate), initially loud then not as loud after its warm, it doesnt shake or throw any codes.

it seems normal but its just the sound that throws me off. ive booked with bmw to get the positive battery cable campaign replaced early in july and going into worx automotive to get a diagnostics test. I need to sus out if my JB4 has auto clear codes or not. ill see if i can upload a video of how it sounds when i get the chance.

EDIT: "injectors were either tested fine or changed if required and had a tick next to it marking that it had been cleared" quite possibly have the originals in there from the looks of things, cant confirm 100% anyone know how i can dig up information on the job? ill ask the tech when it goes in July.

Last edited by ady9; 05-28-2014 at 12:46 AM.
Appreciate 0
      05-28-2014, 12:59 AM   #6
_ink
Major
_ink's Avatar
Australia
23
Rep
1,282
Posts

Drives: 335i 09' DCT M-Sport
Join Date: May 2012
Location: Sydney, Australia

iTrader: (0)

hmmm, injectors usually give a lumpy cold start idle.

You need to get that CEL code.
__________________
... Check out the garage
Appreciate 0
      05-29-2014, 04:15 AM   #7
koohs1
Registered
0
Rep
2
Posts

Drives: 335
Join Date: May 2014
Location: Australia

iTrader: (0)

Buy a new car.
Appreciate 0
      06-03-2014, 06:34 AM   #8
ady9
Private
Australia
1
Rep
87
Posts

Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

iTrader: (0)

JB4 was on auto clear mode so the codes didnt come up on diagnostic testing. guys at worx had look at the ticking sound and confirmed it was normal and was just the injectors. recommended to go to them if your in melbourne ! will update if the CEL comes back on.

has anyone had experience with an Eisennman race or Bastuck axle back systems before ?
Appreciate 0
      06-05-2014, 09:39 AM   #9
fo55il
i was a terra thru da public school era ;)
Australia
23
Rep
850
Posts

Drives: 335i
Join Date: Jun 2013
Location: Melbourne Australia

iTrader: (0)

elaborate on this ticking sound? Like engine knocking ticking or stone stuck in tyre knocking?
Appreciate 0
      06-05-2014, 09:59 AM   #10
YA-91
Private First Class
YA-91's Avatar
1
Rep
104
Posts

Drives: 335i E93 Convertible
Join Date: Apr 2014
Location: Melbourne, Australia

iTrader: (0)

had the same thing today on the freeway. Engine light etc restarted the car and its fine now probe the HPFP

Now ticking noise thats interesting, I have some noise but its just the waste gate rattle nothing more would like to know what hrs is like.

Also with the exhaust I am about to purchase a Meisterchaft full system and have heard it in person before in my opinion one of the best sounds on the 335. Look it up and see for yourself
Appreciate 0
      06-05-2014, 09:26 PM   #11
ady9
Private
Australia
1
Rep
87
Posts

Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

iTrader: (0)

Quote:
Originally Posted by fo55il View Post
elaborate on this ticking sound? Like engine knocking ticking or stone stuck in tyre knocking?
sounds like a diesel (somewhat) to me it sounds like lifters like something is knocking on something. But steve at worx said its normal sounding engine and its the injectors that are making the ticking noise - being high flow type

Quote:
Originally Posted by YA-91 View Post
had the same thing today on the freeway. Engine light etc restarted the car and its fine now probe the HPFP

Now ticking noise thats interesting, I have some noise but its just the waste gate rattle nothing more would like to know what hrs is like.

Also with the exhaust I am about to purchase a Meisterchaft full system and have heard it in person before in my opinion one of the best sounds on the 335. Look it up and see for yourself

ive currently got an eisennman race axleback on, sounds pretty sweet at the moment and it has killer tips but not sure how it will sound when i put catless DPs, i dnt want it to loud and i defs dont want drone being an auto - ive read it will drone at 2/2.5k. ive also got a bastuck exhuast as well and ive heard so many good things. im stuck between the 2 and i dnt wanna spend 200 to get it installed each time to hear the difference
Appreciate 0
      06-05-2014, 11:30 PM   #12
naynay
Admiral of the Fleet
Australia
41
Rep
821
Posts

Drives: 2006 E92 335i FBO
Join Date: May 2013
Location: Melbourne Australia

iTrader: (0)

"
Whenever loud ticking is involved, the most likely source is the valvetrain, but the reason for that ticking isn’t always clear. Most cars use hydraulic valve lifters that rely on oil pressure to maintain a tight clearance between the camshaft and rocker arm. If the pressure isn’t right, there is play between the lifters and the rest of the valvetrain, which causes a noticeable tap. It’s possible that cold oil at startup may help pump up the lifters, but at normal temperatures the viscosity drops, and may be too thin to correctly work the lifters. As the oil breaks down after a few thousand miles it thickens, which eliminates the noise.

Mechanical issues may also be the cause. Double-check that you’re using the correct filter, and if you’re not, consider switching to the manufacturer-supplied part. The flow rate through a generic filter could be incorrect, creating insufficient engine oil pressure. The worst-case scenario is that your oil pump is slowly dying and you need a replacement. I hate to say it, but driving the vehicle this way for 20,000 miles hasn’t done the engine any favors. Get thee to a mechanic as soon as possible for proper diagnosis and remediation."
Appreciate 0
      06-06-2014, 12:51 AM   #13
cartaa100
Captain
cartaa100's Avatar
Australia
13
Rep
786
Posts

Drives: E92 335i M-Sport
Join Date: Jan 2012
Location: Sydney

iTrader: (0)

From youtube videos and my car I thought all n54s have a reasonably clicky sound.
__________________
Appreciate 0
      06-06-2014, 03:46 AM   #14
BMWX5driver
Private
BMWX5driver's Avatar
Australia
0
Rep
54
Posts

Drives: BMWX5
Join Date: Aug 2010
Location: Perth

iTrader: (0)

Quote:
Originally Posted by cartaa100 View Post
From youtube videos and my car I thought all n54s have a reasonably clicky sound.
You have to read the Fault codes first, all rest, just guessing
Appreciate 0
      06-06-2014, 09:54 AM   #15
cruvon
Lieutenant Colonel
30
Rep
1,543
Posts

Drives: E90
Join Date: Feb 2010
Location: Sydney, Australia

iTrader: (1)

Could be the ABS acting up? Not sure how the ABS is related to an engine fault but I had a similar issue that was fixed under factory warranty. Think they had to put a new ABS module in but yours could be something different.
__________________
Tiag E90 | JBSPEED Spli t t ers | JBSPEED ACS style Roof Spoiler | JBSPEED M3 style Trunk spoiler | Euro plates | K&N Intake | BMW OEM Performance Exhaust | Debadged | OEM Chromeline trim |230 OEM rims | 19" Michelin Pilot Sport PS2 Non runflats | OEM Burr Walnut Gear knob | OEM Blacklines | OEM Spacesaver |
Appreciate 0
      06-06-2014, 10:14 AM   #16
YA-91
Private First Class
YA-91's Avatar
1
Rep
104
Posts

Drives: 335i E93 Convertible
Join Date: Apr 2014
Location: Melbourne, Australia

iTrader: (0)

ive currently got an eisennman race axleback on, sounds pretty sweet at the moment and it has killer tips but not sure how it will sound when i put catless DPs, i dnt want it to loud and i defs dont want drone being an auto - ive read it will drone at 2/2.5k. ive also got a bastuck exhuast as well and ive heard so many good things. im stuck between the 2 and i dnt wanna spend 200 to get it installed each time to hear the difference[/quote]


Nice !

Yea there would be a bit of drone but not too bad, I personally want it LOUD love the sound also i have carless dp's and it gives it a good note I like it, not sure how it would be with an exhaust but I have to say I personally would want the dp's plus an exhaust.

Also you have 2 exhausts?? wanna give me one lol i would love to see how it sounds let me know if you are keen or parting with one of them also do you have a clip of the current exhaust I would love to hear it !!
Appreciate 0
      06-10-2014, 08:05 PM   #17
7smurfs
Lieutenant
7smurfs's Avatar
Australia
9
Rep
539
Posts

Drives: SGM 135i
Join Date: Apr 2014
Location: Melbourne

iTrader: (0)

Had very similar thing happen to my 135i N54.

Went WOT on launch, threw a CEL and it went into limp mode. My guess is either plugs, coils or injectors that caused a hopefully 'phantom misfire' - will take it to active motorwerke to check the codes.

Also... I similarly noticed a ticking sound at the engine that more or less sounded like a diesel. I'm pretty sure now that it's just us being paranoid and paying more closer attention to the engine whilst driving and at idle since the CEL was thrown.

I've even found myself turning off then music, winding down the windows to listen carefully heh. Been through a plethora of videos on youtube and I will put it down to it being normal!
Appreciate 0
      06-15-2014, 11:38 PM   #18
Testercles
Second Lieutenant
Testercles's Avatar
Australia
2
Rep
224
Posts

Drives: 2008 E90 335iA
Join Date: Apr 2014
Location: Adelaide

iTrader: (0)

Mine did the same thing the other day. Over the past week I have noticed it a lot more, a sort of diesel-ish ticking on cold starts. Threw a Engine Fault - Reduced Power! message about 10kms into a trip yesterday. I didn't feel anything different in the way that the car drove. Finished my trip, another 10kms, restarted and it was all good.
Are injectors and coil packs a labour intensive job?
Appreciate 0
      06-15-2014, 11:50 PM   #19
djpro1
Private First Class
djpro1's Avatar
Australia
2
Rep
141
Posts

Drives: 08 E93 335i
Join Date: Mar 2014
Location: Sydney, Pymble

iTrader: (0)

Quote:
Originally Posted by Testercles View Post
Mine did the same thing the other day. Over the past week I have noticed it a lot more, a sort of diesel-ish ticking on cold starts. Threw a Engine Fault - Reduced Power! message about 10kms into a trip yesterday. I didn't feel anything different in the way that the car drove. Finished my trip, another 10kms, restarted and it was all good.
Are injectors and coil packs a labour intensive job?
Coil packs are definitely not labour intensive. you could even DIY it with some youtube tutorials. It just requires you to take off a few bolts then lift the coil pack out and put a new one in.
Appreciate 0
      06-17-2014, 02:34 AM   #20
Testercles
Second Lieutenant
Testercles's Avatar
Australia
2
Rep
224
Posts

Drives: 2008 E90 335iA
Join Date: Apr 2014
Location: Adelaide

iTrader: (0)

Looked up online costs for 6 coils and 6 spark plugs and it seems that I could probably get away with it all for about $300 and borrow some tools from work on my RDO in that case, awesome.
Appreciate 0
      06-19-2014, 03:44 AM   #21
ady9
Private
Australia
1
Rep
87
Posts

Drives: 335i E92
Join Date: Feb 2014
Location: Melbourne

iTrader: (0)

Quote:
Originally Posted by YA-91 View Post
ive currently got an eisennman race axleback on, sounds pretty sweet at the moment and it has killer tips but not sure how it will sound when i put catless DPs, i dnt want it to loud and i defs dont want drone being an auto - ive read it will drone at 2/2.5k. ive also got a bastuck exhuast as well and ive heard so many good things. im stuck between the 2 and i dnt wanna spend 200 to get it installed each time to hear the difference


Nice !

Yea there would be a bit of drone but not too bad, I personally want it LOUD love the sound also i have carless dp's and it gives it a good note I like it, not sure how it would be with an exhaust but I have to say I personally would want the dp's plus an exhaust.

Also you have 2 exhausts?? wanna give me one lol i would love to see how it sounds let me know if you are keen or parting with one of them also do you have a clip of the current exhaust I would love to hear it !!
ill be selling one of my exhaust once i get enough money to buy DPs, and decide from the sound/drone. keep an eye out in the classifields ive got a clip of the eisennman race as is without DPs on a cold start if u wanna hear that ?

Quote:
Originally Posted by 7smurfs View Post
Had very similar thing happen to my 135i N54.

Went WOT on launch, threw a CEL and it went into limp mode. My guess is either plugs, coils or injectors that caused a hopefully 'phantom misfire' - will take it to active motorwerke to check the codes.

Also... I similarly noticed a ticking sound at the engine that more or less sounded like a diesel. I'm pretty sure now that it's just us being paranoid and paying more closer attention to the engine whilst driving and at idle since the CEL was thrown.

I've even found myself turning off then music, winding down the windows to listen carefully heh. Been through a plethora of videos on youtube and I will put it down to it being normal!
my jb4 was set to "auto clear codes" so i didnt end up finding out what caused the CEL. ive done a few WOT runs since and the CEL hasnt appeared so im pretty happy about that, ive been reading and have been told that our cars are really sensitive. and yea once something happens to your car you become more attenttive and really paranoid but our cars are meant to sound like that.

Quote:
Originally Posted by Testercles View Post
Looked up online costs for 6 coils and 6 spark plugs and it seems that I could probably get away with it all for about $300 and borrow some tools from work on my RDO in that case, awesome.
have you tried looking on ecstuning.com ?? they have pretty cheap parts on there. coil packs and plugs are cheap-ish but a new set of injectors can be up to 1k plus for parts alone
Appreciate 0
      06-19-2014, 04:37 AM   #22
YA-91
Private First Class
YA-91's Avatar
1
Rep
104
Posts

Drives: 335i E93 Convertible
Join Date: Apr 2014
Location: Melbourne, Australia

iTrader: (0)

Quote:
Originally Posted by ady9
Quote:
Originally Posted by YA-91 View Post
ive currently got an eisennman race axleback on, sounds pretty sweet at the moment and it has killer tips but not sure how it will sound when i put catless DPs, i dnt want it to loud and i defs dont want drone being an auto - ive read it will drone at 2/2.5k. ive also got a bastuck exhuast as well and ive heard so many good things. im stuck between the 2 and i dnt wanna spend 200 to get it installed each time to hear the difference


Nice !

Yea there would be a bit of drone but not too bad, I personally want it LOUD love the sound also i have carless dp's and it gives it a good note I like it, not sure how it would be with an exhaust but I have to say I personally would want the dp's plus an exhaust.

Also you have 2 exhausts?? wanna give me one lol i would love to see how it sounds let me know if you are keen or parting with one of them also do you have a clip of the current exhaust I would love to hear it !!
ill be selling one of my exhaust once i get enough money to buy DPs, and decide from the sound/drone. keep an eye out in the classifields ive got a clip of the eisennman race as is without DPs on a cold start if u wanna hear that ?

Quote:
Originally Posted by 7smurfs View Post
Had very similar thing happen to my 135i N54.

Went WOT on launch, threw a CEL and it went into limp mode. My guess is either plugs, coils or injectors that caused a hopefully 'phantom misfire' - will take it to active motorwerke to check the codes.

Also... I similarly noticed a ticking sound at the engine that more or less sounded like a diesel. I'm pretty sure now that it's just us being paranoid and paying more closer attention to the engine whilst driving and at idle since the CEL was thrown.

I've even found myself turning off then music, winding down the windows to listen carefully heh. Been through a plethora of videos on youtube and I will put it down to it being normal!
my jb4 was set to "auto clear codes" so i didnt end up finding out what caused the CEL. ive done a few WOT runs since and the CEL hasnt appeared so im pretty happy about that, ive been reading and have been told that our cars are really sensitive. and yea once something happens to your car you become more attenttive and really paranoid but our cars are meant to sound like that.

Quote:
Originally Posted by Testercles View Post
Looked up online costs for 6 coils and 6 spark plugs and it seems that I could probably get away with it all for about $300 and borrow some tools from work on my RDO in that case, awesome.
have you tried looking on ecstuning.com ?? they have pretty cheap parts on there. coil packs and plugs are cheap-ish but a new set of injectors can be up to 1k plus for parts alone
Yea man would love to hear it and very keen to grab it too if you wanna sell ASAP if I like the sound that's is
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:08 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST