E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Need help with issues from the last few days...



Reply
 
Thread Tools Search this Thread
      09-23-2012, 09:04 PM   #1
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Exclamation Need help with issues from the last few days...

So over the last few days i've ran into a few issues and although I have a decent idea on what to do to diagnose it, I wanted to see if anyone on here has had the same issue or can help me with what I should try first.

So basically i've ran E85 in the past but not as consistent as I have the last two weeks or so. Two weeks ago I threw in 8 gallons of E85, and the rest 93 octane. Everything was running great and the car was pulling extremely hard up until Thursday night. I'm going to do this sort of day by day cause I feel like that's the best way to organize it.

Thursday Night: So Thursday I was driving around and went to do a third gear pull but as soon as the car reached around 3k rpm and full boost it started jerking violently and wouldn't accelerate. I was close to where I was going so once I was there I let it sit for a while. When I got back in I did a 2nd gear pull and didn't really feel anything but as soon as I went to do the same 3rd gear pull the same thing happened. I put the car in the stock map and drove carefully until I was home to check codes. When I got home no codes were thrown so I just let the car sit and was hoping it was just a hiccup.

Friday: Car felt fine all day although I didn't do any third gear pulls or anything of that sort.

Saturday: I'm on the highway and do some Third gear pulls and everything feels good so I assume it fixed itself. I go to do a sixth gear pull just to see if my clutch is slipping and the car does the same Jerking/hesitating it did on Thursday but much worse. The SES light comes on and in any gear it jerks in any gear with any amount of throttle.

I pull off the highway and while i'm stopped waiting to turn into a lot there's a really rough idle and it feel like it might shut off at any minute. I restart it and everything is fine and idle is smooth so I put it in stock map and drive home carefully. Once I get home I checked for codes and the only out of the ordinary code was 29CF cylinder 3 misfire.

After that I decided to do some logs to send in to Terry and see what he has to say (those logs will be below). The first 4 runs are some quick 3rd gear pulls and the 5th run is a 6th gear pull. The only pulls that the car did the usual jerking were the 2nd and 5th run. Both gave me the SES light but the 6th gear felt much worse than the third. When I got home and checked for codes there were the following: 29CF cylinder 3 misfire, 30FF boost under target, 29CC misfirings, several cylinders, and 0000 failure location not implemented.

After Terry looked at the logs he basically said somethings wrong with either the injectors or coil packs so I should do the usual misfire diagnosing. I ruled out the spark plugs because they were just replaced 1.8k miles ago. I was planning on getting DP's, FMIC, and full brakes installed on Saturday so while i'm there i'll probably have the shop figure out what's wrong. Before doing that Terry suggested updating my firmware and lowering open loop to 70 which I did today but the car did the exact same thing.

I'm out of warranty so if something needs to be replaced i'm really hoping it doesn't wind up being that expensive. If it winds up being the coil pack or injector in cylinder 3 do I need to replace all 6, or can I just replace the cylinder 3? I'm at half a tank right now so tomorrow i'm going to fill up with 93 and see if that might solve it. I'm thinking maybe my car just doesn't like this much E85 although i've ran 7 gallons in the past with no issues.

I also forgot to add that it seems to do it worse when the engine is colder as oppose to hot. When the oil temps are above 200 it seems to do it much less frequently. Last night I did some pulls with my buddies STi from 3rd gear probably around 4-5k and it didn't misfire. Those were when my oil temps were around 240-250. Anyways I would appreciate any help anyone can provide.

Logs (ordered 1-5):









__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-23-2012, 09:26 PM   #2
E90Company
Major General
 
E90Company's Avatar
 
Drives: Car
Join Date: Mar 2012
Location: FL

Posts: 6,141
iTrader: (2)

It's a misfire, and explains your 6th gear pull, as well as restarting the car with the DME re-enabling that cylinder. Swap the coil to a different cylinder and see if it follows, and if so replace the coil. You don't need to replace all 6, but if you are above 50k and have the money, you might as well. I doubt it's the injector. Coils are 55$, so around $330 to replace all of them.

Milage? Ever have valve cleaning done or VANOS issues? What FMIC did you end up going with?
E90Company is offline   No_Country
0
Reply With Quote
      09-23-2012, 09:35 PM   #3
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by E90Company View Post
It's a misfire, and explains your 6th gear pull, as well as restarting the car with the DME re-enabling that cylinder. Swap the coil to a different cylinder and see if it follows, and if so replace the coil. You don't need to replace all 6, but if you are above 50k and have the money, you might as well. I doubt it's the injector. Coils are 55$, so around $330 to replace all of them.

Milage? Ever have valve cleaning done or VANOS issues? What FMIC did you end up going with?
Yea that does make sense I was just hoping someone on here might have had the same issue and it was a simple fix like changing a setting or running less E85. I'm going to have the shop do that on Saturday and for now i'll probably only replace what needs to be replaced cause I don't have the money to do all 6 at the moment .

51k miles, never had valve cleaning or VANOS issues although the previous owner might have but I doubt it. I probably should get a valve cleaning soon though because i'm sure the valves are extremely gunked up. I'm really want to wait for the 5 inch VRSF but I feel like I should just do the 7 inch and get it installed/shipped at the same time as downpipes. I don't need a 7 inch for the power i'm making but the cooler IAT's will be nice.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-23-2012, 09:35 PM   #4
bigdnno98
Major
 
bigdnno98's Avatar
 
Drives: 09 e92 335i MT
Join Date: Jul 2011
Location: Clarksville, TN

Posts: 1,143
iTrader: (7)

You're also running lean in the logs but I doubt that's your issue. That's something you need to address after you fix the misfire though. Maybe run less e85 and see if that stabilizes your AFR.
__________________
New Project....... 2.4L Long Rod motor for my EVO
03 Evo 8 HTA3582r Blown Motor
09 e92 335i MT Sold 440hp/480tq
bigdnno98 is offline  
0
Reply With Quote
      09-23-2012, 09:42 PM   #5
E90Company
Major General
 
E90Company's Avatar
 
Drives: Car
Join Date: Mar 2012
Location: FL

Posts: 6,141
iTrader: (2)

Quote:
Originally Posted by psmitty95 View Post
Yea that does make sense I was just hoping someone on here might have had the same issue and it was a simple fix like changing a setting or running less E85. I'm going to have the shop do that on Saturday and for now i'll probably only replace what needs to be replaced cause I don't have the money to do all 6 at the moment .

51k miles, never had valve cleaning or VANOS issues although the previous owner might have but I doubt it. I probably should get a valve cleaning soon though because i'm sure the valves are extremely gunked up. I'm really want to wait for the 5 inch VRSF but I feel like I should just do the 7 inch and get it installed/shipped at the same time as downpipes. I don't need a 7 inch for the power i'm making but the cooler IAT's will be nice.
You are running a bit lean, so use less of an E85 concentration to fix that. Also, before you replace anything, swap the coil just to be sure. WHen you are dealing with misfire issues, you should never assume. (just throwing that out there)

If you haven't had valve cleaning done yet, I would get on that sooner or later, because you should be doing around 35-40k. As far as the front mount, up to you. I think I will be going with a 7" just because of the heat/humidity we have here.
E90Company is offline   No_Country
0
Reply With Quote
      09-23-2012, 09:47 PM   #6
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by bigdnno98 View Post
You're also running lean in the logs but I doubt that's your issue. That's something you need to address after you fix the misfire though. Maybe run less e85 and see if that stabilizes your AFR.
That's exactly what I was hoping some people on here could help me with. I'm not the best at reading logs so that's really helpful. After I fix the misfire issues i'll probably run less E85.

Quote:
Originally Posted by E90Company View Post
You are running a bit lean, so use less of an E85 concentration to fix that. Also, before you replace anything, swap the coil just to be sure. WHen you are dealing with misfire issues, you should never assume. (just throwing that out there)

If you haven't had valve cleaning done yet, I would get on that sooner or later, because you should be doing around 35-40k. As far as the front mount, up to you. I think I will be going with a 7" just because of the heat/humidity we have here.
Yea i'll dfeinitely swap it first and see if that fixes the problem. I'm going to start looking around for a decent priced place to get the valve cleaning done. I don't even want to think about what they probably look like right now
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-24-2012, 10:07 PM   #7
JBax
Private First Class
 
JBax's Avatar
 
Drives: E90 335i
Join Date: May 2011
Location: Charlotte, NC

Posts: 170
iTrader: (2)

OP, let us know what you find. Def seems like coil issue.

i've seen 800+ hp single turbo cars running 5" intercoolers with no problems. i think you'll be fine with the 5" but hey its your $.
__________________
JB4, Alufelgen SF-71, DCI, VRSF DPs, Meth, AR Meth Elbow, AWE BOVs, Catless Exhaust, BMS OCC, ETS FMIC, ECS Strut Bar, ER Engine Cover, M Sport Steering Wheel Trim, LEDs, 20% Tint, Macht Schnell Spacers, ACS Roof Spoiler, ACS Pedals, ACS E-Brake Handle, Blacklines, M3 Steering Wheel w/DCT Paddles, Gunmetal Kidneys, Black Finisher Rods
JBax is offline   United_States
0
Reply With Quote
      09-24-2012, 10:15 PM   #8
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by JBax View Post
OP, let us know what you find. Def seems like coil issue.

i've seen 800+ hp single turbo cars running 5" intercoolers with no problems. i think you'll be fine with the 5" but hey its your $.
I really hope its a coil issue and not injectors. The shop i'm having do all the work is an hour away and i'm leaving my car their Saturday. Because of that I didn't want to have to leave it there until monday to wait for a new part so I went ahead and ordered a coil a few hours ago. If it winds up being a coil I will have one ready for them to replace, but if it's not i'll just return it and get a new injector. Really hoping its just a coil though...

I know I would be fine with a 5" but VRSF isn't coming out with theirs for another few weeks and I'm planning on having everything put on at once (this saturday). If their 5" was out I would hands down be getting that over the 7". I still might just wait it out then install the 5" myself, I just haven't really decided for sure yet.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-24-2012, 10:27 PM   #9
neilvosko
Major
 
neilvosko's Avatar
 
Drives: 335i e92 FBO
Join Date: Dec 2011
Location: miami

Posts: 1,398
iTrader: (16)

Run 25 to 33 percent e85, no more than 5 gallons
neilvosko is offline   United_States
0
Reply With Quote
      09-24-2012, 10:34 PM   #10
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by neilvosko View Post
Run 25 to 33 percent e85, no more than 5 gallons
That's what i used to do in the past when I started running E85 but saw people on here were running around 50/50 with good results. I have ran 50/50 in the past and had no issues except the car pulling like a beast but maybe I had too much this time.

Tomorrow i'm gonna throw in half a tank of 93 to balance it out and see if that helps at all.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-25-2012, 02:18 PM   #11
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

I don't know if this helps at all with figuring out wether its a coil or injector but i'm 90% sure it only happens at low RPMS. Example is I did a third gear pull from around 35 today and the car started misfiring. Right after I downshifted to 2nd which brought the RPM's up and the car pulled hard to redline as if nothing was wrong...
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-26-2012, 11:31 AM   #12
Daily Three
Lieutenant
 
Drives: 07 E90 335i 6MT
Join Date: Jul 2011
Location: United States

Posts: 584
iTrader: (6)

If you want to come over to Stamford I can at least swap the coil for you..
__________________
https://www.youtube.com/channel/UC_6...-_uPBNeipsA9lg watch

07 JB 335i 6MT JB4 G5/E85 Flash DCI HPF FMIC AR Catless DPs Milltek BMW Oil Cooler AR OCC 100% E85 Walbro E85 450 LPFP/392 inline 255/265 PSS M3 Sways M3 Rep Front CF M3 Hood
07 BSM 335xi 6MT JB4 G5/Pump Flash DCI CX FMIC KW V3 VRSF DP LCI Rear
Daily Three is offline  
0
Reply With Quote
      09-26-2012, 12:24 PM   #13
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by Daily Three View Post
If you want to come over to Stamford I can at least swap the coil for you..
I would take you up on that but I don't even have the coil yet. I'm just going to have the shop do it on Saturday cause it should be here by then.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-26-2012, 12:54 PM   #14
Daily Three
Lieutenant
 
Drives: 07 E90 335i 6MT
Join Date: Jul 2011
Location: United States

Posts: 584
iTrader: (6)

i just meant to swap it with another cylinder to see if the misfire moves.
__________________
https://www.youtube.com/channel/UC_6...-_uPBNeipsA9lg watch

07 JB 335i 6MT JB4 G5/E85 Flash DCI HPF FMIC AR Catless DPs Milltek BMW Oil Cooler AR OCC 100% E85 Walbro E85 450 LPFP/392 inline 255/265 PSS M3 Sways M3 Rep Front CF M3 Hood
07 BSM 335xi 6MT JB4 G5/Pump Flash DCI CX FMIC KW V3 VRSF DP LCI Rear
Daily Three is offline  
0
Reply With Quote
      09-26-2012, 12:56 PM   #15
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by Daily Three View Post
i just meant to swap it with another cylinder to see if the misfire moves.
Oh I see what you're saying. I might just try to do that myself today. It isn't that hard, right?
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-26-2012, 01:01 PM   #16
Daily Three
Lieutenant
 
Drives: 07 E90 335i 6MT
Join Date: Jul 2011
Location: United States

Posts: 584
iTrader: (6)

nope very simple, just offerring if you haven't/didn't want to do it. pop the engine cover off pull up the connecter locking mechanism on the cylinder 3 coil slide off the connector pull the coil out and swap it with a coil from bank 2.
__________________
https://www.youtube.com/channel/UC_6...-_uPBNeipsA9lg watch

07 JB 335i 6MT JB4 G5/E85 Flash DCI HPF FMIC AR Catless DPs Milltek BMW Oil Cooler AR OCC 100% E85 Walbro E85 450 LPFP/392 inline 255/265 PSS M3 Sways M3 Rep Front CF M3 Hood
07 BSM 335xi 6MT JB4 G5/Pump Flash DCI CX FMIC KW V3 VRSF DP LCI Rear
Daily Three is offline  
0
Reply With Quote
      09-26-2012, 01:06 PM   #17
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Quote:
Originally Posted by Daily Three View Post
nope very simple, just offerring if you haven't/didn't want to do it. pop the engine cover off pull up the connecter locking mechanism on the cylinder 3 coil slide off the connector pull the coil out and swap it with a coil from bank 2.
Wow sounds simple. I think i'm going to do it right now
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
      09-26-2012, 02:45 PM   #18
psmitty95
Brigadier General
 
psmitty95's Avatar
 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

Posts: 3,594
iTrader: (8)

Well, bad news .... I swapped the coils and the car is still misfiring in cylinder 3. I might go swap one more time just to make sure I didn't somehow leave them where they were but for now i'm assuming it's the injectors...
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: FBO + Meth JB4 ISO, BB flash, VRSF DP/FMIC, ER CP, Stett, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
psmitty95 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST