E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Is My iDrive Screen Dead?



Reply
 
Thread Tools Search this Thread
      09-27-2012, 06:59 AM   #1
Bimmer84
Guardian of the Night
 
Bimmer84's Avatar
 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

Posts: 1,826
iTrader: (5)

Garage List
2010 335i E92  [3.75]
Is My iDrive Screen Dead?

So I was driving today and noticed on two different occasions that when I would get in and start the car, I couldn't press down on the gas pedal at all, like it was stuck. Once I pressed start, it would release just fine, and had no issues with driving.

Anyway, my iDrive screen was fine on my seperate driving occasions, expect just a few minutes ago when I left the store, and started my car the screen turned completely orange. It wouldn't do anything else, it just stayed orange, and after about a minute, it would go black. Everything seems to work normal otherwise. Voice commands work, radio, CD, onboard music and all that. I tried using the voice commands to turn the display off and on again, but it just went back to orange and then would shut off.

I just hit 20k on my odometer this week.

I have included a picture, and I wrote the first part just for some strange reason it could be related.
Attached Images
 
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray
Bimmer84 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:12 AM   #2
Bimmer84
Guardian of the Night
 
Bimmer84's Avatar
 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

Posts: 1,826
iTrader: (5)

Garage List
2010 335i E92  [3.75]
Update: I let the car sit for a bit so everythig could shut off completely, and when I got back in it worked fine. Every screen worked, no pixilation issues or anything. So now the question is.. what the hell happened?
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray
Bimmer84 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:13 AM   #3
Sara504
Lieutenant General
 
Sara504's Avatar
 
Drives: 2013 335is
Join Date: Aug 2007
Location: Newport Beach, CA

Posts: 17,672
iTrader: (6)

Its telling you starbucks now has pumpkin spice lattes
__________________

2013 335is-Current
2011 335i -Sold 4/13 2006 325i-Sold 7/11
Sara504 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:15 AM   #4
Bimmer84
Guardian of the Night
 
Bimmer84's Avatar
 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

Posts: 1,826
iTrader: (5)

Garage List
2010 335i E92  [3.75]
Good call.. don't have one near me here in Germany.. looking forward to that when I get to San Antonio...
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray
Bimmer84 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:16 AM   #5
Sara504
Lieutenant General
 
Sara504's Avatar
 
Drives: 2013 335is
Join Date: Aug 2007
Location: Newport Beach, CA

Posts: 17,672
iTrader: (6)

Quote:
Originally Posted by Bimmer84 View Post
Good call.. don't have one near me here in Germany.. looking forward to that when I get to San Antonio...
No starbucks??????? They need to get on base asap.
__________________

2013 335is-Current
2011 335i -Sold 4/13 2006 325i-Sold 7/11
Sara504 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:19 AM   #6
Bimmer84
Guardian of the Night
 
Bimmer84's Avatar
 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

Posts: 1,826
iTrader: (5)

Garage List
2010 335i E92  [3.75]
Quote:
Originally Posted by Sara504 View Post
No starbucks??????? They need to get on base asap.
The major cities and airports are starting to get them, just none out by where I live... A lot of the German cafes are better anyway... they just don't have all the flavoured stuff like Starbuck's would.
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray
Bimmer84 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:23 AM   #7
Sara504
Lieutenant General
 
Sara504's Avatar
 
Drives: 2013 335is
Join Date: Aug 2007
Location: Newport Beach, CA

Posts: 17,672
iTrader: (6)

I'll have to ship you a bottle of syrup
__________________

2013 335is-Current
2011 335i -Sold 4/13 2006 325i-Sold 7/11
Sara504 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:29 AM   #8
Bimmer84
Guardian of the Night
 
Bimmer84's Avatar
 
Drives: 2010 335i M Sport Coupe
Join Date: Oct 2010
Location: San Antonio

Posts: 1,826
iTrader: (5)

Garage List
2010 335i E92  [3.75]
Quote:
Originally Posted by Sara504 View Post
I'll have to ship you a bottle of syrup
I'll be back stateside in December
__________________
2010 335i M Sport Coupe -- Black Sapphire Metallic|Coral Red|Loaded|JB4 Stage 3|BMS DCI|VRSF DPs|Camaross 6k AE|Performance Gloss Black Grilles|CF Performance Spoiler|CF Quad Diffuser|Double Layer Black Chrome Quad Tips|CF Roundels|Smoked Reflectors|Red Cyba Scoops|193s Painted Lamborghini Metallic Dark Gray
Bimmer84 is offline   United_States
0
Reply With Quote
      09-27-2012, 09:32 AM   #9
manny127
Private
 
Drives: 09 335i Coupe (E92)
Join Date: Jul 2009
Location: Mississauga

Posts: 59
iTrader: (3)

I had the exact same issue before, it should go back to normal next time you start the car, just let the car sit for some time. I showed the dealership a picture of the issue when it happened to me and they reinstalled the software on the car, haven't had an issue since.
manny127 is offline  
0
Reply With Quote
      09-27-2012, 03:21 PM   #10
jmarino21
Private First Class
 
Drives: 335i xDrive
Join Date: Aug 2011
Location: Cleveland, OH

Posts: 112
iTrader: (0)

Quote:
Originally Posted by Sara504 View Post
Its telling you starbucks now has pumpkin spice lattes
+1 or actually like +100
jmarino21 is offline   United_States
0
Reply With Quote
      09-27-2012, 05:39 PM   #11
ZTZ1010
Captain Planet
 
ZTZ1010's Avatar
 
Drives: 11' E92 ZCP M3
Join Date: Feb 2008
Location: CT

Posts: 1,062
iTrader: (8)

Garage List
2009 BMW 335i  [4.80]
2011 BMW M3  [0.00]
Send a message via AIM to ZTZ1010
Quote:
Originally Posted by Bimmer84 View Post
Update: I let the car sit for a bit so everythig could shut off completely, and when I got back in it worked fine. Every screen worked, no pixilation issues or anything. So now the question is.. what the hell happened?

exact same thing has happened to me twice. I just let the car sit and when i restarted everything was fine... no clue
__________________
2011.5 Alpine White E92 M3 | DCT w/ BPM Software | ZCP | CF Roof | CF Lip| Fully Coded | AFE Stage 2 Intake| ACM Exhaust | ACM Test Pipes | BPM Stage II Dev Tune | AA Pulleys | RPi Scoops | Swift Springs | LED Interior Lights| LUX V4 | Extended Aluminum DCT Paddles|
ZTZ1010 is offline   United_States
0
Reply With Quote
      09-27-2012, 10:59 PM   #12
drknight
Second Lieutenant
 
drknight's Avatar
 
Drives: 2010 328i
Join Date: Apr 2010
Location: San Francisco,CA

Posts: 221
iTrader: (5)

Garage List
2010 328i  [0.00]
This happened to me around the 10k mark. I left the car as is to go to work and when I came back it was gone. I'm at 24k miles and it hasn't happened since (knock on wood).
__________________
BMW Performance Exhaust | BMW Performance Intake | BMW Performance CF Strut Bar | BMW Performance Grilles | Vortex Tuning LM Reps | Michelin PSS | Gloss Black Interior Trim | M-Sport Wheel | ACS Pedals | Tint | Future Mods: AA Tune | Headers | Musicar Stage 2 Sound | Full M-Sport Kit | BMW Performance Brakes/Spoiler | Swift Springs | Koni Shocks |
drknight is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:20 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST