E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Jb4 map 5 shutting my car down!



Reply
 
Thread Tools Search this Thread
      09-25-2012, 10:07 AM   #1
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

Jb4 map 5 shutting my car down!

When I get to upper RPM's in 4th gear my car would shut down and the engine light popped on. The car would no longer accelerate and i had to turn it off and back on again in which it then performed back to normal. What happened to my car when it shut down and why ?
aph335i is offline  
0
Reply With Quote
      09-25-2012, 10:24 AM   #2
Bimmer305
Second Lieutenant
 
Bimmer305's Avatar
 
Drives: E92 335i
Join Date: Jun 2012
Location: Miami

Posts: 277
iTrader: (1)

Quote:
Originally Posted by aph335i View Post
When I get to upper RPM's in 4th gear my car would shut down and the engine light popped on. The car would no longer accelerate and i had to turn it off and back on again in which it then performed back to normal. What happened to my car when it shut down and why ?
Bookmark this page http://www.n54tech.com/forums/showthread.php?t=10605

Read: How do I read out and delete codes?

Make sure you have AUTO CODE CLEAR disabled.
__________________
Cobb / DCI / VRSF Downpipes / VRSF 7" Intercooler / Walbro LPFP / E85
Bimmer305 is offline  
0
Reply With Quote
      09-25-2012, 12:55 PM   #3
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

I had like 5 codes afterwards but i deleted them. If it happens again ill figure out which codes they are. Has anyone experienced a similar situation?
aph335i is offline  
0
Reply With Quote
      09-25-2012, 12:58 PM   #4
marv85
Colonel
 
marv85's Avatar
 
Drives: '07 335i MT
Join Date: Jun 2010
Location: Portland

Posts: 2,559
iTrader: (4)

no one can help you with no codes... Could be anything really.

Try to replicate and post the codes.
__________________
'10 E92 335i , COBB
marv85 is offline   United_States
0
Reply With Quote
      09-25-2012, 04:01 PM   #5
5soko
Brigadier General
 
5soko's Avatar
 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

Posts: 4,207
iTrader: (4)

Get the codes and everyone can help you again.. Try to do the same thing you were doing.. Sounds like a high speed WOT run.

Could be a common issue of the auto open fuel loop on the JB4 map5.. I would always get CEL/Limp mode at the end of 3rd into 4th. This cured m problem..

"In some cars the auto learning may not properly range open loop fueling, triggering false 29F2 fuel pressure codes, and you will need to set it manually. To do this first disable open loop learning by setting FutureUseA = 2. Then start with an open loop setting of 75. If you experience 29F2 codes lower the setting by 5 until they subside. If your fuel trims are stuck over 50, you experience run lean failsafe (2 SES flashes), or encounter frequent 2D25 tuner codes, increase the setting by 5 until they subside. If your high fuel pressure is consistently below 13 when open loop is 75% or higher you likely have a physical fuel pump problem. If you are unable to find a suitable setting to avoid both 29F2 and 2D25 codes you will need to reduce the alcohol content of your fuel (e.g. if mixing in E85 mix in less), lower the all map AFR settings to lean the air/fuel targets, or use a fixed boost map like 1 or 2."
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
5soko is offline   Montenegro
0
Reply With Quote
      09-25-2012, 04:07 PM   #6
ragingpanda
Lieutenant
 
Drives: 135i
Join Date: May 2012
Location: Florida

Posts: 497
iTrader: (0)

Switch to procede....
ragingpanda is offline  
0
Reply With Quote
      09-25-2012, 04:21 PM   #7
E90Company
Major General
 
E90Company's Avatar
 
Drives: Car
Join Date: Mar 2012
Location: FL

Posts: 6,141
iTrader: (2)

Quote:
Originally Posted by ragingpanda View Post
Switch to procede....
Let's not start a tuning battle. They are both great tunes.

OP, you need to read your codes like everyone else said.
E90Company is offline   No_Country
0
Reply With Quote
      09-25-2012, 04:32 PM   #8
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 16,401
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
Probably misfires, how many miles on the spark plugs?
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      09-25-2012, 05:32 PM   #9
JamesM3M5
Some dude
 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

Posts: 1,647
iTrader: (0)

Quote:
Originally Posted by ragingpanda View Post
Switch to procede....
Easy, big panda, no tune is immune to limp, CEL, or misfires, especially with the age and unknown maintenance history that these cars have on them. I have a hard enough time fixing stock 335s back to perfect running conditions.
JamesM3M5 is offline   United_States
0
Reply With Quote
      09-25-2012, 05:34 PM   #10
JamesM3M5
Some dude
 
Drives: E28 M5, E92 335i
Join Date: Sep 2011
Location: Northern VA

Posts: 1,647
iTrader: (0)

Quote:
Originally Posted by Jeff@topgearsolutions View Post
Probably misfires, how many miles on the spark plugs?
Was thinking the same. Bad plugs or a weak coil or two. Dirty intake, flaky injector, weak LPFP, who knows? Plugs are the cheapest and easiest thing to try, first.
__________________
RRT Racing
E92 335i/6MT Dinan Stage 3: intercooler, oil cooler, intake, flash, exhaust, LW dual-mass flywheel.
Vishnu PWM methanol custom trunk mount, Diffsonline 3-clutch Salisbury custom diff, Ohlins Road and Track coilovers, Vorshlag camber plates, much more...
E28 M5 w/ buncha stuff, R171 SLK350
JamesM3M5 is offline   United_States
0
Reply With Quote
      09-25-2012, 09:24 PM   #11
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

Ok it did it again and now I have codes and teh cars acting bad I have 2CFB and 2D09.
2CFB:

2CFB Throttle valve adaptation value
Error will cause a warning light
Error is currently present


2D09:
2D09 butterfly valve
Error will cause a warning light
Error is currently present

Now when I start the car, the RPMS jump up and down from 1k RPM straight to 2RPM and back and forth and back and forth and just keep doing it! the car goes "vroom vroom vroom vroom" with every jump and it just keeps going. its not driveable unless i restart car and then its fine but does it on random start ups now. ive tried resetting codes and everything.

Sounds like the butterfly valve option on the jb4 isnt working properly with my car

edit: car has 27.5K miles

I just went back out and took a vid of the start up issue. boy does this suck
heres the vid: http://tinypic.com/r/1zqq69w/6

Last edited by aph335i; 09-25-2012 at 09:36 PM.
aph335i is offline  
0
Reply With Quote
      09-25-2012, 09:35 PM   #12
Bimmer305
Second Lieutenant
 
Bimmer305's Avatar
 
Drives: E92 335i
Join Date: Jun 2012
Location: Miami

Posts: 277
iTrader: (1)

Quote:
Originally Posted by aph335i View Post
Ok it did it again and now I have codes and teh cars acting bad I have 2CFB and 2D09.
2CFB:

2CFB Throttle valve adaptation value
Error will cause a warning light
Error is currently present


2D09:
2D09 butterfly valve
Error will cause a warning light
Error is currently present

Now when I start the car, the RPMS jump up and down from 1k RPM straight to 2RPM and back and forth and back and forth and just keep doing it! the car goes "vroom vroom vroom vroom" with every jump and it just keeps going. its not driveable unless i restart car and then its fine but does it on random start ups now. ive tried resetting codes and everything.

Sounds like the butterfly valve option on the jb4 isnt working properly with my car

edit: car has 27.5K miles

I just went back out and took a vid of the start up issue. boy does this suck
heres the vid: http://tinypic.com/r/1zqq69w/6
Fix here:
http://www.e90post.com/forums/showth...highlight=2D09
__________________
Cobb / DCI / VRSF Downpipes / VRSF 7" Intercooler / Walbro LPFP / E85
Bimmer305 is offline  
0
Reply With Quote
      09-25-2012, 09:43 PM   #13
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

Quote:
Originally Posted by Bimmer305 View Post
the fix there was "throttle adaptation reset followed by a dme reset. " what is that and how do I do that?
aph335i is offline  
0
Reply With Quote
      09-25-2012, 09:54 PM   #14
07bmw335iguy
Second Lieutenant
 
Drives: 2007 BMW 335i Sedan
Join Date: Sep 2011
Location: South Carolina

Posts: 227
iTrader: (4)

try resetting the throttle valve by going out cut the cars electronics on not the car. Then hold the gas pedal for 25 seconds, this will reset the throttle body. Then cut the car on and see what happens. Not sure if this will do the trick but won't hurt either.
07bmw335iguy is offline   United_States
0
Reply With Quote
      09-26-2012, 06:23 AM   #15
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,323
iTrader: (86)

Quote:
Originally Posted by aph335i View Post
Ok it did it again and now I have codes and teh cars acting bad I have 2CFB and 2D09.
2CFB:

2CFB Throttle valve adaptation value
Error will cause a warning light
Error is currently present


2D09:
2D09 butterfly valve
Error will cause a warning light
Error is currently present

Now when I start the car, the RPMS jump up and down from 1k RPM straight to 2RPM and back and forth and back and forth and just keep doing it! the car goes "vroom vroom vroom vroom" with every jump and it just keeps going. its not driveable unless i restart car and then its fine but does it on random start ups now. ive tried resetting codes and everything.

Sounds like the butterfly valve option on the jb4 isnt working properly with my car

edit: car has 27.5K miles

I just went back out and took a vid of the start up issue. boy does this suck
heres the vid: http://tinypic.com/r/1zqq69w/6
Has nothing to do with the JB4 or tune. Your throttle body is defective or getting there and the DME flagged a fault for it.

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      09-26-2012, 09:05 AM   #16
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

Mike, when the car starts with that revving issue... I immediately go to the code delete option on jb4 and it stops. I dont know if that means it IS the jb4 or not? But this started with use of the jb4 in map 5.

Is it possible that using the jb4 had damaged my throttle body?
aph335i is offline  
0
Reply With Quote
      09-26-2012, 09:10 AM   #17
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,318
iTrader: (0)

Quote:
Originally Posted by aph335i View Post
Mike, when the car starts with that revving issue... I immediately go to the code delete option on jb4 and it stops. I dont know if that means it IS the jb4 or not? But this started with use of the jb4 in map 5.

Is it possible that using the jb4 had damaged my throttle body?
no... remove the jb and see what happens.
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      09-26-2012, 09:31 AM   #18
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

Well I'm not going to remove the jb4. I don't believe the jb4 itself is the issue.
aph335i is offline  
0
Reply With Quote
      09-26-2012, 09:57 AM   #19
5soko
Brigadier General
 
5soko's Avatar
 
Drives: M5
Join Date: Aug 2007
Location: Brooklyn, NY

Posts: 4,207
iTrader: (4)

Try commands 1, 7 in the steering wheel menu...
This enables adaption reset of the throttle. This should help your issue.

http://www.n54tech.com/forums/showthread.php?t=10605
__________________
Current: ///M5 LCI with Evolve and RPi mods
Previous: E92 335i ||| FBO Heavy modded E90 LCI M-Sport 335i
5soko is offline   Montenegro
0
Reply With Quote
      09-26-2012, 10:15 AM   #20
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

When I get off work today I will reset all codes and adaptions. I will try the throttle body reset, and then d/c battery for about 30 min. Ill see how things go from there. However, I won't touch map 5 until we can figure out why it's doing that
aph335i is offline  
0
Reply With Quote
      09-26-2012, 02:50 PM   #21
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

i reset everything and the car is fine. i took this video to get your opinions on if the car is running fine. this is stock with just a jb4 in map 1 and this is in 3rd gear. please let me know if everything is okay in terms of power and boost.

link to video http://tinypic.com/r/aon7th/6
aph335i is offline  
0
Reply With Quote
      10-05-2012, 08:34 PM   #22
aph335i
Banned
 
Drives: 2009 BMW 335i Coupe
Join Date: Sep 2012
Location: West Point, NY

Posts: 268
iTrader: (3)

This happened again and the code im getting is 29F2. any ideas? happens in any map but was in 4th gear everytime
aph335i is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST