E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > Internal fan not working



Reply
 
Thread Tools Search this Thread
      02-14-2013, 08:21 AM   #1
Greg330
Captain
 
Greg330's Avatar
 
Drives: E92 335i
Join Date: Mar 2012
Location: South Coast

Posts: 681
iTrader: (0)

Internal fan not working

Last night the fans gave up the ghost, up full with no air coming out. I had noticed that it had slowed down and speeded back up recently but thought it was to do when I came to a stop, bit like the wipers!

There seems to be well documented issues on the E46 but not much about the E92....

Any suggestions or similar experiences?
Greg330 is online now  
0
Reply With Quote
      02-14-2013, 10:59 AM   #2
A_P
Lieutenant Colonel
 
Drives: E46 M3
Join Date: Mar 2012
Location: South East

Posts: 1,698
iTrader: (0)

Greg Just because you have Cades apollo I will help you.

First things to check is Blown fuse for the AC unit. Then if this is ok. Dissconnect the battery for a few mins to see if anything resets.

Next is to plug in a diagnostics cable to see if your IHKA unit is faulty.

I will try and find a DIY for you for replacement. But only because of the Cades.
A_P is offline   United Kingdom
0
Reply With Quote
      02-14-2013, 11:02 AM   #3
A_P
Lieutenant Colonel
 
Drives: E46 M3
Join Date: Mar 2012
Location: South East

Posts: 1,698
iTrader: (0)

Here is a DIY for the HVAC unit But again only because you have....

http://www.e90post.com/forums/showthread.php?t=464807

LOL I had them for 3 years on my E90 they are now sitting in my garage and I must put them up for sale.

Best of luck mate.
A_P is offline   United Kingdom
0
Reply With Quote
      02-14-2013, 03:38 PM   #4
Greg330
Captain
 
Greg330's Avatar
 
Drives: E92 335i
Join Date: Mar 2012
Location: South Coast

Posts: 681
iTrader: (0)

A P you are a gent and a scholar!!
Greg330 is online now  
0
Reply With Quote
      02-14-2013, 04:30 PM   #5
Greg330
Captain
 
Greg330's Avatar
 
Drives: E92 335i
Join Date: Mar 2012
Location: South Coast

Posts: 681
iTrader: (0)

Just had a good read and I'll see if I can get it working with a bit of WD-40....

Regardless, its good to know how to replace rather than being bent over by a dealer!!
Greg330 is online now  
0
Reply With Quote
      02-15-2013, 07:35 AM   #6
A_P
Lieutenant Colonel
 
Drives: E46 M3
Join Date: Mar 2012
Location: South East

Posts: 1,698
iTrader: (0)

No worries mate. Hope you get it sorted.
A_P is offline   United Kingdom
0
Reply With Quote
      02-16-2013, 05:28 PM   #7
Greg330
Captain
 
Greg330's Avatar
 
Drives: E92 335i
Join Date: Mar 2012
Location: South Coast

Posts: 681
iTrader: (0)

Success!!

Took the bugger apart after faffing around with the fuses which indecently is the most ridiculous design Iíve ever seen. Iím convinced they make it harder to do DIY so you have to go to the dealers!

Anyway, got it apart and oiled up the fan and tested it and all is fine. Short term fix as it is probably the beginning of the end of the motor but can atleast source one for a reasonable price!

Thanks again A P!!
Greg330 is online now  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:02 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST