E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Broken Oxygen Sensor



Reply
 
Thread Tools Search this Thread
      10-11-2012, 01:45 PM   #1
bimmergixxer
Private First Class
 
bimmergixxer's Avatar
 
Drives: E90 SG
Join Date: Nov 2009
Location: GTA

Posts: 188
iTrader: (6)

Broken Oxygen Sensor

My car threw a code about a bad 02 sensor and while replacing it, I found the problem was to be a broken connector that got wet inside and rusted out. Does anyone have a Bank1 post cat 4 pin connector so I can plug in my new sensor or can I just cut both connectors off and attach the wires together? Thanks.
bimmergixxer is offline  
0
Reply With Quote
      10-11-2012, 02:12 PM   #2
Tzu
Major
 
Drives: 335i
Join Date: Jun 2010
Location: Toronto

Posts: 1,466
iTrader: (1)

The connector is used in the calibration of the sensor. People have spliced before and seem to be okay but I'd just buy a new O2 sensor.
Tzu is offline   Canada
0
Reply With Quote
      10-11-2012, 07:49 PM   #3
bimmergixxer
Private First Class
 
bimmergixxer's Avatar
 
Drives: E90 SG
Join Date: Nov 2009
Location: GTA

Posts: 188
iTrader: (6)

The connector for the sensor is fine and I have a new oxygen sensor but I am curious about the connector that connects to the 02 connector
bimmergixxer is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:33 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST