E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Broken Oxygen sensor connector



Reply
 
Thread Tools Search this Thread
      10-11-2012, 11:43 AM   #1
bimmergixxer
Private First Class
 
bimmergixxer's Avatar
 
Drives: E90 SG
Join Date: Nov 2009
Location: GTA

Posts: 186
iTrader: (6)

Broken Oxygen sensor connector

I was throwing a code for bank1 after cat and upon removing the connector, I noticed it was wet inside and that one of the four pins were broken (orange) with green slime everywhere Is there a quick fix for this or will the whole connector that holds 3 sensors need to be replaced?
bimmergixxer is offline  
0
Reply With Quote
      10-11-2012, 10:03 PM   #2
john_e90bimmer
Enlisted Member
 
Drives: Silver
Join Date: Dec 2009
Location: Illinois

Posts: 41
iTrader: (0)

If you own a soldering iron then splice a wire in to bypass that pin on the connector. If you don't know how to solder then replacing the harness may be better.
Have fun.
john_e90bimmer is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:04 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST